The following warnings occurred:
Warning [2] count(): Parameter must be an array or an object that implements Countable - Line: 906 - File: showthread.php PHP 7.2.34 (Linux)
File Line Function
/showthread.php 906 errorHandler->error



Thank you for your donation!


Instruction Guide AUDIOPHONICS RaspDAC Mini Kit - I-Sabre ES9038Q2M
#1

Couple of days ago I have ordered and received this latest kit from Audiophonics 

I is the new  AUDIOPHONICS RaspDAC Mini Kit - I-Saber ES9038Q2M

[Image: jaded_800.jpg]

[Image: raspdacmini_arri%C3%A8re.jpg]
[Image: 4Nn1dT.jpg][Image: jgrBI0.jpg]

[Image: vt2KPJ.jpg]

It supports payback up to 32bit 384kHz / DSD 128


Now I have this new DAC fully working with latest moOde thanks to a guys from Audiophonic @audiophonics  directly who provided an extended support and help me a lot
So I take no credits for any of this what so ever!

Here is how to enable DAC
(obsolete on moOde 5.x versions as driver is included in kernel)

Driver installation
Code:
sudo apt-get install minizip
cd /home/pi

wget https://github.com/audiophonics/Volumio2_I-sabre9028_plugin/raw/master/Q2M_kernel_4.14.71.zip
miniunzip Q2M_kernel_4.14.71.zip

cd Q2M

sudo cp i-sabre-codec.ko /lib/modules/4.14.72-v7+/kernel/sound/soc/codecs/
sudo cp i-sabre-k2m.ko /lib/modules/4.14.72-v7+/kernel/sound/soc/bcm/
sudo depmod -a
sudo cp i-sabre-k2m.dtbo /boot/overlays/

Now in Settings>Audio config select I2S audio device=Audiophonics ES9028 DAC and reboot system

To enable driver we need to add dtoverlay=i-sabre-k2m into /boot/config.txt
Code:
sudo nano /boot/config.txt

so it will look like this 
Code:
dtparam=i2s=on
dtparam=audio=off

dtoverlay=i-sabre-k2m
dtparam=spi=on
#dtoverlay=rpi-dac
#dtoverlay=pi3-disable-wifi
#dtoverlay=pi3-disable-bt

Make sure you have the rpi-dac commented out #

Now we can reboot system after which new driver should be in place. We can check by 

aplay -l 
Code:
pi@moode:~ $ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: DAC [I-Sabre K2M DAC], device 0: I-Sabre K2M DAC i-sabre-codec-dai-0 []
 Subdevices: 0/1
 Subdevice #0: subdevice #0

So with this you should be able to use Hardware volume control under 
Settings -> MPD -> Volume 


Making OLED working (SPI port)

Code:
sudo apt update
sudo apt-get -y install python-dev python-pip libfreetype6-dev libjpeg-dev python-smbus
sudo pip install -U pip
sudo -i pip install --upgrade pip setuptools
sudo -H pip install --upgrade luma.oled

add "spi-dev" to /etc/modules 
Code:
sudo nano /etc/modules
Code:
# /etc/modules: kernel modules to load at boot time.
#
# This file contains the names of kernel modules that should be loaded
# at boot time, one per line. Lines beginning with "#" are ignored.

spi-dev
CTRL+X > Y to save change 


add "dtparam=spi=on" to /boot/config.txt
Code:
sudo nano /boot/config.txt
Code:
disable_splash=1
hdmi_drive=2
dtparam=i2c_arm=on
dtparam=i2s=on
dtparam=audio=off

dtoverlay=i-sabre-k2m
dtparam=spi=on
#dtoverlay=rpi-dac
#dtoverlay=pi3-disable-wifi
#dtoverlay=pi3-disable-bt


Download attached file oled.zip. Unzip and extract 'oled' folder into /home/pi/

Now go into the directory
Code:
cd /home/pi/oled 
sudo chmod 755 /home/pi/oled/moode_oled_1.54_spi_audiophonics.py
sudo cp oled.service /etc/systemd/system/
sudo systemctl enable oled

Now all should be set and we can reboot after which we should have OLED display working


Remote control & SPDIF input 

First we need to install lirc 
Code:
sudo apt-get -y install lirc

Download lirc.zip file. Extract all the files and place them into /etc/lirc (replace the existing files)

Edit
Code:
sudo nano /etc/modules

and add 
Code:
lirc_dev
lirc_rpi gpio_in_pin=4
CTRL+X > Y to save change

Edit 
Code:
sudo nano /boot/config.txt

and add 
(for moOde versions 4.x)
Code:
dtoverlay=lirc-rpi,gpio_in_pin=4

(for moOde versions 5.x)
Code:
dtoverlay=gpio-ir,gpio_pin=4
CTRL+X > Y to save change

Edit
Code:
sudo nano /etc/rc.local

and add
Code:
/usr/bin/irexec -d /etc/lirc/lircrc
CTRL+X > Y to save change

Download spdif.sh and place it into /home/pi

Check your card number and make a note of it. In my case it was card 0
Code:
aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: DAC [I-Sabre K2M DAC], device 0: I-Sabre K2M DAC i-sabre-codec-dai-0 []
 Subdevices: 1/1
 Subdevice #0: subdevice #0
 

Edit your spdif.sh accordingly on all lines ( -c 0 )
Code:
#!/bin/bash
# Audiophonics
if [[ `amixer sget -c 0 'I2S/SPDIF Select' | grep Item0: | awk '{print $2}' ` =$

then amixer sset -c 0 'I2S/SPDIF Select' SPDIF

else amixer sset -c 0 'I2S/SPDIF Select' I2S

fi

Now we can reboot system after which your remote control should works and you should be able to use digital (SPDIF) input.
Remote control can operate 
  • Play/Pause
  • Next/Previous track from playlist (Left/Right) 
  • Vol Up/Down (Up/Down)
  • Stop (OK/Mid button)
  • SPDIF/Card (Menu button) 
[Image: FgIwob.jpg][Image: AgSe8a.jpg]
<marquee behavior="alternate" scrolldelay=150
[color=#ffcc33][font=Courier New][b][u][url=http://moodeaudio.org/forum/announcements.php?aid=1]~~~~>>>Please always follow rules and read before you post<<<~~~~
[/url][/u][/b][/font][/color]
</marquee>
Reply


Messages In This Thread
AUDIOPHONICS RaspDAC Mini Kit - I-Sabre ES9038Q2M - by rikardo1979 - 11-08-2018, 09:58 AM

Forum Jump: