Thank you for your donation!


NAS discovery
#4
(12-27-2018, 02:06 PM)Hiroyuki Wrote:
(12-27-2018, 01:56 PM)Tim Curtis Wrote: It looks like Samba discovery worked fine but name resolution for the host ODROIDXU4 failed. This is typically due to some sort of network or NAS configuration issue.

When you run the cmd below on the Pi does it return the IP address of the NAS?
Code:
ping ODROIDXU4

here's the PING results both with/without local
pi@moode:~ $ ping odroidxu4
ping: odroidxu4: Name or service not known
pi@moode:~ $
pi@moode:~ $ ping odroidxu4.local
PING odroidxu4.local (192.168.0.64) 56(84) bytes of data.
64 bytes from 192.168.0.64 (192.168.0.64): icmp_seq=1 ttl=64 time=6.48 ms
64 bytes from 192.168.0.64 (192.168.0.64): icmp_seq=2 ttl=64 time=7.35 ms
64 bytes from 192.168.0.64 (192.168.0.64): icmp_seq=3 ttl=64 time=6.96 ms
64 bytes from 192.168.0.64 (192.168.0.64): icmp_seq=4 ttl=64 time=2.59 ms
64 bytes from 192.168.0.64 (192.168.0.64): icmp_seq=5 ttl=64 time=5.94 ms

This is a problem with your LAN's DNS service. It's not providing the IP address that corresponds to the hostname "odroidxu4". When you add ".local" to the hostname you are switching from DNS to mDNS which handles hostname resolution differently.

Regards,
Kent
Reply


Messages In This Thread
NAS discovery - by Hiroyuki - 12-27-2018, 01:37 PM
RE: NAS discovery - by Tim Curtis - 12-27-2018, 01:56 PM
RE: NAS discovery - by Hiroyuki - 12-27-2018, 02:06 PM
RE: NAS discovery - by TheOldPresbyope - 12-27-2018, 02:23 PM
RE: NAS discovery - by Hiroyuki - 12-27-2018, 02:39 PM
RE: NAS discovery - by TheOldPresbyope - 12-27-2018, 03:23 PM
RE: NAS discovery - by Hiroyuki - 01-02-2019, 01:26 PM
RE: NAS discovery - by Onionhead - 01-02-2019, 05:54 PM

Forum Jump: