Thank you for your donation!


Official moOde 7.2.1 support thread
#71
Tapping on ‘Filtered by ...’ is documented in Quick Help - always worth reading thoroughly.

Regards,
Geoff
Reply
#72
(05-31-2021, 08:28 AM)John Glenn Wrote: Problem after update
Music is played randomly instead of 1 to 10.
How do I solve that

???   do you have any auto-shuffle, Random-play turned on ??   Wink 
Look at the main menu Quick Help to check..

Otherwise post the output from...

Code:
moodeutl -l

Reply
#73
(05-31-2021, 08:15 PM)Onionhead Wrote:
(05-31-2021, 02:15 PM)Tim Curtis Wrote: Tap the title for example if I searched for Adele the title would be "Filtered by any: Adele"

Your response came before I got back to my puter to make the donation (since rectified). I searched for Adele, now there are 4 albums my screen. So was struggling to get back to the view which has all albums in library not just Adele. I have tried restarting / shutdown that has no effect. Finally, by tapping on the phrase " Filtered by Advance search"  brought back the view of all albums. Must be one of those undocumented features or dumbass luck Dodgy

Not  undocumented but a little obscure... but as Tim advised it has worked.... Wink 

At the top of the window, where it shows "Filtered by any:xxxxxx", just tap or click on that and it reverts to "Filtered by :all"  so the whole library is again available. Cool

@GStevens  beat me to it... Cool

Reply
#74
(05-18-2021, 08:08 PM)Tim Curtis Wrote: Do you have ALSA loopback ON?

Hi Tim,

I do not have ALSO loopback ON, but still no AirPlay nor Spotify. MPD works fine.
It all changed when I updated to the latest version.
I also have a USB DAC connected to my Pi.

Is there a workaround while waiting for the next update?
Thanks,
Reply
#75
(06-01-2021, 07:21 AM)DRONE7 Wrote:
(05-31-2021, 08:28 AM)John Glenn Wrote: Problem after update
Music is played randomly instead of 1 to 10.
How do I solve that

???   do you have any auto-shuffle, Random-play turned on ??   Wink 
Look at the main menu Quick Help to check..

Otherwise post the output from...

Code:
moodeutl -l
Reply
#76
(06-01-2021, 10:34 AM)John Glenn Wrote:
(06-01-2021, 07:21 AM)DRONE7 Wrote:
(05-31-2021, 08:28 AM)John Glenn Wrote: Problem after update
Music is played randomly instead of 1 to 10.
How do I solve that

???   do you have any auto-shuffle, Random-play turned on ??   Wink 
Look at the main menu Quick Help to check..

Otherwise post the output from...

Code:
moodeutl -l
Checked everything and problem persisted.
Reinstalled Moode and problem went away.
So probably a corrupt sd card replace it with a new one.
Thank you very much for support
Reply
#77
Hi Tim,

greetings from Germany  Smile
Unfortunately after updating from 7.2.0 to 7.2.1, I have no audio output anymore. Failure message is "Failed to open ALSA device "_audioout": No such file or directory".
Audio device here is an IQaudIO Pi-DigiAMP+ which had worked flawlessly for months.
In a first attempt I switched the audio device to "None" and after a reboot back to "IQaudIO Pi-DigiAMP+", but that wasn't helpful.
After that I switched the option "ALSA loopback" to "ON", the failure message went away, but still no audio output.

Here are the outputs with ALSA loopback = OFF

Code:
root@moodeDG:~# moodeutl -t
0210601 144632 worker: USB volume knob (Off)
20210601 144632 worker: USB auto-mounter (udisks-glue)
20210601 144632 worker: LED0 (Off)
20210601 144632 worker: LED1 (Off)
20210601 144632 worker: Saved MPD vol level (0)
20210601 144632 worker: Preamp volume level (0)
20210601 144632 worker: MPD volume level (0) restored
20210601 144632 worker: ALSA Digital volume (Invalid card number.)
20210601 144632 worker: Auto-play (Off)
20210601 144632 worker: Maintenance interval (3 hours)
20210601 144632 worker: Screen saver activation (Never)
20210601 144632 worker: Session permissions (OK)
20210601 144635 worker: Watchdog started
20210601 144635 worker: Ready
20210601 151920 waitWorker(): Start (sys-config, w_active=0)
20210601 151920 waitWorker(): End   (sys-config, w_active=0)
20210601 151925 waitWorker(): Start (sys-config, w_active=0)
20210601 151925 waitWorker(): End   (sys-config, w_active=0)
20210601 152605 waitWorker(): Start (snd-config, w_active=0)
20210601 152605 waitWorker(): End   (snd-config, w_active=0)

root@moodeDG:~# cat /etc/alsa/conf.d/_audioout.conf
pcm._audioout {
type copy
slave.pcm "_deviceout"
}
root@moodeDG:~# cat /etc/alsa/conf.d/_deviceout.conf
pcm._deviceout {
type copy
slave.pcm "plughw:0,0"
}
root@moodeDG:~# cat /etc/alsa/conf.d/_sndaloop.conf
#
# This file provides a default Loopback device by overriding the _audioout device defined in /etc/alsa/conf.d/
#
# The trailing underscores are removed/added by job "alsa_loopback" to effectively turn the override On/Off.
# This job is submitted by snd-config.php and corresponds to the setting "ALSA loopback ON/OFF".
#
pcm.!_audioout__ {
   type route
   slave.pcm {
       type multi
       slaves {
           a { channels 2 pcm "_deviceout" }       # Original output
           b { channels 2 pcm "hw:Loopback,0" }    # Loopback output
       }
       bindings {
           0 { slave a channel 0 }
           1 { slave a channel 1 }
           2 { slave b channel 0 }
           3 { slave b channel 1 }
       }
   }
   ttable [
       [ 1 0 1 0 ]   # left  -> a.left,  b.left
       [ 0 1 0 1 ]   # right -> a.right, b.right
   ]
}
root@moodeDG:~# lsmod | grep snd_aloop

root@moodeDG:~# cat /etc/mpd.conf
#########################################
# This file is automatically generated
# by the MPD configuration page.
#########################################

music_directory "/var/lib/mpd/music"
playlist_directory "/var/lib/mpd/playlists"
db_file "/var/lib/mpd/database"
log_file "/var/log/mpd/log"
pid_file "/var/run/mpd/pid"
state_file "/var/lib/mpd/state"
sticker_file "/var/lib/mpd/sticker.sql"
user "mpd"
group "audio"
bind_to_address "any"
port "6600"
log_level "default"
restore_paused "yes"
auto_update "no"
follow_outside_symlinks "yes"
follow_inside_symlinks "yes"
zeroconf_enabled "no"
zeroconf_name "Moode MPD"
filesystem_charset "UTF-8"
metadata_to_use "+comment"
replaygain "off"
replaygain_preamp "0"
volume_normalization "no"
audio_buffer_size "65536"
max_output_buffer_size "131072"
max_playlist_length "16384"
max_connections "128"

decoder {
plugin "ffmpeg"
enabled "yes"
}

input {
plugin "curl"
}

resampler {
plugin "soxr"
quality "high"
threads "1"
}

audio_output {
type "alsa"
name "ALSA Default"
device "_audioout"
mixer_type "software"
dop "no"
}

audio_output {
type "alsa"
name "ALSA Bluetooth"
device "btstream"
mixer_type "software"
}

audio_output {
type "httpd"
name "HTTP Server"
port "8000"
encoder "lame"
bitrate "320"
tags "yes"
always_on "yes"
}

Here are the outputs with ALSA loopback = ON

Code:
root@moodeDG:~# moodeutl -t
51920 waitWorker(): End   (sys-config, w_active=0)
20210601 151925 waitWorker(): Start (sys-config, w_active=0)
20210601 151925 waitWorker(): End   (sys-config, w_active=0)
20210601 152605 waitWorker(): Start (snd-config, w_active=0)
20210601 152605 waitWorker(): End   (snd-config, w_active=0)
20210601 153444 waitWorker(): Start (snd-config, w_active=0)
20210601 153445 waitWorker(): End   (snd-config, w_active=0)
20210601 153450 waitWorker(): Start (chp-config, w_active=0)
20210601 153450 waitWorker(): End   (chp-config, w_active=0)
20210601 153457 waitWorker(): Start (snd-config, w_active=0)
20210601 153457 waitWorker(): End   (snd-config, w_active=0)
20210601 153505 waitWorker(): Start (snd-config, w_active=1)
20210601 153506 worker: Job alsa_loopback
20210601 153507 watchdog: Error: MPD restarted (check syslog for errors)
20210601 153508 openMpdSocket(): error: connection failed (1) 111, Connection refused
20210601 153509 waitWorker(): Wait  (1)
20210601 153509 waitWorker(): End   (snd-config, w_active=0)

root@moodeDG:~# cat /etc/alsa/conf.d/_audioout.conf
pcm._audioout {
type copy
slave.pcm "_deviceout"
}

root@moodeDG:~# cat /etc/alsa/conf.d/_deviceout.conf
pcm._deviceout {
type copy
slave.pcm "plughw:0,0"
}

root@moodeDG:~# cat /etc/alsa/conf.d/_sndaloop.conf
#
# This file provides a default Loopback device by overriding the _audioout device defined in /etc/alsa/conf.d/
#
# The trailing underscores are removed/added by job "alsa_loopback" to effectively turn the override On/Off.
# This job is submitted by snd-config.php and corresponds to the setting "ALSA loopback ON/OFF".
#
pcm.!_audioout {
   type route
   slave.pcm {
       type multi
       slaves {
           a { channels 2 pcm "_deviceout" }       # Original output
           b { channels 2 pcm "hw:Loopback,0" }    # Loopback output
       }
       bindings {
           0 { slave a channel 0 }
           1 { slave a channel 1 }
           2 { slave b channel 0 }
           3 { slave b channel 1 }
       }
   }
   ttable [
       [ 1 0 1 0 ]   # left  -> a.left,  b.left
       [ 0 1 0 1 ]   # right -> a.right, b.right
   ]
}

root@moodeDG:~# cat /etc/mpd.conf
#########################################
# This file is automatically generated
# by the MPD configuration page.
#########################################

music_directory "/var/lib/mpd/music"
playlist_directory "/var/lib/mpd/playlists"
db_file "/var/lib/mpd/database"
log_file "/var/log/mpd/log"
pid_file "/var/run/mpd/pid"
state_file "/var/lib/mpd/state"
sticker_file "/var/lib/mpd/sticker.sql"
user "mpd"
group "audio"
bind_to_address "any"
port "6600"
log_level "default"
restore_paused "yes"
auto_update "no"
follow_outside_symlinks "yes"
follow_inside_symlinks "yes"
zeroconf_enabled "no"
zeroconf_name "Moode MPD"
filesystem_charset "UTF-8"
metadata_to_use "+comment"
replaygain "off"
replaygain_preamp "0"
volume_normalization "no"
audio_buffer_size "65536"
max_output_buffer_size "131072"
max_playlist_length "16384"
max_connections "128"

decoder {
plugin "ffmpeg"
enabled "yes"
}

input {
plugin "curl"
}

resampler {
plugin "soxr"
quality "high"
threads "1"
}

audio_output {
type "alsa"
name "ALSA Default"
device "_audioout"
mixer_type "software"
dop "no"
}

audio_output {
type "alsa"
name "ALSA Bluetooth"
device "btstream"
mixer_type "software"
}

audio_output {
type "httpd"
name "HTTP Server"
port "8000"
encoder "lame"
bitrate "320"
tags "yes"
always_on "yes"
}

This the current content of the moode.log

Code:
20210602 085501 worker: Host     (moodeDG)
20210602 085501 worker: moOde    (7.2.1 2021-05-06)
20210602 085501 worker: RaspiOS  (10.6)
20210602 085501 worker: Kernel   (5.4.77-v7+ #1371)
20210602 085501 worker: Platform (Pi-3B 1.2 1GB)
20210602 085501 worker: ARM arch (armv7l, 32-bit kernel)
20210602 085501 worker: MPD ver  (0.22.6_p0x3)
20210602 085501 worker: CPU gov  (ondemand)
20210602 085501 worker: USB boot enabled
20210602 085502 worker: File system expanded
20210602 085503 worker: HDMI port on
20210602 085503 worker: -- Network
20210602 085503 worker: eth0 exists
20210602 085503 worker: eth0 wait 0 for IP address
20210602 085506 worker: eth0 wait 1 for IP address
20210602 085509 worker: eth0 wait 2 for IP address
20210602 085512 worker: eth0 wait 3 for IP address
20210602 085515 worker: eth0 wait 4 for IP address
20210602 085518 worker: eth0 address not assigned
20210602 085518 worker: wlan0 exists
20210602 085518 worker: wifi country (DE)
20210602 085518 worker: wlan0 trying SSID (HasiNetIoT)
20210602 085518 worker: IP addr (192.168.2.30)
20210602 085518 worker: Netmask (255.255.255.0)
20210602 085518 worker: Gateway (192.168.2.1)
20210602 085518 worker: Pri DNS (192.168.2.1)
20210602 085518 worker: Domain  (192.168.2.5)
20210602 085520 worker: Pi integrated wlan0 power save disabled
20210602 085520 worker: -- Audio config
20210602 085520 worker: MPD conf updated
20210602 085520 worker: IQaudIO Pi-DigiAMP+ unmuted
20210602 085520 worker: ALSA card number (0)
20210602 085520 worker: MPD audio output (IQaudIO Pi-DigiAMP+)
20210602 085520 worker: WARNING: No device found at MPD configured card 0
20210602 085520 worker: ALSA mixer name (Digital)
20210602 085520 worker: MPD volume control (software)
20210602 085520 worker: Hdwr volume controller exists
20210602 085520 worker: Max ALSA volume (100%)
20210602 085521 worker: ALSA loopback (On)
20210602 085521 worker: Reset renderer active flags
20210602 085521 worker: CamillaDSP (off)
20210602 085521 worker: -- MPD startup
20210602 085521 worker: MPD started
20210602 085521 openMpdSocket(): error: connection failed (1) 111, Connection refused
20210602 085521 worker: MPD accepting connections
20210602 085521 worker: MPD output 1 ALSA Default (on)
20210602 085521 worker: MPD output 2 ALSA Bluetooth (off)
20210602 085521 worker: MPD output 3 HTTP Server (off)
20210602 085521 worker: MPD crossfade (off)
20210602 085521 worker: MPD ignore CUE files (yes)
20210602 085521 worker: -- Feature availability
20210602 085521 worker: Source select (available)
20210602 085521 worker: Source select (source: MPD)
20210602 085521 worker: Source select (output: IQaudIO Pi-DigiAMP+)
20210602 085521 worker: Bluetooth (available)
20210602 085521 worker: Airplay renderer (available)
20210602 085521 worker: Spotify renderer (available)
20210602 085521 worker: Squeezelite (available)
20210602 085521 worker: RoonBridge renderer (not installed)
20210602 085521 worker: UPnP renderer (available)
20210602 085521 worker: DLNA server (available)
20210602 085521 worker: UPnP browser (available)
20210602 085521 worker: GPIO button handler (available)
20210602 085521 worker: Stream recorder (n/a)
20210602 085521 worker: -- Music sources
20210602 085521 worker: USB source (boot)
20210602 085521 worker: USB source (cdrips)
20210602 085521 worker: USB source (moodeDGclone)
20210602 085521 worker: USB source (mount)
20210602 085521 worker: USB source (music)
20210602 085521 worker: NAS and UPnP sources (none configured)
20210602 085521 worker: -- Other
20210602 085521 worker: USB volume knob (Off)
20210602 085521 worker: USB auto-mounter (udisks-glue)
20210602 085521 worker: LED0 (Off)
20210602 085521 worker: LED1 (Off)
20210602 085521 worker: Saved MPD vol level (0)
20210602 085521 worker: Preamp volume level (0)
20210602 085522 worker: MPD volume level (0) restored
20210602 085522 worker: ALSA Digital volume (amixer: Unable to find simple control 'Digital',0)
20210602 085522 worker: Auto-play (Off)
20210602 085522 worker: Maintenance interval (3 hours)
20210602 085522 worker: Screen saver activation (Never)
20210602 085522 worker: Session permissions (OK)
20210602 085522 worker: Watchdog started
20210602 085522 worker: Ready
20210602 085624 waitWorker(): Start (mpd-config, w_active=0)
20210602 085624 waitWorker(): End   (mpd-config, w_active=0)
20210602 085639 waitWorker(): Start (sys-config, w_active=0)
20210602 085639 waitWorker(): End   (sys-config, w_active=0)
20210602 085647 waitWorker(): Start (sys-config, w_active=0)
20210602 085647 waitWorker(): End   (sys-config, w_active=0)
20210602 085704 waitWorker(): Start (snd-config, w_active=0)
20210602 085704 waitWorker(): End   (snd-config, w_active=0)
20210602 085713 waitWorker(): Start (snd-config, w_active=0)
20210602 085713 waitWorker(): End   (snd-config, w_active=0)

Is there a way to repair my current Moode installation or have I to wait for the release 7.2.30 ?
I don't want to start with a fresh installation because I made some "customizing" like the installation of cd-rip and other tools.

Thanks and kind regards,
Steve
Reply
#78
The log entry below indicates Linux did not find any audio device.

Code:
20210602 085520 worker: WARNING: No device found at MPD configured card 0

That condition occurs before moOde starts so I would try to resolve that first. Check /boot/config.txt for the presence of the lines below.

Code:
dtparam=i2s=on
dtparam=audio=off
dtoverlay=iqaudio-dacplus

Then maybe try unplugging the USB devices, reseating the IQaudIO board and then poweroff/on. Then run the command below. It should list the iqaudio device. If not then there is some unknown breakage

Code:
aplay -l
Enjoy the Music!
moodeaudio.org | Mastodon Feed | GitHub
Reply
#79
a great and very fast help, the problem is solved. The file /boot/config.txt was completely empty, strange ...

Thanks for your work on Moode Audio !
Reply
#80
(06-02-2021, 11:57 AM)SteveFriday Wrote: a great and very fast help, the problem is solved. The file /boot/config.txt was completely empty, strange ...

Thanks for your work on Moode Audio !

I had the same problem with one. of my Moode boxes after updating to 7.2.1 from 7.2.0. Not sure what in the update process is trashing config.txt for some users.

Phil

Reply


Forum Jump: