Thank you for your donation!

Cloudsmith graciously provides open-source package management and distribution for our project.

Solved: Spotify renderer not working on rpi zero

You can follow the issue I just posted on liberespot-org repo.

Enjoy the Music! | Mastodon Feed | GitHub
I can confirm that librespot has to be compiled directly on armv6l architecture (Pi-1B, Zero, ZeroW) or cross-compiled for armv6l target in order to generate the correct binary.
Enjoy the Music! | Mastodon Feed | GitHub
Yes I saw that.

And I, incorrectly, assumed that building on the rpi0w would resolve this issue but it did not. Since I have the ethernet usb dongle now I tried your build process on a fresh raspbian image. Completed without error but still get the librespot "Illegal instruction" error.

Am unsure how to proceed to rebuild/compile librespot on here correctly.
I just built it today on a 0W and it works perfectly, but took many hours to compile on the little Pi. I just ran the procedure in COMPONENT 4B of the Build Recipe except I used the specific commit (a4e0f58) of librespot thats used in moOde 4.3.
Enjoy the Music! | Mastodon Feed | GitHub
Sorry for my ignorance, but I do not know what you mean by procedure in the build recipe.
The Build Recipe is located in Moode Git repo in /other/build

The librespot sources zip is located in /other/librespot
Enjoy the Music! | Mastodon Feed | GitHub
Ok, so I do the following (forgive me, I literally know nothing about git)

sudo apt-get -y install portaudio19-dev

cd ~
git clone
curl -sSf | sh
# choose 1

sudo reboot

cd librespot/
cargo build --release --features alsa-backend

sudo cp target/release/librespot /usr/local/bin
cd ~
sudo rm -rf librespot

Except at the clone line I use your commit? But git clone on any of those addresses doesn't work. I ended up downloading the zip and extracting it manually to ~/librespot and did the rust installation and then rebooted and then "cargo build --release --features alsa-backend"

Now it is building I assume. Your main build (when manually building from fresh raspbian) is using a precompiled version of librespot?
359m 55s to compile!

But it is working now! Yay!

root@MusicBox:~# pgrep -l librespot
723 librespot
But Spotify still doesn't see it in the connect menu Sad


Works on my phone and a different computer. So its specific to this machine. Hunting that down now.


Got it working! Did a bunch of stuff and it still wasn't working but then realized the renderer stopped responding to I restarted it. And now it works! But, I think w hat it was is I had multiple IPs/subnets defined on my nic. Cleared that off and also started spotify before my VPN connection.
I updated the original post with steps to fix in the mean time, though I am sure you will have this fixed soon.

Thanks for the help Tim!

Forum Jump: