Thank you for your donation!


WIFI IP address appears only with wired connection
#1
So I'm a fan, and have built my second system around this OS. Thank you for all of this!

Second system I want to have as wifi only. Have looked for this issue on the forums, but don't find it.

Trying to configure - with my SSID on my router (DHCP) eth0 connection and DHCP wlan0 enabled I get an IP address on the network config screen. Can ping the wlan0 on my network, but it does not appear when I try to do a device discovery on my android (using WiFiman).

Have tried blank (AP mode active) and it shows 172.24.1.1 - but can't connect with http://172.24.1.1 on android.

Have tried my SSID on my router. As long as my eth0 is on strangely both IP addresses show up as wired connections on my router (192.168.1.23 - wired, and .17 - wireless on Moode network config screen, but shows as wired on router connected devices).

I can disconnect eth0 and can no longer ping either address. (strangely the wifi connection functionally existed for a little while on my android)

Plug back in my ethernet cable and both .23 and .17 reappear on connected devices list, both as wired connections.

Is there some other setting that is interacting with wifi that I need to know about?

Latest version of the Raspere Pi 3 Model B, Moode audio 4.4  

USB connected SATA hard drive, but let's just worry about getting radio to play. (Wired everything works).

Any advice is appreciated.

Thanks,

Jerry
Reply
#2
If you want WiFi only configuration then Eth0 should be set to DHCP, WiFi can be either DHCP or STATIC. After saving the Network config power off, remove Ethernet cable, then power up.

If you get a successful WiFi connection then open System config and tuen "Wait for eth0 address" off. It will trim 10 secs off of the boot sequence.
Enjoy the Music!
http://moodeaudio.org | http://twitter.com/MoodeAudio | http://github.com/moodeaudio
Reply
#3
(02-19-2019, 04:04 PM)Tim Curtis Wrote: If you want WiFi only configuration then Eth0 should be set to DHCP, WiFi can be either DHCP or STATIC. After saving the Network config power off, remove Ethernet cable, then power up.

If you get a successful WiFi connection then open System config and tuen "Wait for eth0 address" off. It will trim 10 secs off of the boot sequence.

Hello Tim,

Thanks for taking the time to look at my problem. I did as you told, both ways, applying and power cycling each time.

Alas if I configure wlan0 to static and put in address and pw for router - it shows that the WIFI is "Not in use" on restart.

If I configure wlan0 as DHCP and shut down, power off and power on, it shows an IP address. And my wifi router shows both IP addresses on the Raspberry Pi as "wired" connections. It is as if my wifi has been aliased to a second virtual connection over the same ethernet port. BTW the wifi router shows no connections if I disconnect the RJ45 port cable.

Very strange.

J
Reply
#4
Thats very odd.

I'd reboot the Router.
Enjoy the Music!
http://moodeaudio.org | http://twitter.com/MoodeAudio | http://github.com/moodeaudio
Reply
#5
Well - I flashed a raspberian installation (no Moode audio) and it turns out my wifi works just fine. Used raspi-config and set everything up on the wifi and can even hold a full VNC session with the system.

I then swap boot disks - put in the moode audio one and run "sudo apt-get update" and then "sudo raspi-config" and select network and try to enable wifi and it says "no wireless interface found".

So this definitely appears to be a moode installation problem. I'm loathe to re-install as I have a 2tb music collection that takes a very long time to re-index. In case anybody knows how to enable wifi within Moode's implementation of raspberry light.

Thanks,

Jerry
Reply
#6
Start with a fresh image of moOde r4.4 on an (u)SD card.

-do not add a moodecfg.txt file to /boot.
-do insert the card into an RPi with either internal or known-to-work-with-RPi external WiFi adapter and *no* ethernet connection.
-do boot moOde.
-do not: make ethernet connection, ssh into moOde, and run 'apt-get update'
-do not: make ethernet connection, ssh into moOde, and run 'raspi-config'
-do disconnect your phone from your existing WiFi Access point and connect it with the Access Point SSID=Moode, pwd=moodeaudio
-do now open http://172.24.1.1 in your browser on your phone.
et voilà

I have three Android devices with various Android versions, one Apple iPod with current iOS version, and a Linux laptop with recent Linux MintOS. None has any trouble connecting to moOde following this scheme..

Regards,
Kent
Reply
#7
(02-25-2019, 06:12 PM)TheOldPresbyope Wrote: Start with a fresh image of moOde r4.4 on an (u)SD card.

-do not add a moodecfg.txt file to /boot.
-do insert the card into an RPi with either internal or known-to-work-with-RPi external WiFi adapter and *no* ethernet connection.
-do boot moOde.
-do not: make ethernet connection, ssh into moOde, and run 'apt-get update'
-do not: make ethernet connection, ssh into moOde, and run 'raspi-config'
-do disconnect your phone from your existing WiFi Access point and connect it with the Access Point SSID=Moode, pwd=moodeaudio
-do now open http://172.24.1.1 in your browser on your phone.
et voilà

I have three Android devices with various Android versions, one Apple iPod with current iOS version, and a Linux laptop with recent Linux MintOS. None has any trouble connecting to moOde following this scheme..

Regards,
Kent
Thanks Kent,

Before reading your post, I did almost all you said - but booted the first time with ethernet cable connected. The big trick was to run raspi-config and change locale (which I knew to do) BUT and here is the big butt - when you select a new country (US in my case) the default country remains selected. I failed to notice that it just picked the first checkmark found and reconfigured for Great Britain. YOU MUST DESELECT ALL OTHER COUNTRIES!!! I also selected wifi channel 10 (My SSID is broadcasting around that range). Then I was able to do a DHCP and at least use my own router. Haven't tried the AP setting yet because I don't want to tempt the fates.

But I'll let you know when I do.

Thanks again.

Jerry
Reply
#8
Hi Jerry,

moOde is not multi-language capable and thus the default locale should not be changed.
Code:
pi@rp3:~ $ cat /etc/default/locale
#  File generated by update-locale
LANG=en_GB.UTF-8

The only other localization settings that need to be made are below and they should be set using the moOde config screens and not raspy-config otherwise moOde settings and associated managed conf files will not be right and will cause issues.

- Keyboard layout (System config)
- WiFi country (Network config)

-Tim
Enjoy the Music!
http://moodeaudio.org | http://twitter.com/MoodeAudio | http://github.com/moodeaudio
Reply
#9
Hmmm, wifi country is what I mean't. And I changed it using raspi-config and now everything works.

I'll check the network config for country too.

So far if that's the only thing I've changed in raspi-config it seems to be working. But if something breaks again I'll follow your advice. Thank you Tim.

Jerry
Reply
#10
No prob :-)
Enjoy the Music!
http://moodeaudio.org | http://twitter.com/MoodeAudio | http://github.com/moodeaudio
Reply


Forum Jump: