Thank you for your donation!


Problem with httpd-streaming in moode
#1
Hi,

I want to stream from moode 4.4+ to another RasPi (with current raspbian), but

    sudo netstat -ltpn

found out, that on moode port 8000 is not shown as open.

I did the following changes to /etc/mpd.conf:

    bind_to_address "any"

    audio_output {
        type "httpd"
        name "My HTTP Stream"
        encoder "lame"
        port "8000"
        bitrate "128"
        format "44100:16:1"
        always_on "yes"
        tags "yes"
    }

and restarted mpd, but it doesn't work.

Of course the access from raspbian-mpd to moode doesn't work, too.

Did I miss something ?

Regards, Klaus
Reply
#2
Hi,

I added the code code block below, enabled the new output (#6) and no issues.

See if you can repro.

Code:
audio_output {
type "httpd"
name "HTTP stream"
encoder "flac"
port "8000"
compression "0"
}

Code:
pi@rp3:~ $ mpc enable 6
Output 1 (ALSA default) is enabled
Output 2 (ALSA crossfeed) is disabled
Output 3 (ALSA parametric eq) is disabled
Output 4 (ALSA graphic eq) is disabled
Output 5 (ALSA bluetooth) is disabled
Output 6 (HTTP stream) is enabled
Enjoy the Music!
http://moodeaudio.org | http://twitter.com/MoodeAudio | http://github.com/moodeaudio
Reply
#3
Hi Tim,

thank you very much, 'mpc enable 6' did the trick !

Regards, Klaus
Reply


Forum Jump: