Thank you for your donation!


Solved: Cannot see all folders using Local UI with official Touchscreen
#1
I installed 4.1 on a clean stretch version and activated the LocalUI. I'm not a heavy user, but all works very well, and sound is great.


One minor glitch to report: the instructions say


Quote:4. Configure Chrome Browser
[...]

a. Connect a keyboard.
b. Press Ctrl-t to open a separate instance of Chrome Browser.
c. Enter url chrome://flags and scroll down to Overlay Scrollbars and enable the setting.
d. Optionally, enter url chrome://extensions and install the xontab virtual keyboard extension.

With this alone, I cannot scroll to the bottom of my folders. See the screenshot attached, a white stripe appears, and the two last folders are not accessible.

I solved it with the keyboard pressing Ctrl + -   -> this sets the zoom to 90%, then everything is displayed correctly, and the two last folder become visible again. Second screenshot is also attached.

You might want to fix this, or include the zoom setting in the recipe.


Attached Files Thumbnail(s)
       
Reply
#2
Hi,

I'm able to repro this. Its caused by a bug in CSS. I'll add to the TODO list for moOde 4.2 but in the meantime if you want to fix yourself then follow the procedure below.

1. Edit /var/www/css/moode.css
2. Comment out the #database line below. It should be at line number 128 in the file.

Code:
/* tpc r41 pi touch */
@media (height: 479px) and (width: 799px) {
/*#database {height: 100vh;}*/

3. Save the file

4. Clear Chrome Browser cache

Code:
sudo rm -rf ~/.config/chromium/Default/
sudo rm -rf ~/.cache/chromium

5. In moOde UI: Menu, Refresh

-Tim
Reply
#3
I applied the fix - problem solved.

Now the interface on the Touchscreen looks better than with the zoom at 90%, fonts are bigger and it's easier to tap where I want.

Thank you!   Smile
Reply


Forum Jump: