Thank you for your donation!


Bad quality sound on MoodeAudio 6.x
#29
moOde knob just sends MPD the volume level (0 - 100) same as if u used the mpc command. Then MPD either alters the samples with its own Software volume routine before sending them to ALSA or it sends the desired volume level to the DAC's Hardware volume controller and then sends the samples as-is to ALSA. The DAC's Hardware volume controller will alter the samples using it's own volume algorithm.

One of my first quick test this morning was Pi4, Hifiberry DAC+Pro, Software volume 100%, ALSA volume 80%, GEQ Vinyl Touch and some 16/4.1 FLAC tracks.

I did not experience any distortion whatsoever no matter how loud I set the downstream Amp volume. I then wanted to see if the Software volume loudness issue was present in my other configs so I tested with my Katana rig and indeed it was present. I also tested the GEQ and ALSA Max volume on this rig and again no distortion.

Based on my tests there is potential issue with MPD Software volume but the Graphic EQ, ALSA volume and Max ALSA volume worked perfectly.

The Graphic EQ doesn't have a master gain and thus there's nothing to adjust.

Unless you or someone else can provide a way to reproduce this distortion you are experiencing there's no way to troubleshoot.
Enjoy the Music!
moodeaudio.org | Mastodon Feed | GitHub
Reply


Messages In This Thread
Bad quality sound on MoodeAudio 6.x - by Jedrek - 08-30-2019, 07:47 PM
RE: Bad quality sound on MoodeAudio 6.x - by Tim Curtis - 06-23-2020, 08:57 PM

Forum Jump: