Thank you for your donation!


Allo USBridge Signature
Here is what native DSD looks like playing some DSF files on a USB stick directly to an Allo Revolution DAC. 

   

Code:
pi@rp2:~ $ cat /proc/asound/card2/pcm0p/sub0/hw_params | grep format
format: DSD_U32_BE
subformat: STD


Maybe you are running an old or vendor modified version of moOde?
Enjoy the Music!
http://moodeaudio.org | http://twitter.com/MoodeAudio | http://github.com/moodeaudio
Reply
(02-27-2021, 03:35 PM)Tim Curtis Wrote: Here is what native DSD looks like playing some DSF files on a USB stick directly to an Allo Revolution DAC. 



Code:
pi@rp2:~ $ cat /proc/asound/card2/pcm0p/sub0/hw_params | grep format
format: DSD_U32_BE
subformat: STD



Maybe you are running an old or vendor modified version of moOde?
Moode was provided installed on the SD card by Allo.
How can I see the version number? I haven't found an "About" tab in the web browser view.
[i][color=#0000cd][size=small]"I'm not young enough to know everything." - Oscar Wilde[/size][/color][/i]
Reply
@HungarianPal

Interesting. I hadn't noticed that "88.2 kHz" tidbit until you pointed it out. It shouldn't be there.

The post you quote is from last July and I don't remember the exact conditions of the test. A lot of things have changed since, from the moOde release to the firmware on the DAC. If I get a chance I'll see if I can get a similar result and if so, figure out why.

Regards,
Kent

PS - your Oscar Wilde post becomes truer for me every day.
Reply
(02-27-2021, 04:31 PM)TheOldPresbyope Wrote: PS - your Oscar Wilde post becomes truer for me every day.

Isn't it appropriate sometimes?!  Wink

Now, you got me worried about that 88.2kHz. I'd find it odd if my dac didn't recognize native DSD.
One thing occured to me. My mch SACD player is connected to my AVR through HDMI to provide a mch DSD stream. According to the manual in Pure Direct mode the AVR decodes the DSD stream to analogue without interim PCM conversion - the display, the video board and all DSP is off. In Source Direct mode only DSP is off and the display shows 88.2 kHz although the DSD light is still on. The same strange 88.2 kHz add-on to DSD playback...
[i][color=#0000cd][size=small]"I'm not young enough to know everything." - Oscar Wilde[/size][/color][/i]
Reply
Are u using official moOde 7.0.1 from moodeaudio.org?
Enjoy the Music!
http://moodeaudio.org | http://twitter.com/MoodeAudio | http://github.com/moodeaudio
Reply
(02-27-2021, 05:23 PM)Tim Curtis Wrote: Are u using official moOde 7.0.1 from moodeaudio.org?

I don't know. I ordered the USBridge Sig. from Allo and in the ordering process I chose moOde as the OS. It all arrived yesterday with the SD card already in the slot and I fired it up, ran the configuration process in Ethernet mode in my Mac Mini's Safari browser (moode.local). I don't even know how to check the version number.
[i][color=#0000cd][size=small]"I'm not young enough to know everything." - Oscar Wilde[/size][/color][/i]
Reply
(02-27-2021, 05:33 PM)HungarianPal Wrote:
(02-27-2021, 05:23 PM)Tim Curtis Wrote: Are u using official moOde 7.0.1 from moodeaudio.org?

I don't even know how to check the version number.

Not obvious:
M menu (top right) > configure > system. Then back to M menu again and select system info.

I would be surprised if Allo are shipping moOde 7.0.1   They seem to ship an arbitrary release from many months ago. In December is was v6.4.0 - I doubt it has changed.
Reply
Putting aside for a moment the fact that this forum doesn't support moOde as packaged and configured by vendors, last July I was using "official" moOde 6.7.0 or 6.7.1.

A quick check with the current testing-release of moOde 7.1.0 and the same minimserver/mconnect/UPnP rendererKhadas Tone Board (now called "Tone1" because of the firmware update) configuration I was using then gives me output comparable to what Tim posted:

Code:
Audio Information
INPUT / OUTPUT
Source http://192.168.4.64:9790/minimserver/*/Music/DSD/NDSD012/01_Welcome-to-NativeDSD-Sampler_NativeDSD-Presents_NDSD012_2ch64.dsf
Encoded at DSD64, 1 bit, 2.822 MHz Stereo
Decoded to DSD bitstream, 5.645 Mbps
Destination Local
Output rate DSD bitstream, 5.645 Mbps

DSP OPERATIONS
Resample rate off
Selective rate off
Resample quality off
Volume mixer Software (MPD)

AUDIO DEVICE
Device Tone1
Mixer name Tone1
Interface USB
Formats S32_LE, SPECIAL, DSD_U32_BE
Platform Pi-4B 1.1 2GB

I'm not eager to roll back to release 6.7.x. I think your best course of action is to flash and configure moOde 7.0.1 from moodeaudio.org.

Regards,
Kent
Reply
(02-27-2021, 06:25 PM)Mark Dirac Wrote:
(02-27-2021, 05:33 PM)HungarianPal Wrote:
(02-27-2021, 05:23 PM)Tim Curtis Wrote: Are u using official moOde 7.0.1 from moodeaudio.org?

I don't even know how to check the version number.

Not obvious:
M menu (top right) > configure > system. Then back to M menu again and select system info.

I would be surprised if Allo are shipping moOde 7.0.1   They seem to ship an arbitrary release from many months ago. In December is was v6.4.0 - I doubt it has changed.

Yup.

Code:
Index of /Allocom/moode
[ICO]    Name    Last modified    Size    Description
[PARENTDIR]    Parent Directory         -    
[DIR]    4.14.92-OS/    2019-11-04 06:12    -    
[   ]    info    2020-02-05 00:33    166    
[   ]    moode-r610-iso.7z    2019-09-20 05:35    1.0G    
[   ]    moode-r640-iso.zip    2020-02-04 23:44    1.5G
Reply
(02-27-2021, 06:25 PM)Mark Dirac Wrote:
(02-27-2021, 05:33 PM)HungarianPal Wrote:
(02-27-2021, 05:23 PM)Tim Curtis Wrote: Are u using official moOde 7.0.1 from moodeaudio.org?

I don't even know how to check the version number.

Not obvious:
M menu (top right) > configure > system. Then back to M menu again and select system info.

I would be surprised if Allo are shipping moOde 7.0.1   They seem to ship an arbitrary release from many months ago. In December is was v6.4.0 - I doubt it has changed.

Thanks a lot. I have checked that menu on the right many times but never when I was in System.
You are right. I have 6.4.0 from 24.11.2019.
I am  not sure I want to update because the system is up and working wonderfully now. I have read a lot about this linux kernel change that affects a lot of DAC's DSD playback so many people are even advised to go back to an earlier version of moOde and not update. 
One more thing. In System I saw something: File system has not been expanded. What does it mean? Should I click EXPAND?
[i][color=#0000cd][size=small]"I'm not young enough to know everything." - Oscar Wilde[/size][/color][/i]
Reply


Forum Jump: