Thank you for your donation!


Instruction Guide Set Startup volume ?
#1
Question 
Hello everybody!

Trying Moode Audio after having used Runeaudio and Volumio for a while:
Using latest Moode Relase on Pi3B with an Iqaudio DAC + Works very well so far :-)

I'm trying to set-up an automatic volume value at startup but didnt found any option in Moode Audio, have i missed something somewhere? If not, is there a way to achieve this?

Actually, the volume at reboot is the same as when shutdown.

Looking forward foy your help :-)
Reply
#2
There is no setting for this.

Whats the usage scenario where a specific volume is needed after reboot?

-Tim
Reply
#3
(05-13-2018, 12:43 PM)Tim Curtis Wrote: There is no setting for this.

Whats the usage scenario where a specific volume is needed after reboot?

-Tim

Hello Sir,
 
Thanks for you answer :-)

i need this because the Amp where my Moode audio player is connected has a computer connected at it aswell and has a "fixed" volume.

I only use windows or moodeaudio volume rockers to fit my needs in a certain volume range. i avoid using the volume from the amp because i need another remote :-(
If Moodaudio start then auto play at 100% volume, it wiil be too loud for my daily listening :-)

Idea is:
if i'm listening at loud volume on volumio, then shut it down, i'd appreciate if, when restarted, the volume was set do a default boot value that is a daily use volume.

for information purpose, Volumio and Runaudio both had this option.

Hope my explanations are clear enough.

If i can help you in any way, dont hesitate asking me :-)

(sorry for my english Tongue )
Reply
#4
If I get more requests for this I can add to the TODO list.

If you want to try a workaround then just set your desired volume level in the restart.sh script. I used the value 50 in the example below.

sudo nano /var/local/www/commandw/restart.sh

Add the following line of code after 'mpc stop' in the "reboot" and "power off" code blocks.
/var/www/vol.sh 50

-Tim
Reply
#5
I have a question regarding to startup volume. I think I have the opposite problem.

I use Moode (4.1) with a HifiBerry DAC+ with volume-control set to hardware as UPnP-renderer. If I hear music, lets say with volume set to "40", restart Moode sometimes the volume ist set back to "26".
I would prefer to have the last used volume on startup.


Is this a known behaviour?
Reply
#6
Try enabling UPnP volume sync, then reboot. This should cause moOde volume knob to sync up with volume changes made on UPnP control point.

Enable UPnP vol sync
Code:
sqlite3 /var/local/www/db/moode-sqlite3.db "UPDATE cfg_system SET value='1534' WHERE param='feat_bitmask'"

Disable UPnP vol sync
Code:
sqlite3 /var/local/www/db/moode-sqlite3.db "UPDATE cfg_system SET value='510' WHERE param='feat_bitmask'"

-Tim
Reply
#7
(05-13-2018, 09:07 PM)Tim Curtis Wrote: If I get more requests for this I can add to the TODO list.

If you want to try a workaround then just set your desired volume level in the restart.sh script. I used the value 50 in the example below.

sudo nano /var/local/www/commandw/restart.sh

Add the following line of code after 'mpc stop' in the "reboot" and "power off" code blocks.
/var/www/vol.sh 50

-Tim

Hello Tim,

Worked perfectly. Cool
Thanks for your help and clear instructions :-)
Reply


Forum Jump: