Thank you for your donation!


Airplay disconnecting and disappearing?
#11
(06-11-2018, 06:04 PM)JST1963 Wrote: Well, I'm not sure but I think you have to replace the "RP3 Airplay" with your own Airplay Receiver name. In my case (since I haven't changed the name) it's still the default "Moode Airplay". Tim has probably several setups and one of them is called "RP3 Airplay". Do the same again with your name. That'll help, I think...


I appreciate your patience @JST1963

I replaced "RP3 Airplay" with the default "Moode Airplay" since I have not altered anything yet. But it gave me the same response as I posted above.
Reply
#12
use the cmd string from your log in post #5
Enjoy the Music!
http://moodeaudio.org | http://twitter.com/MoodeAudio | http://github.com/moodeaudio
Reply
#13
(06-11-2018, 07:27 PM)Tim Curtis Wrote: use the cmd string from your log in post #5

I'm not sure if I did it right but I got this:

[Image: Screen%2BShot%2B2018-06-11%2Bat%2B3.56.46%2BPM.png]

Thanks again for your patience!
Reply
#14
Are you configured for Hardware volume in MPD?
Enjoy the Music!
http://moodeaudio.org | http://twitter.com/MoodeAudio | http://github.com/moodeaudio
Reply
#15
(06-11-2018, 09:08 PM)Tim Curtis Wrote: Are you configured for Hardware volume in MPD?

I've tried all settings - none, hardware and software. None of these settings worked with airplay.
Reply
#16
In moOde the Airplay receiver automatically picks up the Volume config from MPD unless you force Airplay to use "Software" volume in Airplay config screen. If your DAC works with MPD set to Hardware but Airplay does not, which is what the error "failed to attach to mixer" suggests, then you can try setting Airplay to "Software" volume in Airplay config screen.
Enjoy the Music!
http://moodeaudio.org | http://twitter.com/MoodeAudio | http://github.com/moodeaudio
Reply
#17
(06-11-2018, 09:50 PM)Tim Curtis Wrote: In moOde the Airplay receiver automatically picks up the Volume config from MPD unless you force Airplay to use "Software" volume in Airplay config screen. If your DAC works with MPD set to Hardware but Airplay does not, which is what the error "failed to attach to mixer" suggests, then you can try setting Airplay to "Software" volume in Airplay config screen.

I think I've tried these settings before with no success. But I will do it again. 

Thanks so much Tim and @JST1963

Joseph
Reply
#18
Update on the Airplay issue: a few days ago I hooked up a Xiang Sheng DAC 01A to the RPi3B+ and Airplay functioned. It's unfortunate that with the first 3 USB DACs I tried - Topping D30, AQ Dragonfly Black and XtremPro X1 - Airplay disappears.
Reply
#19
Hi Thorsten,

It works perfectly on my end but there is always the possibility of breakage or bugs that surface only in other environments or configs. Try the mods below (in Bold) to enable the launch string for verbose logging to a file. 

1. Edit /var/www/inc/playerlib.php, function startSps()
1. Add -vv to the base cmd string to enable verbose logging
2. Replace 3 occurrences of /dev/null with /home/pi/sps.log to redirect the log output to a file
3. Save the edits
4. Reboot
5. tail -f /home/pi/sps.log -OR- cat /home/pi/sps.log

/var/www/inc/playerlib.php

// start shairport-sync
function startSps() {
// get device num and hardware mixer name
$array = sdbquery('select value_player from cfg_mpd where param="device"', cfgdb_connect());
$device = $array[0]['value_player'];
$mixername = $_SESSION['amixname'];

// format base cmd string
$cmd = '/usr/local/bin/shairport-sync -vv -a "' . $_SESSION['airplayname'] . '" -S soxr -w -B /var/local/www/commandw/spspre.sh -E /var/local/www/commandw/spspost.sh ' . '-- -d hw:' . $device;

// add volume config
if ($_SESSION['airplayvol'] == 'auto') {
$cmd .= $_SESSION['alsavolume'] == 'none' ? ' > /home/pi/sps.log 2>&1 &' : ' -c ' . '"' . $mixername  . '"' . ' > /home/pi/sps.log 2>&1 &';
}
else {
cmd .= ' > /home/pi/sps.log 2>&1 &';
}

// start shairport-sync
debugLog('worker: (' . $cmd . ')');
sysCmd($cmd);
}

-Tim
Enjoy the Music!
http://moodeaudio.org | http://twitter.com/MoodeAudio | http://github.com/moodeaudio
Reply


Forum Jump: