Thank you for your donation!


Solved: NAS mounted volume not visible in library
#11
(04-17-2020, 06:12 PM)TheOldPresbyope Wrote: @GhezoArt

I'm at a loss here. The only essential difference I notice between your config and mine (a DIY OpenMediaVault NAS) is in your mount options: vers=3.0 and username=admin.

On my NAS, Samba is configured to use SMB v1 protocol and to allow guest access to the music share. In moOde mount options, I have vers1=1.0 and username=Guest in the mount options. It 'just works' ™.

Yet, the fact that you can browse the /mnt/NAS/NAS directory suggests your mount options are not a problem.

Regards,
Kent

PS - you should not need to reinstall to resolve this. At worst, remove and then recreate new Music source in moOde Library config should do the trick.

I already try to delete and recreate the share after deleting the Upnp connection.
I suspect this is the problem.

I'll try with a clean install again so I'll be sure Wink
I'll keep you aware of the result !

One again many thanks for your time !

Have a nice weekend.
Georges.
Reply
#12
OK but your earlier evidence showed the source/mountpoint you'd setup in moOde was /mnt/NAS/NAS so that is where mpd will be looking for files not /mnt/NAS/GHENAS.

Try...

Code:
find /mnt/NAS/NAS -type f -iname "*.mp3" -or -iname "*.flac"


With the vague evidence it seems you've may have created a source pointing to a file share with no audio files, or at least none that are accessible to the mpd user.
There's no need to reflash your sd card, just delete the source and recreate, ensuring you point it to where your audio files are.
Reply
#13
(04-17-2020, 09:13 PM)vinnn Wrote: OK but your earlier evidence showed the source/mountpoint you'd setup in moOde was /mnt/NAS/NAS so that is where mpd will be looking for files not /mnt/NAS/GHENAS.

Try...

Code:
find /mnt/NAS/NAS -type f -iname "*.mp3" -or -iname "*.flac"


With the vague evidence it seems you've may have created a source pointing to a file share with no audio files, or at least none that are accessible to the mpd user.
There's no need to reflash your sd card, just delete the source and recreate, ensuring you point it to where your audio files are.

Good catch. I managed to overlook the switch in path between posts.

@GhezoArt what's up with that?

Regards,
Kent
Reply
#14
Ok,
After putting a new image on the Pi, and setting up my samba connection, it worked building my 1222 albums DB.
With my NAS, I had to use at least v2.0 of SMB. V1.0 like your's didn't work.

Some strange thing, I I go to the "folder" interface it stopped indexing and I saw only some album.

Best regards and thanks again.
Reply
#15
(04-17-2020, 09:58 PM)TheOldPresbyope Wrote:
(04-17-2020, 09:13 PM)vinnn Wrote: OK but your earlier evidence showed the source/mountpoint you'd setup in moOde was /mnt/NAS/NAS so that is where mpd will be looking for files not /mnt/NAS/GHENAS.

Try...

Code:
find /mnt/NAS/NAS -type f -iname "*.mp3" -or -iname "*.flac"


With the vague evidence it seems you've may have created a source pointing to a file share with no audio files, or at least none that are accessible to the mpd user.
There's no need to reflash your sd card, just delete the source and recreate, ensuring you point it to where your audio files are.

Good catch. I managed to overlook the switch in path between posts.

@GhezoArt what's up with that?

Regards,
Kent

Hello full of Flacs .
I reply with samples in #10 post where you can find more info.

Regards
Reply
#16
@GhezoArt

We're confused because post #1 shows a music source added in Library config as "NAS", which is mounted in the Linux directory structure at /mnt/NAS/NAS. 

Posts #7/#10 imply a source is mounted at /mnt/NAS/GHENAS. It has a different directory structure than the source above. Did you mount this source by hand or through the Library config?

Regards,
Kent
Reply
#17
(04-18-2020, 04:48 PM)TheOldPresbyope Wrote: @GhezoArt

We're confused because post #1 shows a music source added in Library config as "NAS", which is mounted in the Linux directory structure at /mnt/NAS/NAS. 

Posts #7/#10 imply a source is mounted at /mnt/NAS/GHENAS. It has a different directory structure than the source above. Did you mount this source by hand or through the Library config?

Regards,
Kent

Ho, I understand, sorry for that.
I had tried to delete and to recreate the share with another name to be sure there was no history keepen.
But the mount point was the same !

Thanks for your attention !
Reply
#18
(04-18-2020, 08:02 AM)GhezoArt Wrote: Ok,
After putting a new image on the Pi, and setting up my samba connection, it worked building my 1222 albums DB.
With my NAS, I had to use at least v2.0 of SMB. V1.0 like your's didn't work.

Sorry, I overlooked this post.

So is your NAS visible now? Then please go back to your original post and edit the prefix from 'Problem:' to 'Solved:'.

Usable SMB versions is a matter of your NAS configuration, so no surprise if any particular version doesn't work.

Quote:Some strange thing, I I go to the "folder" interface it stopped indexing and I saw only some album.

Maybe you interrupted the scan? You can always force a rescan.

Quote:Best regards and thanks again.


To borrow Tim's byline, "enjoy the music!"

Regards,
Kent
Reply
#19
If the Library is opened b4 MPD database update completes the library cache will be incomplete.

Menu, Configure, Library
Delete Library cache
Enjoy the Music!
http://moodeaudio.org | http://twitter.com/MoodeAudio | http://github.com/moodeaudio
Reply
#20
(04-19-2020, 03:11 PM)Tim Curtis Wrote: If the Library is opened b4 MPD database update completes the library cache will be incomplete.

Menu, Configure, Library
Delete Library cache

Thans for all this.
Works fine now !!!!!

You have a great support !

Many thanks !
Reply


Forum Jump: