Thank you for your donation!


moOde release 4.1
#61
I've just updated my Pi Zero W to Moode 4.1.

All went without a hitch.

Is a my imagination or does Moode 4.1 sound better than 4.0?

I was using the 4.14 kernel in 4.0, so it's not the kernel version bump.

Well done Tim.

Phil

Reply
#62
(04-09-2018, 03:26 PM)kitamura_design Wrote: Hi,

The in-place update worked fine, thanks Tim.

But I now found that  '_' character (under-bar) was rejected when I tried to edit the SSID on WiFi config part.
On ver 4.0, this is allowed to be used, I think.

kitamura_design

Hi,

This is a bug :-0

I'll have to put out a 4.1 bugfix update in the next couple of weeks. If you need the fix right now then follow the procedure below.

1. Open an SSH session

2. Edit the net-config.html file using the nano editor. Page to the bottom of the file.

Code:
sudo nano /var/www/templates/net-config.htm


3. Add \_ to the pattern= statement

Code:
pattern="[A-Za-z0-9\-\_]{3,32}"

4. Ctrl-o <return> Ctrl-x to save the file.

-Tim
Enjoy the Music!
http://moodeaudio.org | http://twitter.com/MoodeAudio | http://github.com/moodeaudio
Reply
#63
(04-09-2018, 07:07 PM)philrandal Wrote: I've just updated my Pi Zero W to Moode 4.1.

All went without a hitch.

Is a my imagination or does Moode 4.1 sound better than 4.0?

I was using the 4.14 kernel in 4.0, so it's not the kernel version bump.

Well done Tim.

Phil

Hi Phil,

Glad to hear that :-) no pun intended, lol.

-Tim
Enjoy the Music!
http://moodeaudio.org | http://twitter.com/MoodeAudio | http://github.com/moodeaudio
Reply
#64
Hi moOde fans,
 :@
Reply
#65
(04-09-2018, 05:39 PM)FizzyTea Wrote:
(04-09-2018, 04:48 PM)zenscape Wrote: So, you're saying I can boot up my Dell workstation that is running Linux Mint, open a terminal session and SSH to my Moode Pi - and that's how I do the build?

If that's the case, great. I just asked what I needed to create the build. I thought I had to have another Pi.

Yes.
Use your workstation to burn a fresh raspbian lite image to sd.
Add the ssh text file to enable ssh. Details online if needed.
Boot your pi with your new raspbian image.
Log into raspbian from your workstation via ssh.
Follow the mosbuild instructions on the Github page to run the build script.

Thanks @FizzyTea. That was all I asked and all needed to know.
Reply
#66
(04-09-2018, 06:36 AM)patrik96 Wrote:
(04-08-2018, 09:28 PM)Tim Curtis Wrote: The error suggests DNS resolve issue. What are the entries on the Network config screen?

Now I give up, I was installa fresh Raspbian and after it, not possible to access the PI from putty.... someting wrong on the Rasbian may be?!

Did you create a ssh.txt file in the boot directory on the raspbian image?
Reply
#67
(04-09-2018, 10:44 AM)tomek Wrote: I have built 4.1 on Pi3B+ without problems. I noticed few things :

1. I  am missing the buttons backward, pause-play, forwad at the top in browse and library view. Before it was possible for me to choose and play album and without going to "playback" i could go to next track, pause, stop  etc.



2. Also a small circle at the top-right dissappeared (when using android phone), it was pointing directly to play view with volume etc. On my phone or tablet i have to touch "playback", i am in the playlist view, and i have to scroll down to get the playback view with "playbackknob". When the playlist is long, than i have to scroll a lot to get the "playbackknob", before "playbackknob" view was over first track of the playlist, easier to reach.

3. I noticed also, that the response of the round "playbackknob" is strange. I tried it in browser in computer, it works very well, but on my phone and tablet  when i want to go forward inside one loooong track, than often it is not possible to do it, there is just no response, when i am touching it, i didn't have this kind of problems with 3.8 and 4.05b.

Is there any chance to get the buttons and a small circle pointing to "playbackknob"  back ?

Thanks to all developpers for Your great work Smile

Hi,

The Library panel is getting some nice improvements for moOde 4.2 including a return of the playback buttons. 

I don't quite understand #2 and #3 but there are no knobs displayed in the mobile portrait view. There is a timeline slider and a popup volume control.

-Tim
Enjoy the Music!
http://moodeaudio.org | http://twitter.com/MoodeAudio | http://github.com/moodeaudio
Reply
#68
(04-08-2018, 09:28 PM)Tim Curtis Wrote: The error suggests DNS resolve issue. What are the entries on the Network config screen?

Hi Tim!
I've got same problem/same log with NAS.


Attached Files Thumbnail(s)
   
Reply
#69
(04-09-2018, 08:40 PM)Deenoo Wrote:
(04-08-2018, 09:28 PM)Tim Curtis Wrote: The error suggests DNS resolve issue. What are the entries on the Network config screen?

Hi Tim!
I've got same problem/same log with NAS.
Everything is OK! :Smile Solved
Reply
#70
(04-09-2018, 08:24 PM)Tim Curtis Wrote: Hi,

The Library panel is getting some nice improvements for moOde 4.2 including a return of the playback buttons. 

I don't quite understand #2 and #3 but there are no knobs displayed in the mobile portrait view. There is a timeline slider and a popup volume control.

-Tim

Hi Tim, 

In the former moode version in portrait mode on the top there was a small circle, when touched i was immediately in playback mode with time slider (not playlist), this circle dissapeared,. Here it is still there, in the center between other dissapeared buttons.

   

Direct acces to volume control was also nice.

It would be nice to browse through directories, or library having some  playback control possibilities without switching into "playback" mode.

The big round time slider ? is not working properly on phone and  tablet, i can't "rewind" inside the track. Lets say the track has 5:43 minutes, and i am listening at the begining, than i want to jump to 2 minute, it works, than i want to jump into 4 minute, i am touching the circle, but there is no reaction, i am trying to jump at 5 minutes or whatever, no reaction. I tested it on my phone and tablet, both android. 

   

I think, that _daRK reported the same thing here:


http://moodeaudio.org/forum/showthread.p...d=79#pid79

Tomek Smile
Reply


Forum Jump: