Thank you for your donation!


Solved: Connect MoOde Library to Linux Computer
#1
I have streached the limits of my knowledge of both Linux on a PC and MoOde.   I have an old PC that I installed Debian "Buster" on with the purpose of using Podget to load it up with radio shows that have been archived so that I can listen to them on MoOde at a latter date.  The problem I'm having is I cannot get the Moode library to connect to the PC running Debian.

So far...  I can ping the pc from the Moode SSH Pi.  I can SSH into the PC from the Moode Pi.  I set the library to:
NFS,   then set the path to RichardsonDebian/home/eric/Music

I get the error: 

NAS mount error:Cick to view moode.log for errors

Log shows:
20200420 183659 sourceMount(): Mount error: (mount.nfs: mount to NFS server 'RichardsonDebian:/home/eric/Music' failed: RPC Error: Unable to receive)
20200420 183659 sourceMount(): result=(mount.nfs: mount to NFS server 'RichardsonDebian:/home/eric/Music' failed: RPC Error: Unable to receive)
20200420 183659 waitWorker(): Wait  (2)
20200420 183659 waitWorker(): End   (lib-config, w_active=0)

It seems like I'm making some obvious error.....  What should I try next?

Thanks in advance.
Reply
#2
(04-21-2020, 12:06 AM)eracerr Wrote: I have streached the limits of my knowledge of both Linux on a PC and MoOde.  ...

I set the library to:
NFS,   then set the path to RichardsonDebian/home/eric/Music

BUT did you set up an NFS server on your Debian box and configure it to export 'RichardsonDebian/home/eric/Music' ?

Regards,
Kent
Reply
#3
(04-21-2020, 12:17 AM)TheOldPresbyope Wrote:
(04-21-2020, 12:06 AM)eracerr Wrote: I have streached the limits of my knowledge of both Linux on a PC and MoOde.  ...

I set the library to:
NFS,   then set the path to RichardsonDebian/home/eric/Music

BUT did you set up an NFS server on your Debian box and configure it to export 'RichardsonDebian/home/eric/Music' ?

Regards,
Kent

I did not.  Let me ask Google for some more help.  Honestly, I have never created a Linux based OS on a computer before.  It's all been a good learning experience. Most of the time it's just trying to figure out the right question and then there is a solution!
Reply
#4
(04-21-2020, 12:24 AM)eracerr Wrote:
(04-21-2020, 12:17 AM)TheOldPresbyope Wrote:
(04-21-2020, 12:06 AM)eracerr Wrote: I have streached the limits of my knowledge of both Linux on a PC and MoOde.  ...

I set the library to:
NFS,   then set the path to RichardsonDebian/home/eric/Music

BUT did you set up an NFS server on your Debian box and configure it to export 'RichardsonDebian/home/eric/Music' ?

Regards,
Kent

I did not.  Let me ask Google for some more help.  Honestly, I have never created a Linux based OS on a computer before.  It's all been a good learning experience. Most of the time it's just trying to figure out the right question and then there is a solution!

Nobody is born knowing how to do this stuff. You've got the right attitude---it's a learning experience for all of us.

Good hunting.

Regards,
Kent
Reply
#5
Rather than an older power hungry PC why not use a Pi 3 or 4?
Enjoy the Music!
http://moodeaudio.org | http://twitter.com/MoodeAudio | http://github.com/moodeaudio
Reply
#6
(04-21-2020, 01:27 AM)Tim Curtis Wrote: Rather than an older power hungry PC why not use a Pi 3 or 4?

My first thought was to attach a HDD to the Pi that has Moode on it. But I didn't have an external HDD to use, but I did have this old PC.  Eventually I will get an external drive and use that instead.  I wanted to use the PC to Linux as a learning experience, and it has been!  I also hate throwing out old electronics if I can find a new use for them, e-waste is a big issue.

Speaking of learning.  I added NFS to the PC but cannot seem to connect to it.  I'm using the machine name/Music
i.e. RichardsonDebian/Music in Moode.  The Moode log is timing out trying to reach the PC. I did update the /etc/exports with
/home/Music       192.168.1.0/24(rw,sync,no_subtree_check)

Seems as if I'm still missing a step.  Any help would be appreciated.
Reply
#7
OK, so if /home/Music is the export/share on your NFS server, that's the remote path you'd mount from a client, in Moode's web interface this will look like e.g.

Code:
hostname.or.ipaddress/home/Music

That's should be it.

One thing you haven't accounted for in your export is ownership of the files and whether different users (i.e. local or remote users) can access them so be aware of the ownership and permissions of the /home/Music directory and its contents.
If this directory is owned by user joebloggs for example then you can add an all_squash to your export options so remote users appear to be and have same access permissions as  joebloggs as to avoid permission/access issues and to ensure new files transferred to this share from other computers will inherit that ownership e.g.

On your Linux file server see who owns /home/Music...
Code:
$ ls -ld /home/Music
drwxrwxr-x 1 joebloggs users 862 Apr 21 08:13 /home/Music

$ ls -l /home/Music
-rw-rw--- 1 joebloggs users 10240 Apr 21 08:13 file1
-rw-rw--- 1 joebloggs users 10240 Apr 21 08:30 file2
-rw-rw--- 1 joebloggs users 10240 Apr 21 09:00 file3

Find joebloggs' user id;
Code:
$ id -u joebloggs
1000

Alter the appropriate line in /etc/exports to squash all incoming NFS clients to joebloggs' uid.
Code:
/home/Music       192.168.1.0/24(rw,sync,no_subtree_check,all_squash,anonuid=1000)

When making changes to the exports file you'll need to unexport and re-export the changed export to affect the change.
Code:
$ sudo exportfs -u /home/Music
$ sudo exportfs -a

You can see what is currently exported with the exportfs command without options;
Code:
$ sudo exportfs

Hope that helps

Vin
Reply
#8
@eracerr

Everything you learn using Debian on your old PC will be useful when you get around to building your RPi-powered NAS!

Quote: I did update the /etc/exports with

/home/Music       192.168.1.0/24(rw,sync,no_subtree_check)

Perhaps the directory you want to export is "/home/<your username>/Music"?

Regards,
Kent
Reply
#9
(04-21-2020, 12:59 PM)TheOldPresbyope Wrote: @eracerr

Everything you learn using Debian on your old PC will be useful when you get around to building your RPi-powered NAS!

Quote: I did update the /etc/exports with

/home/Music       192.168.1.0/24(rw,sync,no_subtree_check)

Perhaps the directory you want to export is "/home/<your username>/Music"?

Regards,
Kent

Thanks.  I updated the file to /home/eric/Music  with 192.168.1.0/24(rw,sync,no_subtree,all_squash,anonuid=0)  yes the user ID was root.  I ran podget from the root ID.  i will work out how to change that.

I'm now getting a different error when I try to connect.  Is it possible that the version of NFS I'm using is not compatible with what is in Moode ?

Error is:
20200421 211212 worker: Job sourcecfg
20200421 211212 sourceMount(): Mount error: (mount.nfs: requested NFS version or transport protocol is not supported)
20200421 211212 sourceMount(): result=(mount.nfs: requested NFS version or transport protocol is not supported)
20200421 211212 waitWorker(): Wait  (3)
20200421 211212 waitWorker(): End   (lib-config, w_active=0)
Reply
#10
(04-22-2020, 01:20 AM)eracerr Wrote: Thanks.  I updated the file to /home/eric/Music  with 192.168.1.0/24(rw,sync,no_subtree,all_squash,anonuid=0)  yes the user ID was root.  I ran podget from the root ID.  i will work out how to change that.

I'm now getting a different error when I try to connect.  Is it possible that the version of NFS I'm using is not compatible with what is in Moode ?

Error is:
20200421 211212 worker: Job sourcecfg
20200421 211212 sourceMount(): Mount error: (mount.nfs: requested NFS version or transport protocol is not supported)
20200421 211212 sourceMount(): result=(mount.nfs: requested NFS version or transport protocol is not supported)
20200421 211212 waitWorker(): Wait  (3)
20200421 211212 waitWorker(): End   (lib-config, w_active=0)

OK but as that directory is in the eric user's home directory shouldn't it be owned by eric?

If you want to change this ownership use the chown command, e.g. Login to your Debian box with your eric account and run...

Code:
sudo chown -R eric /home/eric

Then of course change your /etc/exports as described earlier squashing to eric's user id instead of 0.
Reply


Forum Jump: