Thank you for your donation!


Problem: Moode find my Nas but not the library
#21
@romain64


The first screen capture in your post # suggests you are now trying all sorts of source config options with spurious colon and/or port number, an extra forward slash, or a subdirectory of the exported directory. Predictably, all these fail.

It was my understanding that you were using NFS to export the directory "/volume1/Music" so in the moOde Source config, you should manually enter "192.168.0.18/volume1/Music" (or whatever the directory actually is) as you had in your first post. Once you get the green checkmark again you can try the commands @vinnn suggested.

Regards,
Kent
Reply
#22
I think the path has to have a colon ??
"192.168.0.18:/volume1/Music"
Enjoy the Music!
http://moodeaudio.org | http://twitter.com/MoodeAudio | http://github.com/moodeaudio
Reply
#23
(04-22-2020, 04:31 PM)Tim Curtis Wrote: I think the path has to have a colon ??
"192.168.0.18:/volume1/Music"

I don't have time to walk the code but I resurrected my virtual Synology NAS a bit ago. Host DS3615xs exporting  directory /volume1/Music.

I entered "DS3615xs/volume1/Music" in moOde's Source Music config and get a green checkmark.

From the command line, mount shows

Code:
DS3615xs:/volume1/Music on /mnt/NAS/DS-NFS type nfs (ro,relatime,vers=3,rsize=131072,wsize=131072,namlen=255,hard,nolock,proto=tcp,timeo=600,retrans=2,sec=sys,mountaddr=192.168.1.222,mountvers=3,mountport=892,mountproto=udp,local_lock=all,addr=192.168.1.222)


Close enough for my taste.

Regards,
Kent
Reply
#24
Works for me.
Enjoy the Music!
http://moodeaudio.org | http://twitter.com/MoodeAudio | http://github.com/moodeaudio
Reply
#25
But I tested on a beta r6.5.0, not the OP's r6.2.1.

I still think he should try mounting the Samba share since he's apparently already enabled it.

Regards,
Kent
Reply
#26
(04-22-2020, 04:43 PM)Tim Curtis Wrote: Works for me.

I tested all the command and I have the green checkmark. after I update mpd but the folder Music doesn't appear.
I think  it comes from sinology DS 218 play and den 6.2

Do you think it 's possible to use smb and not NFS? because with my iPhone when  I used app folder I can't play the song . And in support apple, there says: folderol ios13 use smb protocole.???
Reply
#27
The symptom "share mounts successfully but MPD update finds no music files" is almost always indicative of permission issues on the NAS. Switching to Samba prolly won't make a diff but its worth a try.
Enjoy the Music!
http://moodeaudio.org | http://twitter.com/MoodeAudio | http://github.com/moodeaudio
Reply
#28
(04-22-2020, 04:55 PM)romain64 Wrote:
(04-22-2020, 04:43 PM)Tim Curtis Wrote: Works for me.

I tested all the command and I have the green checkmark. after I update mpd but the folder Music doesn't appear.
I think  it comes from sinology DS 218 play and den 6.2

Do you think it 's possible to use smb and not NFS? because with my iPhone when  I used app folder I can't play the song . And in support apple, there says: folderol ios13 use smb protocole.???

when I use smb(service folder I don't check Nfs just smb) and i have a red X . 
I send the errors.


Attached Files Thumbnail(s)
           
Reply
#29
(04-22-2020, 05:02 PM)romain64 Wrote:
(04-22-2020, 04:55 PM)romain64 Wrote:
(04-22-2020, 04:43 PM)Tim Curtis Wrote: Works for me.

I tested all the command and I have the green checkmark. after I update mpd but the folder Music doesn't appear.
I think  it comes from sinology DS 218 play and den 6.2

Do you think it 's possible to use smb and not NFS? because with my iPhone when  I used app folder I can't play the song . And in support apple, there says: folderol ios13 use smb protocole.???

when I use smb(service folder I don't check Nfs just smb) and i have a red X . 
I send the errors.

Hello, I just read the following post: Ghezo art: NAS mounted volume not visible in library. Would it be the same problem for me?
Reply
#30
Not the same problem but ultimately the same fix. Create your NFS share correctly and mount/connect to it in Moode, the issue still seems to be how you've setup your NFS share and not a problem relating to Moode or your Raspberry Pi.
My test with the find command showed that the share/export was mounted and accessible but it looks like you've changed it again so it now doesn't work.
  • Create your NFS share, include an all_squash in the export options so that all users can read/write files as the owner of the files.
  • Mount the NFS share in Moode
  • Update your library/mpd database, if there are tagged audio files on the share and they're readable by the mpd user they'll be imported into mpd's database.
Reply


Forum Jump: