Thank you for your donation!


Official moOde 6.5.0 support thread
(04-27-2020, 05:13 AM)DRONE7 Wrote:
(04-27-2020, 02:09 AM)DRONE7 Wrote:
(04-27-2020, 01:54 AM)seanbranam Wrote:
(04-27-2020, 01:09 AM)DRONE7 Wrote:
(04-27-2020, 12:37 AM)seanbranam Wrote: Thanks for your work Tim, I hope to contribute as best I can.
I'm not a coder, but am a seasoned (old) IT professional.

I've noticed something odd with adding radio stations.

Some entries do not update the jpg when I enter them.
The last version didn't have any problem with my entries.

Let me know what you'd like from me and I'll provide it
This isn't urgent. The stations play fine.

2 things to check...from the main (m) moOde menu... Update Library...this regenerates the thumbnail cache at the same time...
Same menu, after update do a Refresh.
Reopen the radio page...are the .jpgs showing now ?

-Bob


Nope.
I refreshed from moode, as well as the browser.

These are stations you have added manually and with artwork ?
One final refresh to try...at the top of the radio library page 3rd icon in (between 'home' and 'settings') is a refresh for the radios. Does that work?

Might be a bug...?
If I create a station but do not name it...ie  leave first input as "New Station"  then I can add , save and have instantly appear in the radio page an image of my choice. Smile
If I create a station and name it  and add an image then I can no longer get any added image to appear no matter how many and what type of refresh I do it stays as the default 'moOde audio' Sad
-Bob

I'm not able to repro. I successfully aded a station named AAA New Station w/logo and it appeared instantly in Radio view.

You could try verifying the logo image was actually actually created by looking in the directories below for the file.

Code:
pi@rp3:~ $ ls -l /var/www/images/radio-logos/
total 14916
-rwxr-xr-x 1 root root  27836 Apr 26 16:37 '1.FM - Blues Radio.jpg'
-rwxr-xr-x 1 root root  72937 Apr 26 16:37 '2BOB Radio 104.7 FM.jpg'
-rwxr-xr-x 1 root root  20094 Apr 26 16:37 '4ZZZ FM 102.1 - Alternative.jpg'
-rwxr-xr-x 1 root root 214014 Apr 26 16:37 '6forty Radio.jpg'
-rw-r--r-- 1 root root  12943 Apr 27 07:50 'AAA New station.jpg'
.
.

pi@rp3:~ $ ls -l /var/www/images/radio-logos/thumbs
total 2468
-rwxr-xr-x 1 root root  6553 Apr 26 16:37 '1.FM - Blues Radio.jpg'
-rwxr-xr-x 1 root root 19200 Apr 26 16:37 '2BOB Radio 104.7 FM.jpg'
-rwxr-xr-x 1 root root  6612 Apr 26 16:37 '4ZZZ FM 102.1 - Alternative.jpg'
-rwxr-xr-x 1 root root 25128 Apr 26 16:37 '6forty Radio.jpg'
-rw-r--r-- 1 root root  5472 Apr 27 07:50 'AAA New station.jpg'
.
.
Enjoy the Music!
http://moodeaudio.org | http://twitter.com/MoodeAudio | http://github.com/moodeaudio
Smile 
I've been trying to install fix 3 onto 6.5 as per Tim's instructions. I seem to download the file OK but when I try to unzip it I get:

   

What am I doing wrong.....or not doing right?  Big Grin

Cheers

Chris
(04-27-2020, 02:09 AM)Tim Curtis Wrote:
Code:
wget -q http://moodeaudio.org/test/r650-fix-3.zip
unzip -q r650-fix-3.zip -d www
sudo cp -r ./www/* /var/www
sudo rm -rf ./www
sudo rm ./r650-fix-3.zip

deleted


Attached Files Thumbnail(s)
       
Very odd regarding the issues with fix-3 zip file. I just tried wget and unzip and no issues. Maybe there is some ISP filtering happening on the zip. ??

I'll be releasing an in-place update for 6.5.0 -> 6.5.1 plus a whole 6.5.1 image later this week. That should cover any odd issues or breakage with the hot fixes.
Enjoy the Music!
http://moodeaudio.org | http://twitter.com/MoodeAudio | http://github.com/moodeaudio
(04-26-2020, 01:50 PM)Tim Curtis Wrote: Below are instructions for installing r650-fix-3 which contains the fixes listed in the release notes. Simply paste the block of commands at the SSH prompt and then perform a Browser refresh or two.

Code:
wget -q http://moodeaudio.org/test/r650-fix-3.zip
unzip -q r650-fix-3.zip -d www
sudo cp -r ./www/* /var/www
sudo rm -rf ./www
sudo rm ./r650-fix-3.zip

Code:
########################################################
//
// 2020-MM-DD TC moOde 6.5.1
//
########################################################

Updates

- UPD: Remove Radio and Playlist search result tallies

Bug fixes

- FIX: Playlist not auto-scrolling in certain cases
- FIX: Playlist item line 2 left margin not correct
- FIX: Track info formatting from Folder view
- FIX: Position issue with search reset buttons
- FIX: Incorrect volume level when unmuting

Bump
Enjoy the Music!
http://moodeaudio.org | http://twitter.com/MoodeAudio | http://github.com/moodeaudio
(04-24-2020, 09:02 PM)Tim Curtis Wrote: Hi,

Post all bug reports for moOde 6.5.0 in this thread. Please paste log output, scripts, etc in code boxes for readability.

-Tim

moOde 6.5.0 (with the 6.5.1 test patch) has stopped working. Cannot play anything, and the Tag view does not display the covers for the selected album, hence there is nothing to click on to play anything. Also I cannot navigate the folder view (if I click on a disk name, it does not go down). No error message in the log at /var/log/mpd/log Rebooting brings it back to the same state, i.e. totally unfunctional.

[Image: what-2.jpg]
Shocked 
When I switched from soft- to hardware volume this morning at 06:45am !! the hifiberry Amp2 (2x30W connected to Klipsch speakers with 94db/W/m) blowed me out off the room Angel because it started with 100% before the electronic fuse of the power supply stopped the party Smile Smile Smile .

After:
Code:
wget -q http://moodeaudio.org/test/r650-fix-3.zip
...

all works well, thank you!

Best regards
Norbert
Look for 6.5.1 today followed by in-place update 6.5.0 -> 6.5.1 :-)
Enjoy the Music!
http://moodeaudio.org | http://twitter.com/MoodeAudio | http://github.com/moodeaudio
(04-27-2020, 12:55 PM)Tim Curtis Wrote: Very odd regarding the issues with fix-3 zip file. I just tried wget and unzip and no issues. Maybe there is some ISP filtering happening on the zip. ??

I'll be releasing an in-place update for 6.5.0 -> 6.5.1 plus a whole 6.5.1 image later this week. That should cover any odd issues or breakage with the hot fixes.

okie dokie. We’ll blame it on Brexit!

Can’t say I’m overly bothered, so will wait for the update Smile
This thread will be closed due to the release of moOde 6.5.1 and in-place update for 6.5.0 -> 6.5.1.

There is a new support thread for 6.5.1 :-)

-Tim
Enjoy the Music!
http://moodeaudio.org | http://twitter.com/MoodeAudio | http://github.com/moodeaudio


Forum Jump: