Thank you for your donation!


cuts in music played from USB Disk
#1
When I play USB music in raspberry at moode 4.1, there are short breaks / cuts in the song. Is it the fault of weak USB in raspberry? Do you know a similar problem? I've Rpi3B.
Reply
#2
A couple of quick things to try..
moOde>Configure>System set the "USB (UAC2)" fix to ON and reboot.
moOde>Configure>System check that "Max USB current 2X" is ON (should be default for Rpi3B)

Otherwise some more info is needed.... What Dac, what usb storage device,what file type and quality etc..
Post output from..moOde>System Info

Reply
#3
The card is HiFiBerry Digi+ Pro. Separate power supplies for card and raspberry. The USB drive also has its own separate power supply.

Both options were tested without solving the problem. I will attach the systeminfo result immediately.
Reply
#4
By the strangest of coincidences I have the same card on a Pi2B....
USB playback is good without interruption or dropouts. I am powering the Hifiberry from the Pi.

You could put some files on a usb stick and try that to see if there is a problem with the usb storage drive.
How are you powering the Hifiberry Digi+ pro ?  just the 5v or 5v and 3.3 ?

Ah... just remembered... the jumper by the coax transformer (galvanic isolation) is a fix for earthing loops...see the Hifiberry site for details...
Here is one of many...https://support.hifiberry.com/hc/en-us/community/posts/207749389-HiFiBerry-Digi-Pro-beta-test?page=3

Very short dropouts can be caused by emi from lighting switches etc... again, experiment with the jumper. Also you could try using the Toslink output if your dac has this as input.
https://support.hifiberry.com/hc/en-us/c...al-Quality

Reply


Forum Jump: