Thank you for your donation!

Solved: No Web-UI after wifi-setup

Guten tag!

It's hard for me to make order out of the various clues you've posted. Somehow we have to sort out what may be a networking issue vs what may be a moOde issue. Turning on WiFi should not be killing any essential moOde processes. I'm just going to toss out some random thoughts.

1) in post #3 you presented a reasonable looking output from for an unconfigured system connected to Ethernet. Looking at the network info:

20200504 063928 worker: -- Network
20200504 063928 worker: eth0 exists
20200504 063928 worker: IP addr (
20200504 063928 worker: Netmask (
20200504 063928 worker: Gateway (
20200504 063928 worker: Pri DNS (
20200504 063928 worker: Domain  (localdomain)
20200504 063928 worker: wlan0 exists
20200504 063928 worker: wifi country (US)
20200504 063928 worker: wlan0 SSID is blank
20200504 063928 worker: eth0 addr exists, AP mode not started
20200504 063928 worker: wlan0 address not assigned

These are normal values for an IPv4 network with a consumer-grade router assigning the customer-side LAN to a traditional private subnet 192.168.1.x and with DHCP enabled.

Then in post #10  you mention "I also switched IPv6 off for testing....". What is IPv6 vis-a-vis your network and how did you switch it off? 

While some components of moOde are not yet IPv6-ready, the underlying Raspbian OS is and does enable IPv6 at the network interfaces. Recently, I have been experimenting with dual stack IPv4/IPv6 on my LAN. I don't see any problem with moOde running in this environment as an IPv4 client but it definitely won't work correctly against an IPv6-only host/browser.

2) The use of "moode.local" is independent of the network issue. The .local suffix is the indicator that you are asking mDNS to resolve the address of hostname "moode" (this process is called zero-configuration networking). It should work in most browser/OS combinations except on Android.

The use of the numeric IP address should always work. If it doesn't then I would suggest the wrong address is being tried. Please note that when WiFi is enabled, your moOde player will have a different IP address for the WiFi interface than it had for the Ethernet interface. That's why it's nice to be able to use a symbolic hostname instead. Various methods are available to determine what the IP address is. Probably the easiest is to ask the router using whatever UI it has. Next easiest is to use a phone- or tablet-based network sniffer app like Fing. Third easiest is to become proficient with Linux command line usage.

3) Don't change so many things randomly. I gather you went from the working system described in post #3 to a semi-responsive system described in post #7. If you get back to that, there are Linux command line exercises we can do in a working ssh session to gather more information if you are up for it.

Hi Kent,
yes, thanks, I absolutely will do..
and you are right, my info about switching off IPv6 was a bit confusing. It was just some sort of last wild guess. I switched it off manually by editing the file /etc/sysctl.conf (adding net.ipv6.conf.all.disable_ipv6 = 1).  I have to admit, last time working with such kind of stuff was 20 years ago, I'm no expert - so better ignore that piece of information as it probably was nonsense Wink.

I have set up a fresh system, without anything configured (just did a first boot and positively checked if the ui is accessible). So right now it is connected via ethernet, audio is not configured.

Just to clearify,  as soon as I configure my wifi (and unplug ethernet cable), I still can access the system over wifi via ssh (so a wrong IP is not the problem - I always get them with the help of a network scanner). But the web-ui doesn't show up, and via ssh the 'moodeutl -l' command shows only the first lines (as shown in my initial post), and running the '' as mentioned by Tim doesn't give any output but leaves the ssh-connection nonresponding.

Ciao Chris
The symptom "works over ethernet but not over wifi" suggests a network issue external to moOde software.

From Mac, Linux or Windows client you should be able to ping any of the hosts on your network by their host name for example "ping moode" regardless of whether they are connected via Ethernet or Wifi.
It is possible to ping and to connect via ssh, even after I set up wifi and the ui is not showing anymore.
I set up Volumio for testing the system, there wifi (as well as audio) works.
I also tried your last version 6.5.1 but no luck either. Right now I don't know if there is anything left trying out Sad
Maybe really hardware is faulty, but it doesn't seems obvious to me.
Soo.. it turned out to be a really dumb error.. unstable power.
I found in the output of 'dmesg' a line saying 'Under-voltage detected! (0x00050005)'.
Just used a different USB cable and now it worked!

It's almost embarrasing, but as I had been trying two different supplies (one labeled with up to 8A) with a short USB cable, and power via the i2s rail as well I hadn't thought about that. So powering via the Mamboberry might was unstable and the cable was not good enough.

I don't understand why Volumio had been working and why configuring the wifi triggered that kind of problem. And why the output of the command 'moodeutl -l' stops after the System section (ok, next part is the network part, but I would have thought that reporting still would continue even if something went wrong - or showing some error). 
But it seems save to say, if you are running in curious problems you should connect via ssh, execute 'dmesg' and have a look for an error regarding voltage.. 

Thanks for trying to help me out!
I'm happy now Smile

Forum Jump: