Thank you for your donation!


Solved: Configuring Windows To Access Moode USB Drive
#11
And my only Windows host is a 10-year laptop which started as a Win7 machine, was turned into a dual-boot Win7/Linux machine, and then upgraded some years ago to a dual-boot Win10/Linux machine.

Just today I finally bit the bullet and replaced the aging hard drive with an SSD. This time I made it a single-boot LInux machine with Win10 installed as a virtual machine running in Oracle VirtualBox. For this I downloaded a fresh 5.4GB WIn10_1909_English_x64.iso image from Microsoft.

When I started up the virtual Win10, it promptly found all my moOde players and displayed them as Computers in the Network section of the File Manager. ?!?!?!   Clicking on one and drilling down to the NAS caused the Windows Media Player to fire up when the music files were discovered.

Color me confused by Microsoft.

Regards,
Kent
Reply
#12
lol, its the inspiration that counts :-)
Enjoy the Music!
http://moodeaudio.org | http://twitter.com/MoodeAudio | http://github.com/moodeaudio
Reply
#13
(05-25-2020, 08:58 PM)kurek Wrote: Problem solved - that took a lot more trial and error than would have been nice but hopefully this helps future users!

Link to solution here: https://support.microsoft.com/en-us/help...indows-ser

Actual steps to solution here:

Open "Local Group Policy Editor" by searching in Start Menu or going to Run and running gpedit.msc, then go to Computer Configuration\Administrative Templates\network\Lanman Workstation and: "Enable insecure guest logons"




After performing the above action,  mapping the drive as a network location was pretty much immediate, no reboot even. 

Thanks for your assistance and patience,  now on to the fun bits.  

@kurek

You may claim total noobiness on Linux Wink but you do have Windows chops... Excellent result.
Reply
#14
At some point we'll have to turn this info into a Guide, but since I posted incomplete info here, I'm posting the followup here.

I now have fresh installs of Windows 10 Home and Windows 10 Pro running as guest OSes in Oracle VirtualBox on my Linux box.

Out of the box, Windows 10 Home sees moOde players in the network section of the File Explorer and can mount the moOde shares.

Out of the box, Windows 10 Pro does not see the moOde players and requires additional work to mount the shares. One can use either 'net' comands as I posted or make changes with the 'Local Group Policy Editor' as @kurek  posted in order to mount the moOde SMB shares.

Truth to tell, I installed the Home edition by accident the other day and installed the intended Pro edition only this morning, otherwise I wouldn't have discovered this. In retrospect, I'm not surprised that Microsoft has dialed down the security features a bit so Harry Homeowners can access all their existing consumer-grade gear.

Regards,
Kent
Reply


Forum Jump: