Thank you for your donation!

Problem: GPIO button false trigger on startup
(06-25-2020, 12:50 AM)gbh_uk Wrote: So, potentially the bug could be that the button is connected to GPIO 8, the capacitor is connected to GPIO9, and the script is controlling GPIO3, which is not connected to anything at all.
Here's the pinout that I believe is correct
If I'd used the wrong pins neither the button nor the relay would work at all Smile

I've tried it with the button on gpio 12 (that doesn't have any capacitors or any interfaces like i2c) and I also tried powering the system with power bank to avoid any kind of interference, but the problem didn't go away. The next step is to try a clean install on another sd card I guess.

(06-25-2020, 01:08 AM)TheOldPresbyope Wrote: I forgot to ask. Just for completeness, what model RPi and, if an RPi4B, have you tried the same with an earlier model?
Sorry, forgot to mention that, but you can see it in the logs I posted:
20200624 185221 worker: Raspbian (10.3)
20200624 185221 worker: Kernel   (4.19.115-v7+ #1305)
20200624 185221 worker: Platform (Pi-3B 1GB v1.2)
20200624 185221 worker: ARM arch (armv7l, 32-bit kernel)

Messages In This Thread
GPIO button false trigger on startup - by waffle - 06-24-2020, 04:21 PM
RE: GPIO button false trigger on startup - by waffle - 06-25-2020, 01:52 AM

Forum Jump: