Thank you for your donation!


Instruction Guide Radio stream recorder
#21
(08-02-2020, 06:45 PM)Ikke4 Wrote: i used radio recorder kast week to record the pearl jam concert on Kink FM, but today i went to my.ip:8080 and safari told me it could get there. i did a moode upgrade a couple off days ago, can that trigger the problem? 

how can i check that radio recording has started


@Tim Curtis radio recording would be a bonus app in  moode, (in my opinion) 

grt ikke

Did you mean to say 'safari told me it could not get there'. If so, the moOde update will have broken the start up command in rc.local.
To reset this, drop down to the command line in moOde. Use ssh or even moOdes built in ssh terminal server by going to 'configure', 'system' and scroll down to 'local services'. You will see the option 'SSH term server'. On the command line type:
    sudo mcedit /etc/rc.local

At the end of the file just before 'exit 0' you should have the following two lines:
    # Start the radio recorder web server.
    /usr/bin/php -q -S 0.0.0.0:8080 -t /home/pi/RadioRecorder >/dev/null 2>&1


If not, add them and press F2 followed by F10 and then reboot.
    sudo reboot

As you performed the moOde upgrade after recording the concert it will still be in the 'Library', 'Folder', 'Recordings' tab.
Reply
#22
(08-02-2020, 09:07 PM)TheMetalHead Wrote:
(08-02-2020, 06:45 PM)Ikke4 Wrote: i used radio recorder kast week to record the pearl jam concert on Kink FM, but today i went to my.ip:8080 and safari told me it could get there. i did a moode upgrade a couple off days ago, can that trigger the problem? 

how can i check that radio recording has started


@Tim Curtis radio recording would be a bonus app in  moode, (in my opinion) 

grt ikke

Did you mean to say 'safari told me it could not get there'. If so, the moOde update will have broken the start up command in rc.local.
To reset this, drop down to the command line in moOde. Use ssh or even moOdes built in ssh terminal server by going to 'configure', 'system' and scroll down to 'local services'. You will see the option 'SSH term server'. On the command line type:
    sudo mcedit /etc/rc.local

At the end of the file just before 'exit 0' you should have the following two lines:
    # Start the radio recorder web server.
    /usr/bin/php -q -S 0.0.0.0:8080 -t /home/pi/RadioRecorder >/dev/null 2>&1


If not, add them and press F2 followed by F10 and then reboot.
    sudo reboot

As you performed the moOde upgrade after recording the concert it will still be in the 'Library', 'Folder', 'Recordings' tab.

YES thank you, the lines in rc.local weren't there!  so after reading them the radio recorder webserver was back in action... 

bytheway mcedit wasn't found..  nano it is!
Reply


Forum Jump: