Thank you for your donation!


Solved: Some radio station images not displayed
#1
I am having a problem when creating some radio stations.

When I import the logo image I get the small thumbnail displayed ok. Pressing update takes me back to 'Browse by Radio Stations'. It is at this point that some images are not displayed.
I have cleared the browser cache and re-loaded the page to no avail. All the stations play ok but still some images are not displayed. Are there any restrictions apart from the 1M image limit?
The image filename consist of a maximum of 30 alpha-characters, underscore, space, hyphen and apostrophe.

One of the images has the following details:
    470 x 290
    72 x 72 DPI
    Print size: 6.53 x 4.03 inches
    24 Bits per pixel
    28512 unique colours
    Disk size: 36,890 bytes
    Memory size: 409,520 bytes

The browser tried is Firefox and Edge and I am using moOde v6.6.0
Reply
#2
You will prolly need to zip up one of the images and PM me a download link so I can see if I can repro. I'll need the playable URL as well.
Reply
#3
Your image is ok but there is a bug in the code block that updates a station. I'm testing a fix and if you know some Linux SSH I can push the commit a bit later so you can try it out.
Reply
#4
(07-13-2020, 10:45 PM)Tim Curtis Wrote: Your image is ok but there is a bug in the code block that updates a station. I'm testing a fix and if you know some Linux SSH I can push the commit a bit later so you can try it out.

I am ok with SSH and the command line.
I have looked at the repo and have seen the changes in the 3 files. I've copied them into the following after making backups:

    /var/www/command/moode.php
    /var/www/templates/indextpl.html
    /var/www/templates/indextpl.min.html


The permissions were set as 755 and the owner as root:root and the pi was rebooted.

The images can now be saved in the 'Browse by Radio Stations' tab and appear after a page refresh ok. However, when adding user added radio stations to the playlist, the images are not displayed whereas the moOde supplied stations are displayed ok.

On the front playlist tab I get 'Cover art not found'. The station name is ok as well as the artist, track and bit rate.


 /var/log/moode.log shows no errors. 'Worker' logs 'Job setlogoimage' when the images were saved.
Reply
#5
Ok, I'll investigate.
Reply
#6
I ran a couple of tests and didn't experience any issues.

1. Added a new station
2. Play and the logo shows in the playback panel
3. Updated the station with a different logo
4. Play and the new logo appears in the Playback panel

The large logo is in /var/local/www/imagesw/radio-logos/
Maybe try verifying the SQL entries. User added stations should be > 499
sqlite3 /var/local/www/db/moode-sqlite3.db "select * from cfg_radio"
Reply
#7
(07-14-2020, 09:22 PM)Tim Curtis Wrote: I ran a couple of tests and didn't experience any issues.

1. Added a new station
2. Play and the logo shows in the playback panel
3. Updated the station with a different logo
4. Play and the new logo appears in the Playback panel

The large logo is in /var/local/www/imagesw/radio-logos/
Maybe try verifying the SQL entries. User added stations should be > 499
sqlite3 /var/local/www/db/moode-sqlite3.db "select * from cfg_radio"

Hi Tim

The images were ok. It was the sqlite database entry. For some reason I had a space character before the leading underscore on the station name.

Original entry:
    500|http://edge-bauermz-02-gos1.sharp-stream.com/planetrock.mp3| _Planetrock|u|local|Hard Rock||English|UK|Europe|112|mp3

After deletion and creation of the station:
    522|http://edge-bauermz-02-gos1.sharp-stream.com/planetrock.mp3|_Planetrock|u|local|Hard Rock||English|UK|Europe|112|mp3

All ok now. Just another 21 stations to change.

Many thanks and just donated.
Reply
#8
Nice :-)

I should prolly add to the TODO list to trim the entries from the add/edit screens.
Reply
#9
(07-14-2020, 10:30 PM)Tim Curtis Wrote: Nice :-)

I should prolly add to the TODO list to trim the entries from the add/edit screens.

I have just added an issue to the moOde github page.
Reply
#10
Cool :-)
Reply


Forum Jump: