Thank you for your donation!


Mpd 0.22 git stops for two seconds
#1
I prefer to use MPD 0.22, it certainly sounds better to me, but I have had a problem for several versions of Moode, which seems to indicate that it is an MPD problem, although I do not see it commented on in the Forum, which concerns me and leads me to the conclusion that it could be a problem in my hardware configuration. 


When playback of any track begins, regardless of the origin (usb, Tidal...) and file type, the sound disappears for 2 seconds when it reaches 8-9 seconds after the track has started, otherwise everything perfect. 

I think I've tried adjusting all MPD values, without success. 

Moode 6.7.1, Khadas TB, Raspi 4 4gb. 

I hope I explained myself well, if anyone has any, I'd appreciate some help. 

Thanks 
Edu.
Reply
#2
If you are using stock 6.7.1 without any of those OS tweaks or other add-in's then the symptom would suggest something external to moOde software for example a network issue, NAS issue, SDCard issue, other hardware issue etc.
Enjoy the Music!
http://moodeaudio.org | http://twitter.com/MoodeAudio | http://github.com/moodeaudio
Reply
#3
Thanks Tim this happens with any source, from the Moode interface and also from Bubbleupnp.

I have an oled screen set up, and a RemotePi
Reply
#4
@Edues

I have been using a Khadas Tone Board for more than a year---currently with moOde 6.7.1 on an RPi4B but previously with every version of moOde released since 6/2019 and with an RPi3B+ before I got the Rpi4B. It's been used with different versions of mpd including 0.22~git and with both 32-bit and 64-bit kernels. I have never experienced the gap in playback you describe.

The question implicit in Tim's response is, do you experience this gap in a test environment with a clean install of moOde 6.7.1 with no changes in default audio settings (other than selecting "Khadas Tone Control"), with the default 32-bit kernel, and with no hardware/software add-ons?

Beyond your focus on mpd-0.22~git, which is already one change from the proposed test environment, you mention an oled screen setup and a RemotePi, which suggest both hardware and software add-ons.

You might also consider trying your KTB on some other computer, even a laptop. If the gap persists, I'd suggest you go to the Khadas forum with your issue. You may have a defective KTB.

Regards,
Kent
Reply
#5
Thanks Kent, I'm going to prepare a clean installation and check the results.

I've tried the KTB on Windows without any problems.

Regards
Edu
Reply
#6
@Edues

Glad to hear your KTB seems to be working since there have been a number of posts on the Khadas Forum over the past year about failures. Granted they were more frequent earlier, but still....

I received my KTB a year ago June. It didn't have the latest firmware so I immediately updated it to v1.04 which I believe is the latest version.

While I'm uncertain how power issues would cause the audio gap you observe, as always be sure to have a good power supply with adequate juice for both RPi4B and KTB and use short, good quality USB cables between the supply and the RPi, and between the RPi and the KTB.

Good luck. I think the KTB is a very decent performer at US$100. While it can play DSD material natively or via DoP, I have only a few test tracks to make sure both modes work with moOde. My ears are too old to bother buying music in DSD format. Besides, it's a nuisance to have to control the volume downstream of the DAC when in DSD mode. With PCM material it has been quite good for me.

Regards,
Kent
Reply
#7
I have started a new installation.
I have configured the KTB with MPD 0.22, the tft display, and the Remotepi, so far the MPD stop problem has not occurred.
Then I have configured the oled display, according to the antiprism method, everything is correct after the installation of Cava Spectrum and mpd_oled, but when I activate the oled display, the problem appears, when I turn it off. the problem disappears.

I have just the right technical capacity to carry out these installations thanks to how well they are explained by the developers, I am very grateful for all that work, but I really don't understand what I am doing, so I think it is going to be difficult for me to solve this, I don't even know how to explain it correctly, much less understand what is being said.

I think I will discard the oled screen for now, those stops in the reproduction are more painful than the contribution of the oled screen, that although I like it very much, it is dispensable in this case.

Thanks Kent and Tim for your interest.

Regards,
Edu
Reply
#8
I have verified that although the oled screen is off, the problem persists, in a more random way, with a minor incidence, so the problem is related to the Cava or mpd_oled.

Edu.
Reply
#9
Hi Edu

Check if cava or mpd_oled are really running with ps ax | grep "cava\|mpd_oled"


Code:
pi@moode:~ $ sudo systemctl stop mpd_oled

pi@moode:~ $ ps ax | grep "cava\|mpd_oled"

20643 pts/0    S+     0:00 grep --color=auto cava\|mpd_oled

pi@moode:~ $ sudo systemctl start mpd_oled

pi@moode:~ $ ps ax | grep "cava\|mpd_oled"

20720 ?        Dsl    0:00 /usr/local/bin/mpd_oled -o 6 -b 21 -g 1 -f 25
20724 ?        S      0:00 sh -c cava -p /tmp/cava_config_jin9v2
20725 ?        Sl     0:00 cava -p /tmp/cava_config_jin9v2
20783 pts/0    S+     0:00 grep --color=auto cava\|mpd_oled

If mpd_oled and cava are not running then the problem should be isolated to the configuration changes for the mpd_oled install. Here are some possibilities --

Extra packages installed for mpd_oled or cava:
Maybe the khadas tone board installation uses particular packages/programs/libraries that are overriden by packages installed during the mpd_oled installation. 

i2c-dev in /etc/modules and dtparam=i2c_arm_baudrate=400000 added to /boot/config.txt (if your oled is I2C):
As far as I can see the Khadas Tone OLED support is limited to making the relevent pins from the Pi available on a header, but maybe it is using I2C (or some other configuration software for the board has configured it) and there is some kind of conflict.

Adding the FIFO output to /etc/mpd.conf:
This doesn't seem like it could cause your issue (but maybe there are some changes in MPD 0.22 affecting the FIFO configuration)


I recommend running 'top' (the command is called top) in the ssh terminal while playing music. It will show you resource usage. You could see if anything unusual happens when the audio pauses. Are programs running at 100% cpu? Is all the memory being used up? Are any values obviously different?

Another possibility is that if you see the issue with mpd_oled not running, but rarely, the underlying issue may exist before you install mpd_oled, but didn't occur while you were testing, i.e. running mpd_oled may exacerbate the issue, perhaps because of the extra resource usage, but not because of the configuration changes or packages installed).

Adrian.
Reply


Forum Jump: