Thank you for your donation!


Official moOde 7.1.0 support thread
(04-06-2021, 02:38 PM)Botte Wrote:
(04-06-2021, 02:34 PM)Tim Curtis Wrote: 1. Which one do you connect to from the control point, "Moode UPNP" or "Moode UPNP-UPnP/AV"?
2. Are both Open home and A/V services on in moOde UPnP Config?

I use "Moode UPNP-UPnP/AV"

A/V services is on, Open home is on.

I tried changing the name of the renderer on server to just "Moode UPNP", still didn't work.

I see that it still show's up as "Moode UPNP-UPnP/AV" on the Device list in Windows.
Reply
Interesting. It looks like the cover art fetcher needs a way to determine when to task on the "-UPnP/AV" suffix to the renderer name.

I'll investigate.
Enjoy the Music!
moodeaudio.org | Twitter Feed | Git Repo
Reply
Hello,
I have had a problem for a while (back to moode6? still ther with moode 7.1), but it really hasn't bothered me too much so I have not posted it. When one file is playing and I go to play another about 25% of the time I get "OpenMpdSocks() failed". After reinitiating the action it works. I currently have radio buttons programed into my IR remote that do a mpc clear; mpc load""; mpc play. I have traced this error to mpc clear and even stop. It is slightly annoying as it requires multiple radio button operations to stick. Attached are results from my moodeutl -l
20210406 093836 watchdog: Error: MPD restarted (check syslog for errors)
20210406 094430 watchdog: Error: MPD restarted (check syslog for errors)
20210406 094431 moode.php: MPD connect failed: cmd=(playlist)
20210406 094448 moode.php: MPD connect failed: cmd=(playlist)
20210406 094448 watchdog: Error: MPD restarted (check syslog for errors)
20210406 094506 moode.php: MPD connect failed: cmd=(playlist)
20210406 094507 watchdog: Error: MPD restarted (check syslog for errors)
20210406 094834 watchdog: Error: MPD restarted (check syslog for errors)
20210406 094850 moode.php: MPD connect failed: cmd=(playlist)
20210406 094853 watchdog: Error: MPD restarted (check syslog for errors)
20210406 095135 moode.php: MPD connect failed: cmd=(playlist)
20210406 095138 watchdog: Error: MPD restarted (check syslog for errors)
20210406 095655 moode.php: MPD connect failed: cmd=(playlist)
20210406 095655 watchdog: Error: MPD restarted (check syslog for errors)
20210406 100304 worker: Job mpdcfg
20210406 100325 moode.php: MPD connect failed: cmd=(playlist)
20210406 100326 watchdog: Error: MPD restarted (check syslog for errors)
20210406 100354 worker: Job mpdcfg
20210406 100358 worker: Job mpdcfg


and syslog files
Apr 6 10:30:11 moode-pi3 rngd[400]: stats: bits received from HRNG source: 140064
Apr 6 10:30:11 moode-pi3 rngd[400]: stats: bits sent to kernel pool: 94336
Apr 6 10:30:11 moode-pi3 rngd[400]: stats: entropy added to kernel pool: 94336
Apr 6 10:30:11 moode-pi3 rngd[400]: stats: FIPS 140-2 successes: 7
Apr 6 10:30:11 moode-pi3 rngd[400]: stats: FIPS 140-2 failures: 0
Apr 6 10:30:11 moode-pi3 rngd[400]: stats: FIPS 140-2(2001-10-10) Monobit: 0
Apr 6 10:30:11 moode-pi3 rngd[400]: stats: FIPS 140-2(2001-10-10) Poker: 0
Apr 6 10:30:11 moode-pi3 rngd[400]: stats: FIPS 140-2(2001-10-10) Runs: 0
Apr 6 10:30:11 moode-pi3 rngd[400]: stats: FIPS 140-2(2001-10-10) Long run: 0
Apr 6 10:30:11 moode-pi3 rngd[400]: stats: FIPS 140-2(2001-10-10) Continuous run: 0
Apr 6 10:30:11 moode-pi3 rngd[400]: stats: HRNG source speed: (min=693.704; avg=767.798; max=810.089)Kibits/s
Apr 6 10:30:11 moode-pi3 rngd[400]: stats: FIPS tests speed: (min=2.480; avg=4.700; max=7.077)Mibits/s
Apr 6 10:30:11 moode-pi3 rngd[400]: stats: Lowest ready-buffers level: 2
Apr 6 10:30:11 moode-pi3 rngd[400]: stats: Entropy starvations: 0
Apr 6 10:30:11 moode-pi3 rngd[400]: stats: Time spent starving for entropy: (min=0; avg=0.000; max=0)us
Apr 6 10:31:15 moode-pi3 kernel: [10874.717774] bcm2835-i2s 3f203000.i2s: I2S SYNC error!
Apr 6 10:31:27 moode-pi3 systemd[1]: mpd.service: Main process exited, code=killed, status=11/SEGV
Apr 6 10:31:27 moode-pi3 systemd[1]: mpd.service: Failed with result 'signal'.
Apr 6 10:31:27 moode-pi3 rc.local[503]: MPD error: Connection refused
Apr 6 10:31:28 moode-pi3 rc.local[503]: MPD error: Connection refused
Apr 6 10:31:28 moode-pi3 systemd[1]: Started Music Player Daemon.
Apr 6 10:31:28 moode-pi3 rc.local[503]: MPD error: Connection refused
Apr 6 10:31:28 moode-pi3 rc.local[503]: MPD error: Connection refused
Apr 6 10:31:28 moode-pi3 rc.local[503]: MPD error: Connection refused
Apr 6 10:31:28 moode-pi3 rc.local[503]: MPD error: Connection refused
Apr 6 10:31:28 moode-pi3 rc.local[503]: MPD error: Connection refused
Apr 6 10:33:25 moode-pi3 systemd[1]: session-16.scope: Succeeded.
Apr 6 10:33:50 moode-pi3 systemd[1]: Started Session 17 of user pi.
Apr 6 10:41:41 moode-pi3 systemd[1]: session-17.scope: Succeeded.
Apr 6 10:48:49 moode-pi3 systemd[1]: Started Session 18 of user pi.
Apr 6 10:49:43 moode-pi3 systemd[1]: session-18.scope: Succeeded.
Apr 6 10:50:23 moode-pi3 systemd[1]: Started Session 19 of user pi.
when this happens. BTW I am running camilla and a python script to show whether a file is playing.
Reply
(04-06-2021, 06:09 PM)I found the source of the problem. Camilladsp causes a lag in stopping playback, particularly with long fir filters. Solution is to sop playback first then wait. Wrote: Hello,
I have had a problem for a while (back to moode6? still ther with moode 7.1), but it really hasn't bothered me too much so I have not posted it. When one file is playing and I go to play another about 25% of the time I get "OpenMpdSocks() failed". After reinitiating the action it works.  I currently have radio buttons programed into my IR remote that do a mpc clear; mpc load""; mpc play. I have traced this error to mpc clear and even stop. It is slightly annoying as it requires multiple radio button operations to stick. Attached are results from my moodeutl -l
20210406 093836 watchdog: Error: MPD restarted (check syslog for errors)
20210406 094430 watchdog: Error: MPD restarted (check syslog for errors)
20210406 094431 moode.php: MPD connect failed: cmd=(playlist)
20210406 094448 moode.php: MPD connect failed: cmd=(playlist)
20210406 094448 watchdog: Error: MPD restarted (check syslog for errors)
20210406 094506 moode.php: MPD connect failed: cmd=(playlist)
20210406 094507 watchdog: Error: MPD restarted (check syslog for errors)
20210406 094834 watchdog: Error: MPD restarted (check syslog for errors)
20210406 094850 moode.php: MPD connect failed: cmd=(playlist)
20210406 094853 watchdog: Error: MPD restarted (check syslog for errors)
20210406 095135 moode.php: MPD connect failed: cmd=(playlist)
20210406 095138 watchdog: Error: MPD restarted (check syslog for errors)
20210406 095655 moode.php: MPD connect failed: cmd=(playlist)
20210406 095655 watchdog: Error: MPD restarted (check syslog for errors)
20210406 100304 worker: Job mpdcfg
20210406 100325 moode.php: MPD connect failed: cmd=(playlist)
20210406 100326 watchdog: Error: MPD restarted (check syslog for errors)
20210406 100354 worker: Job mpdcfg
20210406 100358 worker: Job mpdcfg


and syslog files
Apr  6 10:30:11 moode-pi3 rngd[400]: stats: bits received from HRNG source: 140064
Apr  6 10:30:11 moode-pi3 rngd[400]: stats: bits sent to kernel pool: 94336
Apr  6 10:30:11 moode-pi3 rngd[400]: stats: entropy added to kernel pool: 94336
Apr  6 10:30:11 moode-pi3 rngd[400]: stats: FIPS 140-2 successes: 7
Apr  6 10:30:11 moode-pi3 rngd[400]: stats: FIPS 140-2 failures: 0
Apr  6 10:30:11 moode-pi3 rngd[400]: stats: FIPS 140-2(2001-10-10) Monobit: 0
Apr  6 10:30:11 moode-pi3 rngd[400]: stats: FIPS 140-2(2001-10-10) Poker: 0
Apr  6 10:30:11 moode-pi3 rngd[400]: stats: FIPS 140-2(2001-10-10) Runs: 0
Apr  6 10:30:11 moode-pi3 rngd[400]: stats: FIPS 140-2(2001-10-10) Long run: 0
Apr  6 10:30:11 moode-pi3 rngd[400]: stats: FIPS 140-2(2001-10-10) Continuous run: 0
Apr  6 10:30:11 moode-pi3 rngd[400]: stats: HRNG source speed: (min=693.704; avg=767.798; max=810.089)Kibits/s
Apr  6 10:30:11 moode-pi3 rngd[400]: stats: FIPS tests speed: (min=2.480; avg=4.700; max=7.077)Mibits/s
Apr  6 10:30:11 moode-pi3 rngd[400]: stats: Lowest ready-buffers level: 2
Apr  6 10:30:11 moode-pi3 rngd[400]: stats: Entropy starvations: 0
Apr  6 10:30:11 moode-pi3 rngd[400]: stats: Time spent starving for entropy: (min=0; avg=0.000; max=0)us
Apr  6 10:31:15 moode-pi3 kernel: [10874.717774] bcm2835-i2s 3f203000.i2s: I2S SYNC error!
Apr  6 10:31:27 moode-pi3 systemd[1]: mpd.service: Main process exited, code=killed, status=11/SEGV
Apr  6 10:31:27 moode-pi3 systemd[1]: mpd.service: Failed with result 'signal'.
Apr  6 10:31:27 moode-pi3 rc.local[503]: MPD error: Connection refused
Apr  6 10:31:28 moode-pi3 rc.local[503]: MPD error: Connection refused
Apr  6 10:31:28 moode-pi3 systemd[1]: Started Music Player Daemon.
Apr  6 10:31:28 moode-pi3 rc.local[503]: MPD error: Connection refused
Apr  6 10:31:28 moode-pi3 rc.local[503]: MPD error: Connection refused
Apr  6 10:31:28 moode-pi3 rc.local[503]: MPD error: Connection refused
Apr  6 10:31:28 moode-pi3 rc.local[503]: MPD error: Connection refused
Apr  6 10:31:28 moode-pi3 rc.local[503]: MPD error: Connection refused
Apr  6 10:33:25 moode-pi3 systemd[1]: session-16.scope: Succeeded.
Apr  6 10:33:50 moode-pi3 systemd[1]: Started Session 17 of user pi.
Apr  6 10:41:41 moode-pi3 systemd[1]: session-17.scope: Succeeded.
Apr  6 10:48:49 moode-pi3 systemd[1]: Started Session 18 of user pi.
Apr  6 10:49:43 moode-pi3 systemd[1]: session-18.scope: Succeeded.
Apr  6 10:50:23 moode-pi3 systemd[1]: Started Session 19 of user pi.
when this happens. BTW I am running camilla and a python script to show whether a file is playing.
Reply
I'm working on a new build of 7.1 on a Pi 3B+ and keep getting stuck in the same place. Am using the direct build method and everything goes well until I get down to Component 10, where I keep getting the message below. Have rebooted a number of times with same result. For what it's worth, I do not yet have a DAC attached. I haven't gotten one yet, just going one step at a time. Not sure if that matters.

Any advice appreciated. Thanks.
Code:
////////////////////////////////////////////////////////////////
//
// COMPONENT 10 - Allo Boss 2 OLED display
//
////////////////////////////////////////////////////////////////

Install Python libs
Reading package lists...
Building dependency tree...
Reading state information...
python-pil is already the newest version (5.4.1-2+deb10u2).
python-smbus is already the newest version (4.1-1).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Install Display driver
Install Systemd unit
cp: cannot stat './moode/lib/systemd/system/boss2oled.service': No such file or directory
** Error: Install failed
** Error: image build exited
** Error: reboot to resume the build
Reply
@eddywouldgo
You don't need a DAC to build the software.
Is there a specific reason why you don't download the working image, but try to build it yourself from scratch?
Reply
(04-08-2021, 12:16 AM)eddywouldgo Wrote: I'm working on a new build of 7.1 on a Pi 3B+ and keep getting stuck in the same place. Am using the direct build method and everything goes well until I get down to Component 10, where I keep getting the message below. Have rebooted a number of times with same result. For what it's worth, I do not yet have a DAC attached. I haven't gotten one yet, just going one step at a time. Not sure if that matters.

Any advice appreciated. Thanks.
Code:
////////////////////////////////////////////////////////////////
//
// COMPONENT 10 - Allo Boss 2 OLED display
//
////////////////////////////////////////////////////////////////

Install Python libs
Reading package lists...
Building dependency tree...
Reading state information...
python-pil is already the newest version (5.4.1-2+deb10u2).
python-smbus is already the newest version (4.1-1).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Install Display driver
Install Systemd unit
cp: cannot stat './moode/lib/systemd/system/boss2oled.service': No such file or directory
** Error: Install failed
** Error: image build exited
** Error: reboot to resume the build

That file is in the sources zip for the current version of mosbuild. 
http://moodeaudio.org/downloads/src/moode-r710.zip
Enjoy the Music!
moodeaudio.org | Twitter Feed | Git Repo
Reply
Hi,

My local UI crashes when moOde is on idle for a while, usually after the music has been paused or stopped playing.
I haven't been able to determine and exact amount of time, but at least 25'-30' are needed.

The local UI crashes with the error code RESULT_CODE_INVALID_CMDLINE_URL. Just clicking on Reload button shown, it's enough to recover.
moOde keeps running, I can search or play music through web interface or IR remote, just affects to the local UI.

I've attached a screenshot.

It seems to happen on every view, albums, play, coverview, but never when playing music. 

My setup is:

- Raspberry Pi 4 Model B 4GB
- 0,96" OLED display with pydPiper
- external 7" HDMI touch display
- never blank screen
- show coverview after 10'

Regards,
Joaquín


Attached Files Thumbnail(s)
   
Reply
Does it occur on a fresh image with no 3rd party software installed or modifications to system files for example /boot/config.txt, etc?
Enjoy the Music!
moodeaudio.org | Twitter Feed | Git Repo
Reply
(04-09-2021, 10:35 AM)Tim Curtis Wrote: Does it occur on a fresh image with no 3rd party software installed or modifications to system files for example /boot/config.txt, etc?

Sorry I forgot to tell, yes it's a fresh installation and the only software installed are Lirc for the infrared remote and pydPiper/docker for the OLED display.

The system files have been modified just to config HDMI display, OLED and LIRC, and one power button with a led.

I've added this to /boot/config.txt:

Code:
#Touch screen
hdmi_force_hotplug=1
config_hdmi_boost=7
hdmi_group=2
hdmi_mode=87
hdmi_drive=1
display_rotate=0
hdmi_cvt 1024 600 60 6 0 0 0

#lcd
dtparam=i2c_arm_baudrate=400000

#led power
enable_uart=1

# Enable the lirc-rpi module
dtoverlay=lirc-rpi
dtoverlay=gpio-ir,gpio_pin=18

And this to /etc/rc.local:

Code:
# IR
sudo -u pi irexec -d

I've been using this setup and same configuration since version 6, and even with 7.0 I haven't seen this error, just with 7.1.
Regards,
Joaquín.
Reply


Forum Jump: