Thank you for your donation!


Instruction Guide Camilla DSP
#11
@lurkio maybe it easier; try to use the HDMI 7.1 output with a HDMI 7.1 audio extractor.
I'm not sure if it really works, but for arround $50 you can buy a cheap quality device to see if it works at all. 
And if so buy another device to upgrade the sound quality to the required level. (like http://www.cypeurope.com/store/store/app....2-HDMI2.0 ).
With 8x channels the max samplerate is limited.

I tried the following procedure on my Pi 4, but I have no mini hdmi cable or audioextractor to verify if the audio plays correct:
  • Activate HDMI as active output device
  • Create new crossover.yml config with the example below
  • Upload the crossover.yml with upload button on the moode camilladsp config screen
  • Active the crossover configuration and press save
  • After that toggle the default device button to off and save
  • At the pipeline editor section
  • Toggle expert mode to on
  • Toggle status to on
  • Open the editor
  • In the playback device settings, change the channels from 2 tot 4
  • Connect with mini hdmi to hdmi cable to a hdmo 7.1 audio extractor.
  • If you now play music, you will see at the audio multichannel output is active



The crossover example config taken from the camilladsp site:

Code:
---
devices:
 samplerate: 44100
 chunksize: 1024
 capture:
   type: Alsa
   channels: 2
   device: "hw:Loopback,0,0"
   format: S16LE
 playback:
   type: Alsa
   channels: 4
   device: "hw:0"
   format: S16LE
   
mixers:
 to4chan:
   channels:
     in: 2
     out: 4
   mapping:
     - dest: 0
       sources:
         - channel: 0
           gain: 0
           inverted: false
     - dest: 1
       sources:
         - channel: 1
           gain: 0
           inverted: false
     - dest: 2
       sources:
         - channel: 0
           gain: -5.0
           inverted: false
     - dest: 3
       sources:
         - channel: 1
           gain: -5.0
           inverted: false

filters:
 highpass2k:
   type: Biquad
   parameters:
     type: Highpass
     freq: 2000
     q: 0.707
 lowpass2k:
   type: Biquad
   parameters:
     type: Lowpass
     freq: 2000
     q: 0.707
 bafflestep:
   type: Biquad
   parameters:
     type: Highshelf
     freq: 500
     slope: 6.0
     gain: -4.0

pipeline:
 - type: Mixer
   name: to4chan
 - type: Filter
   channel: 2
   names:
     - highpass2k
 - type: Filter
   channel: 3
   names:
     - highpass2k
 - type: Filter
   channel: 0
   names:
     - lowpass2k
     - bafflestep
 - type: Filter
   channel: 1
   names:
     - lowpass2k
     - bafflestep
Reply
#12
Here's a guide which I found useful. It's aimed at Roon users, but you don't actually need Roon. It walks you through a route to use REW to create a room correction convolution file that can then be loaded into Camilla DSP in Moode. https://community.roonlabs.com/t/a-guide...roon/23800

Edit: I just want to add that I have not been able to get this working correctly yet. The 'corrected' response when played back through Camilla has more deviations than the original. Further investigation showed that a frequency dip that I set at 1kHz became shifted up to around 2.5kHz. I followed the advice from @bitlab in another thread but had no success. I'll wait for Moode 7.2 to appear with its improved wav file converter, and if that doesn't change things I'll try asking for help in the Camilla DSP thread at diyAudio.
Reply
#13
(03-19-2021, 05:39 AM)DRONE7 Wrote: I went to the AutoEQ page and downloaded the AKG K240 Sextett minimum phase 44100Hz.wav

Hi Drone7,
 why not the 48k?
Reply
#14
(03-30-2021, 10:53 PM)Alaini93 Wrote:
(03-19-2021, 05:39 AM)DRONE7 Wrote: I went to the AutoEQ page and downloaded the AKG K240 Sextett minimum phase 44100Hz.wav

Hi Drone7,
 why not the 48k?

Was a trial on some cheap playback hardware.
Once it worked I used the 48k version on my main player.

@jonners 

Quote:Here's a guide which I found useful. It's aimed at Roon users, but you don't actually need Roon. It walks you through a route to use REW to create a room correction convolution file that can then be loaded into Camilla DSP in Moode

Thanks for that....copied off to read tonight. I have a Dayton mic that I think REW will accept. Not USB but fairly sure it will work...

Reply
#15
Am I correct in understanding that this only supports music files with 44.1 and 48kHz sampling rates? So no correction for higher sampling rates nor DSD? Using the stock parametric EQ functionality I am able to to apply DSP for PCM up through 384 and DSD64. Is the equalization in Camilla better than the stock parametric EQ?

Thanks for any help in understanding how this works!
Reply
#16
I wanted to ask that too.
ParamEQ stop at 18k, don't know where the dsp stop.
But it seems, or correct me if I'm wrong, you can listen to music with any sample rate using ParamEQ, but if you use Camilladsp, and listen to 44.1k music, you need to load the 44.1 file, and if you listen to 48k you need to load the 48k file.
I hope I'm wrong.
Reply
#17
Hmmmm... This is interesting. I loaded the "preset" conv_ae_oratory1990_hd800s and ran some test files. I tested 44.1, 96, 192, 352, DSD64 and DSD128. They all played. I know the EQ is working (or something is changing) as 2 of the files are MQA encoded and my DAC indicates that these are NO longer MQA files as they've been altered. The 2 DSD files were automatically transcoded to PCM before EQ was applied. My DAC showed both files as PCM 352.8kHZ/24-bit.

In any case, I've been trying to create my own set up using the instructions but having a bit of difficulty understanding how to do this, I'm going to keep at it for a little while longer...
Reply
#18
@Freezy94027 the 44.1/48k files has nothing to do with CamillaDSP itself, but the way how convolution filters work in general. The impulse response files are create for a specific samplerate.
Alternative you can alsa create regular filters with CamillaDSP (see the cdsp documentation). Those are independed of the samplerate.

The default provided impulse response files (= the files used for the convolution filter) by the AutoEQ project are indeed for 44.1k and 448k, but the tooling of the AutoEQ poject you can generate ir for any samplerate.

CamillaDSP doesn't know for which rate the ir files are, so indeed an ir will play with any samplerate. Only the output is only correct for one single samplerate. But if you read the documentaiton of camilladsp, you will read about a trick with the samplerate in the name, which automatically loads a different file for each samplerate.

@Alaini93
See story above. And you can recreate a peq with camilladsp without convolution files. You wil have far more choices of filters, including shelving etc. Those filters will be samplerate independent. Or even combine a convolution filters with other filters.


Remember moOde only integrates CamillaDSP, but moOde isn't CamillaDSP.
For more indepth information it is really worth it to visit the links in the second post of this thread and read the documentation of CamillaDSP it self.
Reply
#19
Thanks @bitlab for the info, this automatic loading of different files for each sample rate is good to know.
Reply
#20
@bitlab Thanks for taking the time to respond. I did read the documentation a few times but I'm afraid it is a bit over my head. I was successful in setting up the Quick Convolution based on the documentation, though trying to understand pipelines and such were beyond me. I also encountered some minor ticks and clicks periodically with higher sampling rate material as well as files requiring realtime DSD->PCM conversion.

In the end, I reverted to using the built in parametric EQ functionality. I'm not sure if it is less effective or lower quality, but it seems to do the job with minimal effort.

Thanks again.
Reply


Forum Jump: