The following warnings occurred:
Warning [2] count(): Parameter must be an array or an object that implements Countable - Line: 906 - File: showthread.php PHP 7.2.34 (Linux)
File Line Function
/showthread.php 906 errorHandler->error



Thank you for your donation!


What software and plugins use the ALSA Loopback device (Moode >= 7.1)
#1
Hi

I was wondering which software or plugins on Moode (>= 7.1) use (or might use) the ALSA loopback device, and which Loopback subdevice they use, and whether they include options for selecting a different subdevice.

My reason for asking is that I share a program (mpd_oled) that includes an audio visualiser (spectrum analyser) and to do this it needs a duplicate copy of the currently playing audio. I have previously been providing a patch for Moode to enable MPD to make the copy, but I will no longer be providing this patch, and will only be providing an ALSA method, which will require configuring and using the ALSA Loopback device.

I do not want the configuration instructions and script I provide to interfere with any other applications using the Loopback device, or for their configurations to interfere with mpd_oled, and so I am trying to find out if this is likely to be an issue and how it might be avoided.

Adrian.
Reply


Messages In This Thread
What software and plugins use the ALSA Loopback device (Moode >= 7.1) - by adrii - 03-19-2021, 08:29 AM

Forum Jump: