Thank you for your donation!

Editing flat.yml
I wanted to modify the flat profile in CamillaDSP so that it applied the same adjustment to gain as I have in the PEQ filters I'm using.  The aim is to avoid volume differences between the equalized and flat output.  I loaded the flat config into the pipeline editor, dropped the master gain down to -7, saved the file and activated it.  The check now fails saying the file is invalid:

Invalid config file!
filters: invalid type: sequence, expected a map at line 24 column 10
I now cannot load it back into the editor to undo the changes.

I tried creating a "new" file, then editing that in the same way, I get the same error.  Have I missed something obvious?
Just tried this and seems to work OK here. What did you edit the file with?
If you used something like Windows Notepad (which'll append extra carriage-return characters into text files from other OSs) it may be messing up the format.

Update: Well I just tried with Windows Notepad and it imported/checked fine with that too.
Was busy trying to reproduce a problem of another thread (, where this problem also occured.
Finally could reproduce the breakage of the flat.yml file. It only concerns with a config wit no filtersf and/or no mixers. Searching for a solution. Now try to find a solution.
I was editing with the pipeline editor, the file never left the CamillaGUI.

Forum Jump: