Thank you for your donation!


Problem: no sound from radio stations or library
#4
Hi. I have a similar issue.
I run Moode on RPi2. Updated it around 3-4 weeks ago and then most streams or mp3 files were playing, but didn't have sound (timer was running, the volume was ok, no muted). Not sure what was the update version though.
Restored from old SD card backup (from around February or March). It was fine again. Did all updates including updating Moode to the newest version. Still fine.
Then a couple of days later noticed the same issue.
Some radio stations don't work, some mp3 files are muted.
Seems like some kind of decoding problem.
I use 3.5mm jack as my audio output. HDMI is disabled in Moode configuration (not sure if only video is disabled or audio too)

Could someone help please?

Some log files below:

Code:
pi@moode:~ $ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: b1 [bcm2835 HDMI 1], device 0: bcm2835 HDMI 1 [bcm2835 HDMI 1]
 Subdevices: 4/4
 Subdevice #0: subdevice #0
 Subdevice #1: subdevice #1
 Subdevice #2: subdevice #2
 Subdevice #3: subdevice #3
card 1: Headphones [bcm2835 Headphones], device 0: bcm2835 Headphones [bcm2835 Headphones]
 Subdevices: 3/4
 Subdevice #0: subdevice #0
 Subdevice #1: subdevice #1
 Subdevice #2: subdevice #2
 Subdevice #3: subdevice #3




pi@moode:~ $ amixer -c0
Simple mixer control 'HDMI',0
 Capabilities: pvolume pvolume-joined pswitch pswitch-joined
 Playback channels: Mono
 Limits: Playback -10239 - 400
 Mono: Playback 400 [100%] [4.00dB] [on]




pi@moode:~ $ amixer -c1
Simple mixer control 'Headphone',0
 Capabilities: pvolume pvolume-joined pswitch pswitch-joined
 Playback channels: Mono
 Limits: Playback -10239 - 400
 Mono: Playback 400 [100%] [4.00dB] [on]




pi@moode:~ $ moodeutl -a
1    y    Kernel architecture
2    y    Airplay renderer
4    y    DLNA server
8        Stream recorder
16    y    Squeezelite renderer
32    y    UPnP client for MPD
64        Require squashfs for software update
128    y    RoonBridge renderer
256    y    Local display
512    y    Input source select
1024        UPnP volume sync
2048    y    Spotify Connect renderer
4096    y    GPIO button handler
8192    y    UPnP media browser
16384    y    Bluetooth renderer
32768        Developer tweaks




pi@moode:~ $ moodeutl -l
20210601 192755 worker: -- Start
20210601 192756 worker: Successfully daemonized
20210601 192757 worker: Integrity check (passed)
20210601 192800 worker: File check (OK)
20210601 192802 worker: Session vacuumed
20210601 192802 worker: Session loaded
20210601 192802 worker: Debug logging (OFF)
20210601 192802 worker: -- Audio debug
20210601 192802 worker: ALSA cards: (0:b1 | 1:Headphones | 2:empty | 3:empty
20210601 192802 worker: MPD config: (1:Pi Headphone jack | mixer:(Headphone) | card:1)
20210601 192802 worker: ALSA mixer actual (Headphone)
20210601 192802 worker: ALSA Headphone volume set to (0%)
20210601 192802 worker: -- System
20210601 192805 worker: Host     (moode)
20210601 192806 worker: moOde    (7.2.1 2021-05-06)
20210601 192806 worker: RaspiOS  (10.9)
20210601 192806 worker: Kernel   (5.10.17-v7+ #1421)
20210601 192806 worker: Platform (Pi-2B 1.1 1GB)
20210601 192806 worker: ARM arch (armv7l, 32-bit kernel)
20210601 192806 worker: MPD ver  (0.22.6_p0x3)
20210601 192806 worker: CPU gov  (ondemand)
20210601 192806 worker: USB boot not available
20210601 192806 worker: File system expanded
20210601 192806 worker: HDMI port off
20210601 192806 worker: -- Network
20210601 192806 worker: eth0 exists
20210601 192806 worker: eth0 address not assigned
20210601 192806 worker: wlan0 exists
20210601 192806 worker: wifi country (GB)
20210601 192806 worker: wlan0 trying SSID (vodafone15A11G)
20210601 192806 worker: IP addr (192.168.1.111)
20210601 192806 worker: Netmask (255.255.255.0)
20210601 192806 worker: Gateway (192.168.1.1)
20210601 192807 worker: Pri DNS (192.168.1.1)
20210601 192807 worker: Domain  (broadband)
20210601 192807 worker: -- Audio config
20210601 192807 worker: ALSA card number (1)
20210601 192807 worker: MPD audio output (Pi Headphone jack)
20210601 192808 worker: Audio formats (U8, S16_LE)
20210601 192808 worker: ALSA mixer name (Headphone)
20210601 192808 worker: MPD volume control (software)
20210601 192809 worker: Hdwr volume controller exists
20210601 192809 worker: Max ALSA volume (100%)
20210601 192809 worker: ALSA loopback (Off)
20210601 192809 worker: Reset renderer active flags
20210601 192809 worker: CamillaDSP (off)
20210601 192809 worker: -- MPD startup
20210601 192809 worker: MPD started
20210601 192828 worker: MPD accepting connections
20210601 192828 worker: MPD output 1 ALSA Default (on)
20210601 192828 worker: MPD output 2 ALSA Bluetooth (off)
20210601 192828 worker: MPD output 3 HTTP Server (off)
20210601 192828 worker: MPD crossfade (off)
20210601 192828 worker: MPD ignore CUE files (yes)
20210601 192828 worker: -- Feature availability
20210601 192828 worker: Source select (available)
20210601 192828 worker: Source select (source: MPD)
20210601 192828 worker: Source select (output: Pi Headphone jack)
20210601 192829 worker: Bluetooth pairing agent (started)
20210601 192829 worker: Bluetooth (available: started)
20210601 192829 worker: Airplay renderer (available)
20210601 192829 worker: Spotify renderer (available)
20210601 192829 worker: Squeezelite (available)
20210601 192829 worker: RoonBridge renderer (not installed)
20210601 192829 worker: UPnP renderer (available)
20210601 192829 worker: DLNA server (available)
20210601 192829 worker: UPnP browser (available)
20210601 192829 worker: GPIO button handler (available)
20210601 192829 worker: Stream recorder (n/a)
20210601 192829 worker: -- Music sources
20210601 192829 worker: USB sources (none attached)
20210601 192831 worker: NAS and UPnP sources (mountall initiated)
20210601 192831 worker: -- Other
20210601 192831 worker: USB volume knob (Off)
20210601 192831 worker: USB auto-mounter (udisks-glue)
20210601 192831 worker: LED0 (On)
20210601 192831 worker: LED1 (On)
20210601 192831 worker: Saved MPD vol level (0)
20210601 192831 worker: Preamp volume level (0)
20210601 192832 worker: MPD volume level (100) restored
20210601 192832 worker: ALSA Headphone volume (100%)
20210601 192832 worker: Auto-play (Off)
20210601 192832 worker: Maintenance interval (3 hours)
20210601 192832 worker: Screen saver activation (Never)
20210601 192832 worker: Session permissions (OK)
20210601 192832 worker: Watchdog started
20210601 192832 worker: Ready
20210602 200911 worker: Job hdmiport
20210602 200918 worker: Job hdmiport
20210602 201018 worker: Job mpdrestart
20210602 201149 worker: Job mpdcfg



Thanks
Greg
Reply


Messages In This Thread
RE: no sound from radio stations or library - by greg_m - 06-02-2021, 09:53 PM

Forum Jump: