Thank you for your donation!


Solved: Low Volume with HifiBerry DAC+
#1
Question 
Hi,

I've used a Raspberry Pi 2B with HifiBerry DAC+-Module and MoodeOS 2.5 without any Problems for years.
As far as I know there was an volume-related bug with the HifiBerry DAC+-Modules. Workaround was here to set "logarythmic curve" to "Yes" and "max volume" to "81" in the "Customize"-Screen.

Now that I've upgraded to MoodeOS 4.2 the maximal volume seems much quieter then with MoodeOS 2.5 and the described costumations. Even if I set the "analoge gain boost" in the chip-options to .8dB the maximal volume is lower than before.
I can't find the settings for "logarythmic curve" and "max volume" in MoodeOS 4.2.

How can I get back the full volume?

Here some further details from my settings:
MPD options
- Audio device: I2S audio device
- Volume control: Hardware
- SoX resampling: Disabled
Chip/Device options:
- Digital interpolation filter: FIR interpolation with de-
- Analog gain: 0db (2-Vrms)
Crossfeed/Parametric EQ/Graphic EQ: all set to "Off"
Reply
#2
Logarithmic volume curve is done in MPD now so no need to do it in moOde code.

When you say low volume do you mean that the knob setting you used b4 does not yield same perceived volume? Thats probably because MPD uses a slightly different curve that old moOde did.

Whats important is that when you set moOde knob to 100 that the Hardware volume mixer is outputting 0dB. You can verify this by looking at the alsamixer screen or output from the amixer command. Obviously, don't have anything playing when you set moode knob to 100.
Enjoy the Music!
http://moodeaudio.org | http://twitter.com/MoodeAudio | http://github.com/moodeaudio
Reply
#3
Yes, if i set the volume knob to "100" in Moode4.2 the heard volume ist quieter then with Moode2.5
I noticed this with Moode3.7 too.

If I set volume knob to "100" also volume in audo config is set to 100% too. amixer shows 0.00dB
So it seems that 100% in Moode2.5 are more than 100% in Moode4.2 Huh

 
I have a Raspberry Pi 1B here with a HifiBerry DAC+ with the same config too.
If I set volume to 100 via BubbleUPnP amixer shows 0.00db, but the volume knob is always set to "-1".
I didn't notice any changes in the heard volume between Moode2.5, Moode3.7 or Moode4.2 here.

I don't use the volume knob in the browser normaly. I set the volume always with BubbleUPnP-App on my Android with the volume-keys on the device.
Reply
#4
I recall Hifiberry fixed some bugs in their driver that was causing >0dB at 100% ALSA volume. That was probably coupe of years ago.

As long as ALSA shows 100% = 0dB the volume output should be good.
Enjoy the Music!
http://moodeaudio.org | http://twitter.com/MoodeAudio | http://github.com/moodeaudio
Reply
#5
On sunday I had the change to do a A/B-comparison between Moode 2.5 and Moode 4.2 on the described system.

Volume was set to 100%. On both Moode-versions ALSA showed 100%.
At the RCA-OUTs of the Hifiberry I had a MiniDSP. With the MiniDSP 2Way Advanced-Plugin I monitored the volume at LINE-IN of the MiniDSP.
The Test-Songs were both times the same ones.
  • Moode 2.5 was about 10dB louder than Moode 4.2!!
  • the analoge gain boost setting in Moode 4.2 made no difference
I don't know if it's a failure with Moode 4.2 or with Moode 2.5. But I need to know how I can increase the output-volume here.

I noticed that the Input-Gain on the LINE-IN of the MiniDSP was at about 40% under Moode 4.2. So there should be enough room for a bigger input-signlal. All of my songs were set to 89dB with Replay-Gain (Album-Adjust) with MP3Gain (v1.3.4).

So is there a way to set the output-gain of moode manually to a higher value?
Reply
#6
Looking back through my notes for release 2.5 there apparently was a bug in device drivers for the Hifiberry DAC+ and DAC+ Pro that caused +24dB gain at ALSA 0dB. This was why at that time everyone had to back their ALSA volume setting off by ~20% to avoid distortion at normal listening levels. The problem went away starting with moOde 2.6 that included an updated Linux kernel 4.4.8 and device drivers.

Some options might be:
- enabling the Parametric EQ and play with the Master gain setting
- turn off MPD ReplayGain
- re-do the ReplayGain settings for your songs

-Tim
Enjoy the Music!
http://moodeaudio.org | http://twitter.com/MoodeAudio | http://github.com/moodeaudio
Reply
#7
Thank you Tim for your efforts!

I remember that bug. Wasn't that the reason to adjust the max volume in "customation" to "81"?
In the comparison-test the max volume was set to "81" but there was much louder output nevertheless.


My music collection is realy big, and I need the normalisation for another player. So re-doing the ReplayGain settings is not realy an option.
MPD ReplayGain is already turned off. I tried to add "replaygain_preamp "6" to mpd.conf. I thougt this would be the right place to adjust the output volume in my case. But after apply the changes and restarting MPD the Moode-Webconfig and the UPnP-client weren't reachable. So i reverted the change.

Enabling the Parametric EQ and set the Master gain to a higher value could be the solution. I will try this out.
Reply
#8
Thumbs Up 
Last week I tried to enable the Parametric EQ and adjusted master gain to +9dB.

Arrow Output was much louder and very clear even at 100% volume. IMHO sound was much better than with Moode 2.5 at the same effective volume.

Smile So thank you for helping me solving this problem and making my setup even better!!
Reply
#9
Nice to hear that :-)

When you get a moment, update your OP (original post) and mark it SOLVED.

-Tim
Enjoy the Music!
http://moodeaudio.org | http://twitter.com/MoodeAudio | http://github.com/moodeaudio
Reply


Forum Jump: