Thank you for your donation!


Chrod Mojo Problem with 4.2?
#1
This is the first time I try to attach my Chord MoJo to Moode 4.2 and I suspect I'm doing something wrong....

I configure "i2s audio device" to None in Configure/Audio

I can see the MoJo in ssh
Code:
pi@moode:~ $ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 1: Mojo [Mojo], device 0: USB Audio [USB Audio]
 Subdevices: 1/1
 Subdevice #0: subdevice #0

But I cannot choose "USB device" in MPD settings because because the list in the combo "Audio device" is empty with just the entry "Nothing selected"
[Image: MpdConfig42.png]

What am I doing wrong?
Thanks!
franz

PS: for the moment I reverted to using "moOde = Release 4.1 2018-04-02"
Reply
#2
Well... I sure did something wrong... problem now sorted!
So I restarted from scratch
1) flashed again my SD card (from the backup I did after automated install of 4.2)
2) disabled IQaudIO PiDac+ (which was the i2s device I configured on the pi where the image was created and configured initially)
3) reboot
4) disable cross-feed
5) configure wi-fi with correct username and pwd (the pi had booted in AP mode)
6) reboot

What did I do differently from previous time?
I did one step at the time....2 separate reboots and disabled cross-feed.

Sorry for bothering you about this!
Now patiently waiting 4.3....
Reply
#3
After setting I2S device to None a reboot is required, then open MPD config and the USB audio device selection should be available.
Enjoy the Music!
http://moodeaudio.org | http://twitter.com/MoodeAudio | http://github.com/moodeaudio
Reply
#4
(09-01-2018, 10:48 PM)franz159 Wrote: ....
Sorry for bothering you about this!
Now patiently waiting 4.3....

At least now I know what chord mojo is. What a strange name for a DAC! Smile  How good is it?

Remy
Reply
#5
(09-02-2018, 05:46 PM)remy1961 Wrote:
(09-01-2018, 10:48 PM)franz159 Wrote: ....
Sorry for bothering you about this!
Now patiently waiting 4.3....

At least now I know what chord mojo is. What a strange name for a DAC! Smile  How good is it?

Remy

More importantly has @franz159 got his mojo working?  Cool
Reply
#6
(09-02-2018, 08:18 PM)FizzyTea Wrote:
(09-02-2018, 05:46 PM)remy1961 Wrote:
(09-01-2018, 10:48 PM)franz159 Wrote: ....
Sorry for bothering you about this!
Now patiently waiting 4.3....

At least now I know what chord mojo is. What a strange name for a DAC! Smile  How good is it?

Remy

More importantly has @franz159 got his mojo working?  Cool

Ye it is now working.
Just needed to reboot once more after changing the i2s audio device setting from "IQaudIO" to "None" as menioned in few posts earlier.
And the Chord MoJo Dac sounds very good!
Reply
#7
mmm... now happening again when switching from i2s to USB dac + reboot .... I will re-flash the sd, but it is definitely annoying.... any other option?

Different USB dac connected, but same symptom, the "USB device" option is not showing in MPD settings...

Given my device using aplay:

Code:
pi@moode:/etc $ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 1: v14 [TDA 1543 DAC 3 v1.4], device 0: USB Audio [USB Audio]
 Subdevices: 0/1
 Subdevice #0: subdevice #0


I ended up adding manually the following entry 

audio_output {
type "alsa"
name "TDA1543"
device "hw:1,0"
mixer_type "software"
}

in /etc/mpd.conf

...at least I get sound!

______________

Update: I ended up rebuilding the Image... 
** Sat 8 Sep 21:26:52 EDT 2018
** Installation time : 01:00:45
Reply


Forum Jump: