Thank you for your donation!


No permission to write on USB disk
#11
first of all, Tim and TheOld... thankyou for your patience.

I dont remember how did i create the 'home' disk, where i can put files from my desktop, directly with filezilla.

The new one, i just connected usb disk to my win 10 desktop and formatted it in NTFS, using the same win 10 utility (right click on name of the disk and format )
Then i connected it to Raspberry 4.
This time i was able to connected to it from win10, following TheOldPresbyope hint, and iam able to copy files there now.
I went to check permissions and i still have no write permission other than root.
Anyway, copying files in this way its much more slow than Filezilla.

The difference remain between the 2 Moode implementations.
In one i can write with filezilla from my win 10 to raspberry usb disk.
In the new one, (with the same latest release) iam unable to do the same, and the files iam copying actually on usb disk from win10 file explorer , are like these
-rwxr-xr-x 1 root root 28506307 Nov 12 2019 '4-03 4% of Something.flac'
-rwxr-xr-x 1 root root 24840184 Nov 12 2019 '4-04 Waterfall.flac'
-rwxr-xr-x 1 root root 23651904 Nov 12 2019 '4-05 Gismo My Way.flac'
-rwxr-xr-x 1 root root 19095971 Nov 12 2019 '4-06 Channel Swimmer.flac'
-rwxr-xr-x 1 root root 21950962 Nov 12 2019 '4-07 Good News.flac'

Maybe in the home Moode, i have edited some Samba cfg ?
Iam not able to find a clue because iam not so clever in Linux

what is the correct command to chenge permission from SSH term server inside Moode?
I tried with sudo , but as i already said, nothing happens. maybe iam making many mistakes....

thankyou
Reply
#12
It might be due to the format of the disk being NTFS whose permission system may only be compatible with Windows permission commands.

I've always formatted external disks as FAT32 (VFAT) or EXT4 which works fine with the Linux permission command chmod.
Enjoy the Music!
moodeaudio.org | Mastodon Feed | GitHub
Reply
#13
Thanks Tim.
How could i format from inside Moode ssh term then?
I imagine need a completely unformatted disk, just with unassigned space and then some sudo command?
Reply
#14
Both disk are NTFS.
in both Raspy i have /etc/samba/smb.conf like this

[global]
server string = moOde SMB Server
multicast dns register = no
security = User
map to guest = Bad User
guest account = root
log level = 0
load printers = No
printcap name = /dev/null
disable spoolss = Yes
printing = bsd
preferred master = No
local master = No
domain master = No
dns proxy = No
create mask = 0775
directory mask = 0775
browseable = Yes
veto files = /._*/.DS_Store/
delete veto files = yes
[NAS]
comment = NAS Shares
path = /mnt/NAS
read only = No
guest ok = Yes
[Playlists]
comment = Playlist Directory
path = /var/lib/mpd/playlists
read only = No
guest ok = Yes
[Radio]
comment = RADIO Stations
path = /var/lib/mpd/music/RADIO
read only = No
guest ok = Yes
[SDCard]
comment = SDCARD Storage
path = /mnt/SDCARD
read only = No
guest ok = Yes
[HEGOMDUSB]
comment = USB Storage
path = /media/HEGOMDUSB
read only = No
guest ok = Yes

i think must be some conf file different somewhere.
could it be possible?
Reply
#15
i tried with a usb pen drive with FAT filesystem, and results are perfectly the same....
Reply
#16
(11-09-2021, 11:40 PM)HEGOM Wrote: i tried with a usb pen drive with FAT filesystem, and results are perfectly the same....

Hi,
I've no idea whether this may be of any help, or if it just duplicates your issue.
My setup is perhaps similar to yours (NTFS USB disk attached to Rpi4 running Moode 7.41), and I also have some issues with directory access/ownership when working in SSH. I can access it perfectly from Windows File Manager and Filezilla.

I do not have the answers you need - at least not yet - and am working my way gently into using Linux while trying not to lock myself out of the disk!
Logging into moode using SSH :
at the prompt I typed:                mount | grep media

this returned:
pi@moode:~ $ mount | grep media

/dev/sda2 on /media/WDGreen  typefuseblk (rw,nosuid,nodev,noexec,noatime,user_id=0,group_id=0,default_permissions,allow_other,blksize=4096,uhelper=udisks)            
pi@moode:~ $
 
from which I can navigate towards the disk - however today I cannot access the disk/see its folders - unless I use Windows file manager or Filezilla. I can get to   /media, but   cd /WDGreen  returns an error. 

at the /media$ prompt however I ran:
 ls -l

and got

drwxr-xr-x 1 root root 16384 Nov 10 14:49 WDGreen

which I think means that user root has ownership and that other users have no write access.

I also typed    sudo
and got the    root   prompt 
which I think is where you got to.

(user root was created on this disk when I previously ran piCoreplayer, I think)

I will keep working on this (and I do have a full working duplicate of my disk just in case!) and am happy to report back here for the benefit of yourself and any other Linux newbies.
Reply
#17
Folks:

With all the advancements made in Linux it's perfectly possible to mount NTFS filesystems. For many purposes they'll appear indistinguishable from FAT32 and EXT4 filesystems. The NTFS filesystem will be mounted using the Linux fuseblk mechanism and the FAT32 filesystem using the vfat mechanism but that's just a detail.

Here's an example of two thumbdrives I just plugged into a moOde 7.4.1 player

Code:
pi@rpi3bp:~ $ lsblk -f
NAME        FSTYPE LABEL    UUID                                 FSAVAIL FSUSE% MOUNTPOINT
sda                                                                            
└─sda1      ntfs   MyNTFS   64B7E8CB6A07F4D0                      801.5M    18% /media/MyNTFS
sdb                                                                            
└─sdb1      vfat   USB DISK D3B6-C697                              19.4G    33% /media/USB DISK
mmcblk0                                                                        
├─mmcblk0p1 vfat   boot     EBBA-157F                             197.5M    22% /boot
└─mmcblk0p2 ext4   rootfs   b3ce35cd-ade9-4755-a4bb-1571e37fc1b9     11G    19% /

(where mmcblk0 is the uSD card containing moOde/RaspiOS)

I can change into directories in either the NTFS filesystem or the VFAT system and *as root* create or delete files/directories in them. User pi has permission only to read them.

Example for the NTFS filesystem

Code:
pi@rpi3bp:~ $ cd /media/MyNTFS
pi@rpi3bp:/media/MyNTFS $ ls -l
total 4
drwxr-xr-x 1 root root 4096 Nov  7 07:31 'Green Day-Warning'
drwxr-xr-x 1 root root    0 Nov  7 07:35 'System Volume Information'
pi@rpi3bp:/media/MyNTFS $ sudo mkdir testdir
pi@rpi3bp:/media/MyNTFS $ ls -l
total 4
drwxr-xr-x 1 root root 4096 Nov  7 07:31 'Green Day-Warning'
drwxr-xr-x 1 root root    0 Nov  7 07:35 'System Volume Information'
drwxr-xr-x 1 root root    0 Nov 10 11:00  testdir
pi@rpi3bp:/media/MyNTFS $ cd testdir
pi@rpi3bp:/media/MyNTFS/testdir $ sudo touch emptyfile
pi@rpi3bp:/media/MyNTFS/testdir $ ls -l
total 0
-rwxr-xr-x 1 root root 0 Nov 10 11:00 emptyfile

Having said this, I still don't understand the need to be doing this work from the command line locally when it can all be done remotely from the Windows desktop using the Windows file manager.

Regards,
Kent
Reply
#18
hi all and many thanks for your comments.

@TheOldPresbiope : Yes, i tried to operate through Windows 10 explorer, and it does work (even if slower than filezilla), but iam just curious to know why on two identical systems, it behave differently.!!

This thing is making me crazy :-)
Reply


Forum Jump: