Thank you for your donation!


Problem: Issue with Blutooth in 4.1
#31
BINGO!!!!

In the latest commits they changed the default enabled plugins:
Code:
Available BT profiles:
 - a2dp-source Advanced Audio Source
 - a2dp-sink   Advanced Audio Sink
 - hsp-hs      Headset
 - hsp-ag      Headset Audio Gateway
 - hfp-hf      Hands-Free
 - hfp-ag      Hands-Free Audio Gateway

By default only output profiles are enabled, which includes A2DP Source and
HSP/HFP Audio Gateways. If one wants to enable other set of profiles, it is
required to explicitly specify all of them using `-p NAME` options.

So I changed the /etc/systemd/system/bluealsa.service adding -p a2dp-sink .
Code:
#
# 2018-01-26 TC moOde 4.0
#

[Unit]
Description=BluezAlsa proxy
Requires=bluetooth.service
After=bluetooth.service

[Service]
Type=simple
#User=pi
#Group=audio
ExecStart=/usr/bin/bluealsa -p a2dp-sink

[Install]
WantedBy=multi-user.target

And everything resurrected  Cool .
Again now I have the problem that once I connect a device the volume goes to 100%, awaking my son Dodgy  and make me fight with my wife...
I want to test all input profiles, now but this is the right way!!!
Reply
#32
Yes badbat75 ... we worked on that with the crew and next release will have bluetooth really more robust.

Next release will have -p a2dp-sink -p a2dp-source parameters.

About volume problem, maybe you can set Volume Control to Software in mpd settings and set a smooth level before connecting bluetooth devices Wink

Regards.
Reply
#33
(05-01-2018, 12:49 PM)Koda59 Wrote: Yes badbat75 ... we worked on that with the crew and next release will have bluetooth really more robust.

Next release will have -p a2dp-sink -p a2dp-source parameters.

About volume problem, maybe you can set Volume Control to Software in mpd settings and set a smooth level before connecting bluetooth devices Wink

Regards.

Big Grin  oh yes, it is a good idea, why did I not think that before Undecided

Meanwhile I'm trying to use APTx codec in order to try the low latency feature.
This is the modification of the recipe I made:
Code:
cd /tmp
git clone --single-branch https://github.com/Arkq/openaptx
cd openaptx
autoreconf --install
mkdir build
cd build
../configure --prefix=/usr --libdir=/usr/lib/arm-linux-gnueabihf --sysconfdir=/etc --localstatedir=/var
make
sudo make install

cd /tmp
git clone --single-branch https://github.com/Arkq/bluez-alsa.git
cd bluez-alsa
autoreconf --install
mkdir build
cd build
../configure --enable-hcitop --enable-aptx --with-alsaplugindir=/usr/lib/arm-linux-gnueabihf/alsa-lib
make
sudo make install
cd ~
rm -rf /tmp/openaptx
rm -rf /tmp/bluez-alsa
Reply
#34
(05-01-2018, 12:27 PM)badbat75 Wrote: BINGO!!!!

In the latest commits they changed the default enabled plugins:
Code:
Available BT profiles:
 - a2dp-source Advanced Audio Source
 - a2dp-sink   Advanced Audio Sink
 - hsp-hs      Headset
 - hsp-ag      Headset Audio Gateway
 - hfp-hf      Hands-Free
 - hfp-ag      Hands-Free Audio Gateway

By default only output profiles are enabled, which includes A2DP Source and
HSP/HFP Audio Gateways. If one wants to enable other set of profiles, it is
required to explicitly specify all of them using `-p NAME` options.

So I changed the /etc/systemd/system/bluealsa.service adding -p a2dp-sink .
Code:
#
# 2018-01-26 TC moOde 4.0
#

[Unit]
Description=BluezAlsa proxy
Requires=bluetooth.service
After=bluetooth.service

[Service]
Type=simple
#User=pi
#Group=audio
ExecStart=/usr/bin/bluealsa -p a2dp-sink

[Install]
WantedBy=multi-user.target

And everything resurrected  Cool .
Again now I have the problem that once I connect a device the volume goes to 100%, awaking my son Dodgy  and make me fight with my wife...
I want to test all input profiles, now but this is the right way!!!

Hi,

- What type of audio device?
- What is MPD volume (Software, Hardware, Disabled)?

I've added volume management to Bluetooth for the MPD volume disabled (0dB) case.

-TIm
Enjoy the Music!
moodeaudio.org | Twitter Feed | Git Repo
Reply
#35
(05-01-2018, 04:50 PM)Tim Curtis Wrote:
(05-01-2018, 12:27 PM)badbat75 Wrote: BINGO!!!!

In the latest commits they changed the default enabled plugins:
Code:
Available BT profiles:
 - a2dp-source Advanced Audio Source
 - a2dp-sink   Advanced Audio Sink
 - hsp-hs      Headset
 - hsp-ag      Headset Audio Gateway
 - hfp-hf      Hands-Free
 - hfp-ag      Hands-Free Audio Gateway

By default only output profiles are enabled, which includes A2DP Source and
HSP/HFP Audio Gateways. If one wants to enable other set of profiles, it is
required to explicitly specify all of them using `-p NAME` options.

So I changed the /etc/systemd/system/bluealsa.service adding -p a2dp-sink .
Code:
#
# 2018-01-26 TC moOde 4.0
#

[Unit]
Description=BluezAlsa proxy
Requires=bluetooth.service
After=bluetooth.service

[Service]
Type=simple
#User=pi
#Group=audio
ExecStart=/usr/bin/bluealsa -p a2dp-sink

[Install]
WantedBy=multi-user.target

And everything resurrected  Cool .
Again now I have the problem that once I connect a device the volume goes to 100%, awaking my son Dodgy  and make me fight with my wife...
I want to test all input profiles, now but this is the right way!!!

Hi,

- What type of audio device?
- What is MPD volume (Software, Hardware, Disabled)?

I've added volume management to Bluetooth for the MPD volume disabled (0dB) case.

-TIm

Hi Tim,
- The audio device is an HiFiBerryAMP with
- HW Volume enabled.

So the in version 4.0 the volume was managed by MPD?
Reply
#36
On 4.1 - I'm having weirdness with BT as well. I've gotten my iPhone to work only if I connect to the device from MoOde. When I try and connect via the iPhone, nada. Also, I can pair with my Mac and I can get an initial connection, but it disconnects immediately. I'm trying to use my MPB as a source and the MoOde player as a sink.

I'm assuming 4.2 fixes all of this?
Reply
#37
(05-01-2018, 05:01 PM)badbat75 Wrote:
(05-01-2018, 04:50 PM)Tim Curtis Wrote:
(05-01-2018, 12:27 PM)badbat75 Wrote: BINGO!!!!

In the latest commits they changed the default enabled plugins:
Code:
Available BT profiles:
 - a2dp-source Advanced Audio Source
 - a2dp-sink   Advanced Audio Sink
 - hsp-hs      Headset
 - hsp-ag      Headset Audio Gateway
 - hfp-hf      Hands-Free
 - hfp-ag      Hands-Free Audio Gateway

By default only output profiles are enabled, which includes A2DP Source and
HSP/HFP Audio Gateways. If one wants to enable other set of profiles, it is
required to explicitly specify all of them using `-p NAME` options.

So I changed the /etc/systemd/system/bluealsa.service adding -p a2dp-sink .
Code:
#
# 2018-01-26 TC moOde 4.0
#

[Unit]
Description=BluezAlsa proxy
Requires=bluetooth.service
After=bluetooth.service

[Service]
Type=simple
#User=pi
#Group=audio
ExecStart=/usr/bin/bluealsa -p a2dp-sink

[Install]
WantedBy=multi-user.target

And everything resurrected  Cool .
Again now I have the problem that once I connect a device the volume goes to 100%, awaking my son Dodgy  and make me fight with my wife...
I want to test all input profiles, now but this is the right way!!!

Hi,

- What type of audio device?
- What is MPD volume (Software, Hardware, Disabled)?

I've added volume management to Bluetooth for the MPD volume disabled (0dB) case.

-TIm

Hi Tim,
- The audio device is an HiFiBerryAMP with
- HW Volume enabled.

So the in version 4.0 the volume was managed by MPD?

4.0 had no volume coordination between MPD and Bluetooth.
4.1 added volume management and "Resume after MPD" but not implemented for the 0dB case
4.2 covers the 0dB case and fixes a bug in volume mgt :-)

-Tim
Enjoy the Music!
moodeaudio.org | Twitter Feed | Git Repo
Reply
#38
(05-01-2018, 09:54 PM)Mullet Wrote: On 4.1 - I'm having weirdness with BT as well. I've gotten my iPhone to work only if I connect to the device from MoOde. When I try and connect via the iPhone, nada. Also, I can pair with my Mac and I can get an initial connection, but it disconnects immediately. I'm trying to use my MPB as a source and the MoOde player as a sink.

I'm assuming 4.2 fixes all of this?

Yes, including connecting from Mac, connecting Pi-to-Pi, connecting to Bluetooth speaker, inbound connections from Smartphone, Tablet, etc.

All working very nicely in 4.2 Bluetooth implementation :-)

-Tim
Enjoy the Music!
moodeaudio.org | Twitter Feed | Git Repo
Reply
#39
I,m having the same problem with bluetooth in that I have never been able to get a connection with any device to my speakers via buletooth. I am running a raspberry pi 3-B with a hifiberry amp+ hat and moode 4.0 as the OS in my wireless speakers. I have tried connecting with a Samsung Galaxy s7 and Iphone 6 with no success. Both devices can see and pair to the speakers but will not connect. I have read this entire thread and have tried several approaches to solving this (pair the devices, unpair, reconnect, power off, power on, bow down to the east) but it's all been no go for me.

Does anyone have a suggestion on how I might go about getting a connection.

It looks like to me some head way has been made with 4.2. Is 4.2 available for download?
I'll give that a test run if it is.
Reply
#40
(05-16-2018, 05:35 PM)Hugh Bond Wrote: I,m having the same problem with bluetooth in that I have never been able to get a connection with any device to my speakers via buletooth. I am running a raspberry pi 3-B with a hifiberry amp+ hat and moode 4.0 as the OS in my wireless speakers. I have tried connecting with a Samsung Galaxy s7 and Iphone 6 with no success. Both devices can see and pair to the speakers but will not connect. I have read this entire thread and have tried several approaches to solving this (pair the devices, unpair, reconnect, power off, power on, bow down to the east) but it's all been no go for me.

Does anyone have a suggestion on how I might go about getting a connection.

It looks like to me some head way has been made with 4.2. Is 4.2 available for download?
I'll give that a test run if it is.

Hello??
Reply


Forum Jump: