Thank you for your donation!

Solved: Sound form NAS is breaking up via WiFi connection
The ifconfig and iwconfig output looks reasonable. [1]

The only thing odd I see is at the end of your dmesg output

[  477.658969] CIFS VFS: cifs_mount failed w/return code = -112
[  493.234222] CIFS VFS: cifs_mount failed w/return code = -112

This says your moOde player twice tried to mount a CIFS (e.g., SAMBA) filesystem and failed. That 112 return code breaks down to 64 ("some mount succeeded") + 32 ("mount failure") + 16 ("problems writing or locking /etc/mtab"). I think the essential point here is the "mount failure".

Did it mount later? Was this your NAS? What does the mount command say?

As an example, I have no such message in my dmesg output on a working r4.3 system and I have the following excerpt from running the mount command which shows my NAS (OMV-HC1) is mounted as a CIFS filesystem (with 'XXX' substituted for the actual username)

pi@moode:~ $ mount

//OMV-HC1/Music on /mnt/NAS/OMV-HC1 type cifs (ro,relatime,vers=1.0,cache=strict,username=XXXX,domain=,uid=0,noforceuid,gid=0,noforcegid,addr=,soft,unix,posixpaths,serverino,mapposix,acl,rsize=61440,wsize=65536,echo_interval=60,actimeo=1)

Still looking for an aha moment.


[1] if you were using an external WiFi adapter, I'd point to the "Power Management:on" line output by iwconfig, but raspbian disables power management for the internal adapter (you can find it in your dmesg outout) and apparently iwconfig lies about it (consult the RPi forums if you're interested).

Messages In This Thread
RE: Sound form NAS is breaking up via WiFi connection - by TheOldPresbyope - 10-09-2018, 04:40 PM

Forum Jump: