Thank you for your donation!


Instruction Guide AUDIOPHONICS RaspDAC Mini Kit - I-Sabre ES9038Q2M
Updated procedure for moOde 8 and higher:
Code:
sudo apt update
sudo apt-get -y install lirc
sudo -i pip install --upgrade pip setuptools
sudo pip install luma.core luma.oled

\\ Only for moOde 64bits
Code:
sudo nano /lib/systemd/system/lircd.service

Replace this line: "ExecStart=/usr/sbin/lircd --nodaemon" by:
Code:
ExecStart=/usr/sbin/lircd --nodaemon -U /usr/lib/aarch64-linux-gnu/lirc/plugins

Code:
sudo systemctl daemon-reload
Only for moOde 64bits \\

Code:
sudo nano /boot/config.txt

Add at the end of /boot/config.txt:
Code:
dtparam=spi=on
dtoverlay=gpio-ir,gpio_pin=4

Download and install oled and lirc files:
Code:
wget -O raspdacmini_8.tar "https://drive.google.com/uc?export=download&id=1-CRIicwQYm1y5xZgu8w54mvn0XjmcLe9"
tar xvf raspdacmini_8.tar
sudo chmod 755 oled/raspdac_oled_main.py
sudo chmod 644 oled/oled.service
sudo cp oled/oled.service /etc/systemd/system/
sudo systemctl enable oled
sudo cp -r lirc/* /etc/lirc
rm -r lirc
rm raspdacmini_8.tar
sudo reboot
Reply
(04-02-2022, 04:58 PM)TookaFace Wrote: Updated procedure for moOde 8 and higher:
Code:
sudo apt update
sudo apt-get -y install lirc
sudo -i pip install --upgrade pip setuptools
sudo -H pip install 'luma.core==1.13.0' 'luma.oled==3.4.0'

I'm also using  the luma library for my oled screen. Prob the oled screen for the audophonics software used python 2.7, this why the packages where locked to those versions; The packages 'luma.core==1.13.0' 'luma.oled==3.4.0' where the latest that still supported python2.7. Now it is running on python 3 with moode 8, you can prob drop that reqstriction. At my side the newer versions for python3 also works fine:


Code:
pi@m8p4d:~ $ pip freeze |grep luma
luma.core==2.3.1
luma.oled==3.8.1
Reply
Indeed, that work with latest versions, thx
Reply
Thanks TookaFace, all up and running.
Reply
(04-02-2022, 04:58 PM)TookaFace Wrote: Updated procedure for moOde 8 and higher:
Code:
sudo apt update
sudo apt-get -y install lirc
sudo -i pip install --upgrade pip setuptools
sudo pip install luma.core luma.oled

Add at the end of /boot/config.txt:
Code:
dtparam=spi=on
dtoverlay=gpio-ir,gpio_pin=4

Download and install oled and lirc files:
Code:
wget -O raspdacmini_8.tar "https://drive.google.com/uc?export=download&id=1-CRIicwQYm1y5xZgu8w54mvn0XjmcLe9"
tar xvf raspdacmini_8.tar
sudo chmod 755 oled/raspdac_oled_main.py
sudo chmod 644 oled/oled.service
sudo cp oled/oled.service /etc/systemd/system/
sudo systemctl enable oled
sudo cp -r lirc/* /etc/lirc
rm -r lirc
rm raspdacmini_8.tar
sudo reboot

I cannot add anything to config.txt
I use WIN SCP

Permission denied
Reply
(04-06-2022, 02:46 PM)Jempie Wrote:
(04-02-2022, 04:58 PM)TookaFace Wrote: Updated procedure for moOde 8 and higher:
Code:
sudo apt update
sudo apt-get -y install lirc
sudo -i pip install --upgrade pip setuptools
sudo pip install luma.core luma.oled

Add at the end of /boot/config.txt:
Code:
dtparam=spi=on
dtoverlay=gpio-ir,gpio_pin=4

Download and install oled and lirc files:
Code:
wget -O raspdacmini_8.tar "https://drive.google.com/uc?export=download&id=1-CRIicwQYm1y5xZgu8w54mvn0XjmcLe9"
tar xvf raspdacmini_8.tar
sudo chmod 755 oled/raspdac_oled_main.py
sudo chmod 644 oled/oled.service
sudo cp oled/oled.service /etc/systemd/system/
sudo systemctl enable oled
sudo cp -r lirc/* /etc/lirc
rm -r lirc
rm raspdacmini_8.tar
sudo reboot

I cannot add anything to config.txt
I use WIN SCP

Permission denied
I just put the SD card in my Windows computer, opened config.txt, added the two lines and saved using notepad.
Reply
(04-06-2022, 05:06 PM)kit1cat Wrote:
(04-06-2022, 02:46 PM)Jempie Wrote:
(04-02-2022, 04:58 PM)TookaFace Wrote: Updated procedure for moOde 8 and higher:
Code:
sudo apt update
sudo apt-get -y install lirc
sudo -i pip install --upgrade pip setuptools
sudo pip install luma.core luma.oled

Add at the end of /boot/config.txt:
Code:
dtparam=spi=on
dtoverlay=gpio-ir,gpio_pin=4

Download and install oled and lirc files:
Code:
wget -O raspdacmini_8.tar "https://drive.google.com/uc?export=download&id=1-CRIicwQYm1y5xZgu8w54mvn0XjmcLe9"
tar xvf raspdacmini_8.tar
sudo chmod 755 oled/raspdac_oled_main.py
sudo chmod 644 oled/oled.service
sudo cp oled/oled.service /etc/systemd/system/
sudo systemctl enable oled
sudo cp -r lirc/* /etc/lirc
rm -r lirc
rm raspdacmini_8.tar
sudo reboot

I cannot add anything to config.txt
I use WIN SCP

Permission denied
I just put the SD card in my Windows computer, opened config.txt, added the two lines and saved using notepad.

done that, still nothing
see code

Code:
                     ____     __      ___
         __ _  ___  / __ \___/ /__   ( _ )
        /  ' \/ _ \/ /_/ / _  / -_) / _  |
       /_/_/_/\___/\____/\_,_/\__/  \___/

                moOde audio player
             Release 8.0.2 2022-03-25
               (C) 2014 Tim Curtis


The programs included with moOde are free software; the
exact distribution terms for each program are described
in the individual files in /usr/share/doc/*/copyright or
in the moOde source files. moOde comes with absolutely
no warranties either expressed or implied, or any other
such guarantees.

To set a new password for the user 'pi' type 'passwd'.

pi@moode:~ $ sudo apt update
sudo apt-get -y install lirc
sudo -i pip install --upgrade pip setuptools
sudo pip install luma.core luma.oled
Get:1 http://raspbian.raspberrypi.org/raspbian bullseye InRelease [15.0 kB]
Get:2 http://archive.raspberrypi.org/debian bullseye InRelease [23.7 kB]
Get:3 https://dl.cloudsmith.io/public/moodeaudio/m8y/deb/raspbian bullseye InRel                                         ease [5,167 B]
Get:4 http://raspbian.raspberrypi.org/raspbian bullseye/main armhf Packages [13.                                         2 MB]
Get:5 http://archive.raspberrypi.org/debian bullseye/main armhf Packages [276 kB                                         ]
Get:6 https://dl.cloudsmith.io/public/moodeaudio/m8y/deb/raspbian bullseye/main                                          armhf Packages [43.4 kB]
Get:7 http://raspbian.raspberrypi.org/raspbian bullseye/contrib armhf Packages [                                         60.2 kB]
Get:8 http://raspbian.raspberrypi.org/raspbian bullseye/non-free armhf Packages                                          [106 kB]
Fetched 13.8 MB in 12s (1,156 kB/s)
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
38 packages can be upgraded. Run 'apt list --upgradable' to see them.
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
The following additional packages will be installed:
 gir1.2-atk-1.0 gir1.2-freedesktop gir1.2-gdkpixbuf-2.0 gir1.2-gtk-3.0 gir1.2-harfbuzz-0.0 gir1.2-pango-1.0
 gir1.2-vte-2.91 liblirc0 libpangoxft-1.0-0 libportaudio2 libusb-0.1-4 libvte-2.91-0 libvte-2.91-common
Suggested packages:
 lirc-compat-remotes lirc-drv-irman lirc-doc lirc-x setserial ir-keytable
The following NEW packages will be installed:
 gir1.2-atk-1.0 gir1.2-freedesktop gir1.2-gdkpixbuf-2.0 gir1.2-gtk-3.0 gir1.2-harfbuzz-0.0 gir1.2-pango-1.0
 gir1.2-vte-2.91 liblirc0 libpangoxft-1.0-0 libportaudio2 libusb-0.1-4 libvte-2.91-0 libvte-2.91-common lirc
0 upgraded, 14 newly installed, 0 to remove and 38 not upgraded.
Need to get 2,550 kB of archives.
After this operation, 6,494 kB of additional disk space will be used.
Get:1 http://archive.raspberrypi.org/debian bullseye/main armhf gir1.2-gtk-3.0 armhf 3.24.24-4+rpt3 [259 kB]
Get:2 http://mirror.transip.net/raspbian/raspbian bullseye/main armhf gir1.2-atk-1.0 armhf 2.36.0-2 [26.0 kB]
Get:3 http://raspbian.raspberrypi.org/raspbian bullseye/main armhf gir1.2-freedesktop armhf 1.66.1-1+b1 [33.3 kB]
Get:4 http://raspbian.raspberrypi.org/raspbian bullseye/main armhf gir1.2-gdkpixbuf-2.0 armhf 2.42.2+dfsg-1 [19.7 kB]
Get:5 http://mirror.serverius.net/raspbian/raspbian bullseye/main armhf gir1.2-harfbuzz-0.0 armhf 2.7.4-1 [1,154 kB]
Get:6 http://mirror.serverius.net/raspbian/raspbian bullseye/main armhf libpangoxft-1.0-0 armhf 1.46.2-3 [40.9 kB]
Get:7 http://mirror.serverius.net/raspbian/raspbian bullseye/main armhf gir1.2-pango-1.0 armhf 1.46.2-3 [53.0 kB]
Get:8 http://mirror.serverius.net/raspbian/raspbian bullseye/main armhf libvte-2.91-common armhf 0.62.3-1 [64.6 kB]
Get:9 http://mirror.serverius.net/raspbian/raspbian bullseye/main armhf libvte-2.91-0 armhf 0.62.3-1 [176 kB]
Get:10 http://mirror.serverius.net/raspbian/raspbian bullseye/main armhf gir1.2-vte-2.91 armhf 0.62.3-1 [28.1 kB]
Get:11 http://mirror.serverius.net/raspbian/raspbian bullseye/main armhf libusb-0.1-4 armhf 2:0.1.12-32 [21.6 kB]
Get:12 http://mirror.serverius.net/raspbian/raspbian bullseye/main armhf liblirc0 armhf 0.10.1-6.3 [124 kB]
Get:13 http://mirror.serverius.net/raspbian/raspbian bullseye/main armhf libportaudio2 armhf 19.6.0-1.1 [57.5 kB]
Get:14 http://mirror.serverius.net/raspbian/raspbian bullseye/main armhf lirc armhf 0.10.1-6.3 [492 kB]
Fetched 2,550 kB in 2s (1,245 kB/s)
Selecting previously unselected package gir1.2-atk-1.0:armhf.
(Reading database ... 64504 files and directories currently installed.)
Preparing to unpack .../00-gir1.2-atk-1.0_2.36.0-2_armhf.deb ...
Unpacking gir1.2-atk-1.0:armhf (2.36.0-2) ...
Selecting previously unselected package gir1.2-freedesktop:armhf.
Preparing to unpack .../01-gir1.2-freedesktop_1.66.1-1+b1_armhf.deb ...
Unpacking gir1.2-freedesktop:armhf (1.66.1-1+b1) ...
Selecting previously unselected package gir1.2-gdkpixbuf-2.0:armhf.
Preparing to unpack .../02-gir1.2-gdkpixbuf-2.0_2.42.2+dfsg-1_armhf.deb ...
Unpacking gir1.2-gdkpixbuf-2.0:armhf (2.42.2+dfsg-1) ...
Selecting previously unselected package gir1.2-harfbuzz-0.0:armhf.
Preparing to unpack .../03-gir1.2-harfbuzz-0.0_2.7.4-1_armhf.deb ...
Unpacking gir1.2-harfbuzz-0.0:armhf (2.7.4-1) ...
Selecting previously unselected package libpangoxft-1.0-0:armhf.
Preparing to unpack .../04-libpangoxft-1.0-0_1.46.2-3_armhf.deb ...
Unpacking libpangoxft-1.0-0:armhf (1.46.2-3) ...
Selecting previously unselected package gir1.2-pango-1.0:armhf.
Preparing to unpack .../05-gir1.2-pango-1.0_1.46.2-3_armhf.deb ...
Unpacking gir1.2-pango-1.0:armhf (1.46.2-3) ...
Selecting previously unselected package gir1.2-gtk-3.0:armhf.
Preparing to unpack .../06-gir1.2-gtk-3.0_3.24.24-4+rpt3_armhf.deb ...
Unpacking gir1.2-gtk-3.0:armhf (3.24.24-4+rpt3) ...
Selecting previously unselected package libvte-2.91-common.
Preparing to unpack .../07-libvte-2.91-common_0.62.3-1_armhf.deb ...
Unpacking libvte-2.91-common (0.62.3-1) ...
Selecting previously unselected package libvte-2.91-0:armhf.
Preparing to unpack .../08-libvte-2.91-0_0.62.3-1_armhf.deb ...
Unpacking libvte-2.91-0:armhf (0.62.3-1) ...
Selecting previously unselected package gir1.2-vte-2.91:armhf.
Preparing to unpack .../09-gir1.2-vte-2.91_0.62.3-1_armhf.deb ...
Unpacking gir1.2-vte-2.91:armhf (0.62.3-1) ...
Selecting previously unselected package libusb-0.1-4:armhf.
Preparing to unpack .../10-libusb-0.1-4_2%3a0.1.12-32_armhf.deb ...
Unpacking libusb-0.1-4:armhf (2:0.1.12-32) ...
Selecting previously unselected package liblirc0:armhf.
Preparing to unpack .../11-liblirc0_0.10.1-6.3_armhf.deb ...
Unpacking liblirc0:armhf (0.10.1-6.3) ...
Selecting previously unselected package libportaudio2:armhf.
Preparing to unpack .../12-libportaudio2_19.6.0-1.1_armhf.deb ...
Unpacking libportaudio2:armhf (19.6.0-1.1) ...
Selecting previously unselected package lirc.
Preparing to unpack .../13-lirc_0.10.1-6.3_armhf.deb ...
Unpacking lirc (0.10.1-6.3) ...
Setting up libportaudio2:armhf (19.6.0-1.1) ...
Setting up gir1.2-freedesktop:armhf (1.66.1-1+b1) ...
Setting up libpangoxft-1.0-0:armhf (1.46.2-3) ...
Setting up libvte-2.91-common (0.62.3-1) ...
Setting up gir1.2-gdkpixbuf-2.0:armhf (2.42.2+dfsg-1) ...
Setting up gir1.2-atk-1.0:armhf (2.36.0-2) ...
Setting up libvte-2.91-0:armhf (0.62.3-1) ...
Setting up gir1.2-harfbuzz-0.0:armhf (2.7.4-1) ...
Setting up libusb-0.1-4:armhf (2:0.1.12-32) ...
Setting up gir1.2-pango-1.0:armhf (1.46.2-3) ...
Setting up liblirc0:armhf (0.10.1-6.3) ...
Setting up gir1.2-gtk-3.0:armhf (3.24.24-4+rpt3) ...
Setting up gir1.2-vte-2.91:armhf (0.62.3-1) ...
Setting up lirc (0.10.1-6.3) ...
Created symlink /etc/systemd/system/multi-user.target.wants/lircd.service → /lib/systemd/system/lircd.service.
Created symlink /etc/systemd/system/sockets.target.wants/lircd.socket → /lib/systemd/system/lircd.socket.
Processing triggers for man-db (2.9.4-2) ...
Processing triggers for libc-bin (2.31-13+rpt2+rpi1+deb11u2) ...
Looking in indexes: https://pypi.org/simple, https://www.piwheels.org/simple
Requirement already satisfied: pip in /usr/lib/python3/dist-packages (20.3.4)
Collecting pip
 Downloading https://www.piwheels.org/simple/pip/pip-22.0.4-py3-none-any.whl (2.1 MB)
    |████████████████████████████████| 2.1 MB 2.1 MB/s
Requirement already satisfied: setuptools in /usr/lib/python3/dist-packages (52.0.0)
Collecting setuptools
 Downloading https://www.piwheels.org/simple/setuptools/setuptools-62.0.0-py3-none-any.whl (1.1 MB)
    |████████████████████████████████| 1.1 MB 2.2 MB/s
Installing collected packages: setuptools, pip
 Attempting uninstall: setuptools
   Found existing installation: setuptools 52.0.0
   Not uninstalling setuptools at /usr/lib/python3/dist-packages, outside environment /usr
   Can't uninstall 'setuptools'. No files were found to uninstall.
 Attempting uninstall: pip
   Found existing installation: pip 20.3.4
   Not uninstalling pip at /usr/lib/python3/dist-packages, outside environment /usr
   Can't uninstall 'pip'. No files were found to uninstall.
Successfully installed pip-22.0.4 setuptools-62.0.0
Looking in indexes: https://pypi.org/simple, https://www.piwheels.org/simple
Collecting luma.core
 Downloading https://www.piwheels.org/simple/luma-core/luma.core-2.3.1-py2.py3-none-any.whl (71 kB)
    ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 71.3/71.3 KB 1.1 MB/s eta 0:00:00
Collecting luma.oled
 Downloading https://www.piwheels.org/simple/luma-oled/luma.oled-3.8.1-py2.py3-none-any.whl (32 kB)
Collecting deprecated
 Downloading https://www.piwheels.org/simple/deprecated/Deprecated-1.2.13-py2.py3-none-any.whl (9.5 kB)
Requirement already satisfied: pillow>=4.0.0 in /usr/lib/python3/dist-packages (from luma.core) (8.1.2)
Collecting smbus2
 Downloading https://www.piwheels.org/simple/smbus2/smbus2-0.4.1-py2.py3-none-any.whl (11 kB)
Collecting pyftdi
 Downloading https://www.piwheels.org/simple/pyftdi/pyftdi-0.54.0-py3-none-any.whl (144 kB)
    ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 144.8/144.8 KB 1.5 MB/s eta 0:00:00
Requirement already satisfied: spidev in /usr/lib/python3/dist-packages (from luma.core) (3.5)
Collecting cbor2
 Downloading https://www.piwheels.org/simple/cbor2/cbor2-5.4.2.post1-cp39-cp39-linux_armv7l.whl (156 kB)
    ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 156.5/156.5 KB 368.6 kB/s eta 0:00:00
Requirement already satisfied: RPI.GPIO in /usr/lib/python3/dist-packages (from luma.core) (0.7.0)
Collecting wrapt<2,>=1.10
 Downloading https://www.piwheels.org/simple/wrapt/wrapt-1.14.0-cp39-cp39-linux_armv7l.whl (72 kB)
    ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 72.8/72.8 KB 456.1 kB/s eta 0:00:00
Collecting pyusb!=1.2.0,>=1.0.0
 Downloading https://www.piwheels.org/simple/pyusb/pyusb-1.2.1-py3-none-any.whl (58 kB)
    ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 58.4/58.4 KB 554.0 kB/s eta 0:00:00
Collecting pyserial>=3.0
 Downloading https://www.piwheels.org/simple/pyserial/pyserial-3.5-py2.py3-none-any.whl (90 kB)
    ━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━━ 90.6/90.6 KB 708.5 kB/s eta 0:00:00
Installing collected packages: smbus2, pyserial, wrapt, pyusb, cbor2, pyftdi, deprecated, luma.core, luma.oled
Successfully installed cbor2-5.4.2.post1 deprecated-1.2.13 luma.core-2.3.1 luma.oled-3.8.1 pyftdi-0.54.0 pyserial-3.5 pyusb-1.2.1 smbus2-0.4.1 wrapt-1.14.0
WARNING: Running pip as the 'root' user can result in broken permissions and conflicting behaviour with the system package manager. It is recommended to use a virtual environment instead: https://pip.pypa.io/warnings/venv
pi@moode:~ $ wget -O raspdacmini_8.tar "https://drive.google.com/uc?export=download&id=1-CRIicwQYm1y5xZgu8w54mvn0XjmcLe9"
tar xvf raspdacmini_8.tar
sudo chmod 755 oled/raspdac_oled_main.py
sudo chmod 644 oled/oled.service
sudo cp oled/oled.service /etc/systemd/system/
sudo systemctl enable oled
sudo cp -r lirc/* /etc/lirc
rm -r lirc
rm raspdacmini_8.tar
sudo reboot
--2022-04-07 09:32:19--  https://drive.google.com/uc?export=download&id=1-CRIicwQYm1y5xZgu8w54mvn0XjmcLe9
Resolving drive.google.com (drive.google.com)... 2a00:1450:400e:811::200e, 142.250.179.142
Connecting to drive.google.com (drive.google.com)|2a00:1450:400e:811::200e|:443... connected.
HTTP request sent, awaiting response... 303 See Other
Location: https://doc-14-1o-docs.googleusercontent.com/docs/securesc/ha0ro937gcuc7l7deffksulhg5h7mbp1/ei9k716aiopjuacbf7kknpb3m9uvrkd3/1649338275000/06436965574256312569/*/1-CRIicwQYm1y5xZgu8w54mvn0XjmcLe9?e=download [following]
Warning: wildcards not supported in HTTP.
--2022-04-07 09:32:22--  https://doc-14-1o-docs.googleusercontent.com/docs/securesc/ha0ro937gcuc7l7deffksulhg5h7mbp1/ei9k716aiopjuacbf7kknpb3m9uvrkd3/1649338275000/06436965574256312569/*/1-CRIicwQYm1y5xZgu8w54mvn0XjmcLe9?e=download
Resolving doc-14-1o-docs.googleusercontent.com (doc-14-1o-docs.googleusercontent.com)... 2a00:1450:400e:802::2001, 142.251.39.97
Connecting to doc-14-1o-docs.googleusercontent.com (doc-14-1o-docs.googleusercontent.com)|2a00:1450:400e:802::2001|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 22863360 (22M) [application/x-tar]
Saving to: ‘raspdacmini_8.tar’

raspdacmini_8.tar              100%[=================================================>]  21.80M  4.06MB/s    in 5.4s

2022-04-07 09:32:27 (4.07 MB/s) - ‘raspdacmini_8.tar’ saved [22863360/22863360]

lirc/
lirc/irexec.lircrc.dist
lirc/lircd.conf
lirc/lircd.conf.d/
lirc/lircd.conf.d/devinput.lircd.conf
lirc/lircd.conf.d/README.conf.d
lirc/lircd.conf.dist
lirc/lircmd.conf.dist
lirc/lirc_options.conf
lirc/lirc_options.conf.dist
oled/
oled/fonts/
oled/fonts/arial.ttf
oled/fonts/fontawesome-webfont.ttf
oled/fonts/msyh.ttf
oled/oled.service
oled/raspdac_oled_main.py
oled/raspdac_oled_request_mpd.py
oled/raspdac_oled_request_os.py
oled/raspdac_oled_screen_display.py
oled/raspdac_oled_screen_frames.py
oled/raspdac_oled_screen_menu.py
oled/raspdac_oled_telecommand.py
serial.py
Created symlink /etc/systemd/system/multi-user.target.wants/oled.service → /etc/systemd/system/oled.service.
Reply
Double check that the two lines have been added to config.txt. If they have, try going through the listing again.
Reply
(04-02-2022, 04:58 PM)TookaFace Wrote: Updated procedure for moOde 8 and higher:
Code:
sudo apt update
sudo apt-get -y install lirc
sudo -i pip install --upgrade pip setuptools
sudo pip install luma.core luma.oled

Code:
sudo nano /boot/config.txt

Add at the end of /boot/config.txt:
Code:
dtparam=spi=on
dtoverlay=gpio-ir,gpio_pin=4

Download and install oled and lirc files:
Code:
wget -O raspdacmini_8.tar "https://drive.google.com/uc?export=download&id=1-CRIicwQYm1y5xZgu8w54mvn0XjmcLe9"
tar xvf raspdacmini_8.tar
sudo chmod 755 oled/raspdac_oled_main.py
sudo chmod 644 oled/oled.service
sudo cp oled/oled.service /etc/systemd/system/
sudo systemctl enable oled
sudo cp -r lirc/* /etc/lirc
rm -r lirc
rm raspdacmini_8.tar
sudo reboot

As I uderstand this solution is only for the OLED RaspDac, am i right?
Reply
This thread is for the original RaspDAC Mini Kit, the scrip would probably not work with anything else, including the new LCD version.
Reply


Forum Jump: