Thank you for your donation!


Solved: Spotify Connect Failing/Disconnecting Constantly
#1
Hi there, I just upgraded to 4.3 from 4.1 last night and am loving the improvements! I was particularly happy to see the inclusion of native Spotify Connect! After setup I was able to connect to my moode player from my laptop using Spotify Connect and stream all evening. However, towards the end of the evening my desktop Spotify client disconnected from my moode player and wouldn't reconnect until I restarted the Spotify renderer through the moode UI. After this I was able to connect again, but could only play about 10 seconds of a song before I was disconnected again. The same thing is happening with my phone (and iPhone) and my wife's (an android). I know it is probably entirely unconnected, but Airplay has continued to work fine the whole time.

Following the advice given in another post I ran these commands:

Code:
pgrep -l librespot

no output

Code:
aplay -L | grep -v ALSA | grep -w default

default:CARD=sndrpihifiberry

And here is my moode.log:

Code:
20181111 150833 worker: - Start
20181111 150833 worker: Successfully daemonized
20181111 150833 worker: Integrity check ok
20181111 150833 worker: Session loaded
20181111 150833 worker: Debug logging (off)
20181111 150833 worker: - Platform
20181111 150835 worker: Host (moode)
20181111 150835 worker: Hdwr (Pi-3B 1GB v1.2)
20181111 150835 worker: Arch (armv7l)
20181111 150835 worker: Rasp (9.4)
20181111 150835 worker: Kver (4.14.76-v7+)
20181111 150835 worker: Ktyp (Standard)
20181111 150835 worker: Gov  (performance)
20181111 150835 worker: Rel  (Moode 4.3 2018-09-27)
20181111 150835 worker: Upd  (2018-10-19)
20181111 150835 worker: MPD  (0.20.20)
20181111 150835 worker: USB boot not enabled yet
20181111 150835 worker: File system not expanded yet
20181111 150835 worker: HDMI port on
20181111 150835 worker: File check ok
20181111 150835 worker: - Network
20181111 150835 worker: eth0 exists
20181111 150835 worker: eth0 (192.168.1.167)
20181111 150835 worker: wlan0 exists
20181111 150835 worker: wifi country (US)
20181111 150835 worker: wlan0 SSID is blank
20181111 150835 worker: eth0 addr exists, AP mode not started
20181111 150835 worker: wlan0 address not assigned
20181111 150835 worker: - Audio
20181111 150835 worker: ALSA outputs unmuted
20181111 150835 worker: ALSA card number (0)
20181111 150835 worker: Audio out (I2S audio device)
20181111 150835 worker: Audio dev (HiFiBerry Digi+ Pro)
20181111 150835 worker: ALSA mixer name (Digital)
20181111 150835 worker: MPD volume control (software)
20181111 150836 worker: Hdwr volume controller not detected
20181111 150836 worker: - Services
20181111 150836 worker: Reset renderer active
20181111 150838 worker: MPD started
20181111 150838 worker: MPD scheduler policy (time-share)
20181111 150838 worker: Configure MPD outputs
20181111 150838 worker: MPD output 1 ALSA default (on)
20181111 150838 worker: MPD output 2 ALSA crossfeed (off)
20181111 150838 worker: MPD output 3 ALSA parametric eq (off)
20181111 150838 worker: MPD output 4 ALSA graphic eq (off)
20181111 150838 worker: MPD output 5 ALSA bluetooth (off)
20181111 150838 worker: MPD crossfade (off)
20181111 150838 worker: Airplay receiver started
20181111 150838 worker: Airplay volume mgt (auto)
20181111 150838 worker: Spotify receiver started
20181111 150838 worker: Audio scrobbler started
20181111 150838 worker: - Music sources
20181111 150838 worker: USB sources (none attached)
20181111 150838 wrk_sourcemount(): Mount error: (mount error: could not resolve address for TOWER: Unknown error)
20181111 150838 worker: NAS sources (mountall initiated)
20181111 150838 worker: - Miscellaneous
20181111 150838 worker: Volume level (0) restored
20181111 150838 worker: Maintenance interval (21600)
20181111 150838 worker: Screen saver activation (Never)
20181111 150838 worker: Watchdog started
20181111 150838 worker: Ready
20181111 151516 worker: Job spotifysvc
20181111 152925 worker: Job spotifysvc

Any ideas? Thanks!
Reply
#2
Its prolly the Spotify file cache consuming all the free disk space.

This is fixed in upcoming moOde 4.4. To clear the cache manually try the cmd below.

Code:
sudo rm -rf /var/local/www/spotify_cache/files

-Tim
Enjoy the Music!
http://moodeaudio.org | http://twitter.com/MoodeAudio | http://github.com/moodeaudio
Reply
#3
Looks like that fixed it (for now). Good to know that this is being addressed in the next build. Thanks for the help!
Reply
#4
Glad to here that :-)

When you get a moment, mark your OP (original post) as SOLVED.
Enjoy the Music!
http://moodeaudio.org | http://twitter.com/MoodeAudio | http://github.com/moodeaudio
Reply
#5
Hi, when moOde 4.4. ?
Reply
#6
Its planned for release sometime this moth.
Enjoy the Music!
http://moodeaudio.org | http://twitter.com/MoodeAudio | http://github.com/moodeaudio
Reply


Forum Jump: