Thank you for your donation!


Problem: Librespot authentication
#1
Hello everyone. I just switched from volumio. I'm trying out moode and liking it so far.

Raspberry pi 3 & Hifiberry DAC+
Everything worked right out of the box, all but spotify.

Librespot isn't showing on my spotify clients (desktop and mobile)
In my case the problem seems to be authentication. When I run another instance with 

Code:
librespot -n test

I get the same problem (nothing showing up). But as soon as i authenticate with my user and pass it shows on both clients.

Code:
librespot -n test -u foo -p bar

Would you recommed I wait for moode 4.4 or is this fixable?
Reply
#2
Librespot requires a Spotify Premium account which means that you have to be logged in first.

-Tim
Enjoy the Music!
moodeaudio.org | Twitter Feed | Git Repo
Reply
#3
Thanks for the quick reply.

Umh, how do I log in? Is there a conf file where i put my credentials or something alike?
I'm logged with premium on both mobile and desktop if that's what you meant.
Reply
#4
Librespot should automatically pick up your credentials from your Desktop and Mobile clients.

I assume you turned on Spotify in the Renderers section of moOde Audio Config. You should never have to enter commands in SSH to enable Spotify Connect.

Here's a screenie of the app on my Mac playing to a Pi named RP3.

   
Enjoy the Music!
moodeaudio.org | Twitter Feed | Git Repo
Reply


Forum Jump: