Thank you for your donation!


Problem: Display installation and control over Display
#1
Hello,

I am completly new to raspberry pi and moode audio. I want to use moode to listend to internetradio and control it over a small display (without mobile).

I downloaded the image and transfered it with Win32 Disk Imager to the Rasp Pi 3 B (without +). I am able to access the local moode webpage (with the computer) and I can get access with ssh (i use putty on windows).

This display i bought on ebay: https://i.ebayimg.com/images/g/YD0AAOSwz...-l1600.jpg

They told me i can find the drivers here: http://www.spotpear.com/learn/EN/raspber...e-LCD.html

So I tried to install the driver for the display but I fail the hole time (all commands I found somewhere in the web):


Code:
wget http://www.spotpear.com/download/diver24-5/LCD-show-171219.tar.gz
tar xvf LCD-show-171219.tar.gz
cd ./LCD-show
./LCD35-show
after that the rasp pi reboots and it shows the command line on the display.

I typed in >> sudo apt-get install lightdm and change with sudo raspi-config to deskop auto login (B4).
Now it shows in on the display: pi@moode:~ $.... so it is logged in, but I do not know any further...

How can I get the control of the player on the display ? Something like in the webbrowser?

Sorry for the stupid question and thanks for the answer.
Reply
#2
Menu, Configure, System
Scroll down to Local Display section and turn on "Local UI display"
You might have to reboot.

If moOde UI does not show up on your attached display then contact the manufacture of the display and drivers for support.
Enjoy the Music!
moodeaudio.org | Twitter Feed | Git Repo
Reply
#3
Hello Tim,

thanks for your answer.

I reinstalled it only to be sure that I did everything right

step 1: copy moody-r44.img with disk manger and put sd card back in the rasp pi
step 2: boot the raspi, white lcd screen, access over web browser and putty possible
step 3: install display driver (commands above) -> screen shows command line (drivers for the lcd works)
step 4: activate Local UI display -> restart over menu
step 5: check is Local UI display is still activated (it is), Display still shows only the command line (see picture)
with auto log in I can get to picture step 6

What did I do wrong? It seems that the driver of the LCD works correctly.

thanks a lot for your help.


Attached Files Thumbnail(s)
           
Reply
#4
Must be a problem with the custom display drivers. The displays I've tested for example the Raspberry Pi 7" touch don't require any drivers.

Contact the manufacturer of these custom drivers for support.
Enjoy the Music!
moodeaudio.org | Twitter Feed | Git Repo
Reply
#5
I had looked at Waveshare displays a while ago for another project. Never got around to buying one, but my impression from reading the sparse documentation was that they are simply an HDMI display with a resistive touchscreen. 

If you have the RPi-version, then it includes a hat-like base that can plug directly to the RPi for power and gpio but you still need the separate connection between the HDMI port on the RPi and the display. 

The so-called drivers I found on github seem mostly to set up raspbian for an HDMI display and start X. There's also some things to help calibrate the touchscreen, to rotate the screen by 270-degrees, etc.

When you have enabled local display in moOde and rebooted, what is the content of /boot/config.txt? 

On one of my players running moOde r4.4 with local display enabled, I get (with my added note)

Code:
pi@moode44:~ $ more /boot/config.txt
disable_splash=1
hdmi_drive=2             <<-- this forces HDMI mode instead of DVI
dtparam=i2c_arm=on
dtparam=i2s=on
dtparam=audio=on
#dtoverlay=pi3-disable-wifi
#dtoverlay=pi3-disable-bt
 
I ask because the Waveshare folks seem to recommend a number of specific HDMI settings.


Do you have another HDMI display you can use to test that the RPi HDMI output is working? 

Attached is a screenshot of my 19" monitor plugged into the RPi HDMI port. This monitor did not sync with the default /boot/config.txt parameters. Rather than take time to fiddle to find proper settings, I commented out the hdmi_drive line and added

Code:
hdmi_safe=1


Also, just to be sure, is the X-server running, e.g.,

Code:
pi@moode:~ $ ps aux|grep X
root      1150  0.1  3.4 130724 32832 tty2     Ssl+ 11:24   0:00 /usr/lib/xorg/Xorg :0
pi        3593  0.0  0.0   4372   568 pts/0    S+   11:32   0:00 grep --color=auto X

where the first line shows the X-server is running. The second is an artifact of my simplistic use of grep.


Bottom line: I don't believe you are very far from getting the result you want.

Regards,
Kent


Attached Files Thumbnail(s)
   
Reply


Forum Jump: