Thank you for your donation!


Solved: Can’t connect to NAS
#1
Hello all,

I’m pretty new to the whole Pi thing (like, less than 24 hours). I’ve read great things about Moode and I’ve managed to set it up on my new RPi3B but I haven’t been able to get my music volume on my Synology nas to mount. I’ve checked the forums and I think I’m doing everything recommended; copy the file path from finder, login as guest with no password, tried smb, nfs and Upnp, etc. but it doesn’t even show up when I hit the scan button. I know it’s there and working because it’s mounted on my Mac and Moode is working because I have internet radio. I’m not at home but the version is presumably current because I only downloaded it last night and ran updates before I started playing with it. I’d appreciate suggestions for what to try next.

Thanks, Simon 

   
Reply
#2
And what error does the moode.log give you?
Is "music" the name of your shared folder on your NAS? In my case I also added the foldername in which the music is stored. I also use the IP address instead of the name.
Example: 192.168.1.252/Music/Albums
Bad sound kills good music
RPi 3B+  |  Allo Katana with Isolator (SQ)  |  2x AudioPhonics LPSU25  |  NAD C368  |  BeyerDynamic DT 1770 Pro  |  Synology DS712+ with DX513
Reply
#3
(10-04-2019, 10:52 PM)simonmuller Wrote: Hello all,

I’m pretty new to the whole Pi thing (like, less than 24 hours). I’ve read great things about Moode and I’ve managed to set it up on my new RPi3B but I haven’t been able to get my music volume on my Synology nas to mount. I’ve checked the forums and I think I’m doing everything recommended; copy the file path from finder, login as guest with no password, tried smb, nfs and Upnp, etc. but it doesn’t even show up when I hit the scan button. I know it’s there and working because it’s mounted on my Mac and Moode is working because I have internet radio. I’m not at home but the version is presumably current because I only downloaded it last night and ran updates before I started playing with it. I’d appreciate suggestions for what to try next.

Thanks, Simon 

Hi Simon,

You reported that "it doesn’t even show up when I hit the scan button". You may have to use IP address as @JST1963 suggested.

Not showing up in the Samba scan usually suggests some sort of firewall, Browser extension, Network filter etc is present. It also may be something else. These types of issues can be difficult to troubleshoot because the errors returned by the mount process are almost always useless.
Reply
#4
Thanks. I did try it with the IP address instead of the name. It didn’t seem to make any difference. I’m away from home for the next day or so but when I came back I’ll give it another try and maybe post the error log.

Where would the firewall/browser extension/network filter be? I’m not running anything like that that I know of

Thanks for your help
Reply
#5
It might not even be any of the things I suggested but the telltale symptom is:

"it doesn’t even show up when I hit the scan button"

That would suggest something is preventing moOde from seeing the Samba share advertised by your NAS. What that might be is ???
Reply
#6
20191004 231743 worker: - Start
20191004 231743 worker: Successfully daemonized
20191004 231743 worker: Integrity check (passed)
20191004 231743 worker: Session loaded
20191004 231743 worker: Debug logging (off)
20191004 231744 worker: ALSA volume set to (0%)
20191004 231744 worker: - Platform
20191004 231746 worker: Rel (Moode 6.2.1 2019-09-12)
20191004 231746 worker: Rasp (10.0)
20191004 231746 worker: Kern (4.19.69-v7+)
20191004 231746 worker: MPD (0.20.23)
20191004 231746 worker: Host (moode)
20191004 231746 worker: Hdwr (Pi-3B 1GB v1.2)
20191004 231746 worker: Arch (armv7l)
20191004 231746 worker: Gov (ondemand)
20191004 231746 worker: USB boot not enabled yet
20191004 231746 worker: File system not expanded yet
20191004 231746 worker: HDMI port off
20191004 231747 worker: File check (OK)
20191004 231747 worker: - Network
20191004 231747 worker: eth0 exists
20191004 231747 worker: eth0 (192.168.68.117)
20191004 231747 worker: wlan0 does not exist
20191004 231747 worker: - Audio
20191004 231747 worker: ALSA outputs unmuted
20191004 231747 worker: ALSA card number (1)
20191004 231747 worker: Audio output (USB audio device)
20191004 231747 worker: ALSA mixer name (PCM)
20191004 231747 worker: MPD volume control (software)
20191004 231747 worker: Hdwr volume controller exists
20191004 231747 worker: - Services
20191004 231747 worker: Reset renderer active state
20191004 231748 worker: MPD conf updated
20191004 231748 worker: MPD started
20191004 231748 worker: MPD accepting connections
20191004 231748 worker: Configure MPD outputs
20191004 231749 worker: MPD output 1 ALSA default (on)
20191004 231749 worker: MPD output 2 ALSA crossfeed (off)
20191004 231749 worker: MPD output 3 ALSA parametric eq (off)
20191004 231749 worker: MPD output 4 ALSA graphic eq (off)
20191004 231749 worker: MPD output 5 ALSA polarity inversion (off)
20191004 231749 worker: MPD output 6 ALSA bluetooth (off)
20191004 231749 worker: MPD output 7 HTTP stream (off)
20191004 231749 worker: MPD crossfade (off)
20191004 231749 worker: Audio source (Local)
20191004 231749 worker: Output device (Local)
20191004 231749 worker: USB auto-mounter (udisks-glue)
20191004 231749 worker: - Music sources
20191004 231749 worker: USB sources (none attached)
20191004 231749 worker: NAS and UPnP sources (none configured)
20191004 231749 worker: - Miscellaneous
20191004 231749 worker: Saved MPD vol level (0)
20191004 231749 worker: Preamp volume level (0)
20191004 231749 worker: MPD volume level (19) restored
20191004 231749 worker: ALSA volume level (100%)
20191004 231749 worker: Auto-play (Off)
20191004 231749 worker: Maintenance interval (6 hrs)
20191004 231749 worker: Screen saver activation (Never)
20191004 231749 worker: Session permissions (OK)
20191004 231749 worker: Watchdog started
20191004 231749 worker: Ready
20191004 232007 worker: Job sourcecfg
20191004 232009 sourceMount(): Mount error: (mount error: could not resolve address for smb:: Unknown error)
20191004 232012 worker: Job updmpddb
20191004 232321 worker: Job sourcecfg
20191004 232322 sourceMount(): Mount error: (mount error: could not resolve address for Volumes: Unknown error)
20191004 232325 worker: Job updmpddb
20191004 232335 worker: Job sourcecfg
20191004 232338 worker: Job updmpddb
20191004 232407 worker: Job sourcecfg
20191004 232408 sourceMount(): Mount error: (mount error: could not resolve address for Volumes: Unknown error)
20191004 232411 worker: Job updmpddb
20191004 232508 worker: Job sourcecfg
20191004 232510 sourceMount(): Mount error: (Retrying with upper case share name
mount error(6): No such device or address
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs))
20191004 232513 worker: Job updmpddb
20191004 232519 worker: Job sourcecfg
20191004 232523 worker: Job updmpddb
20191004 232829 worker: Job sourcecfg
20191004 232830 sourceMount(): Mount error: (Retrying with upper case share name
mount error(6): No such device or address
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs))
20191004 232833 worker: Job updmpddb
20191004 233045 worker: Job sourcecfg
20191004 233049 worker: Job updmpddb
20191004 233101 worker: Job updmpddb
20191004 233133 worker: Job sourcecfg
20191004 233134 sourceMount(): Mount error: (mount error: could not resolve address for Volumes: Unknown error)
20191004 233138 worker: Job updmpddb
20191004 233323 sourceMount(): Mount error: (mount error: could not resolve address for Volumes: Unknown error)
20191004 234544 worker: Job sourcecfg
20191004 234548 worker: Job sourcecfg
20191004 234551 worker: Job updmpddb
20191004 234555 worker: Job updmpddb
20191004 234558 worker: Job updmpddb
20191004 235416 worker: Job sourcecfg
20191004 235418 sourceMount(): Mount error: (mount error: could not resolve address for Volumes: Unknown error)
20191004 235421 worker: Job updmpddb
20191005 000158 worker: Job sourcecfg
20191005 000200 sourceMount(): Mount error: (mount error: could not resolve address for Volumes: Unknown error)
20191005 000203 worker: Job updmpddb
20191005 000209 worker: Job sourcecfg
20191005 000213 worker: Job updmpddb
20191005 000241 worker: Job sourcecfg
20191005 000243 sourceMount(): Mount error: (mount error: could not resolve address for Volumes: Unknown error)
20191005 000246 worker: Job updmpddb
20191005 000302 worker: Job sourcecfg
20191005 000305 worker: Job updmpddb
20191005 000418 worker: Job sourcecfg
20191005 000419 sourceMount(): Mount error: (mount.nfs: Failed to resolve server volumes: Name or service not known)
20191005 000422 worker: Job updmpddb
20191005 000600 worker: Job sourcecfg
20191005 000604 worker: Job updmpddb
20191005 000632 worker: Job sourcecfg
20191005 000634 sourceMount(): Mount error: (mount error(13): Permission denied
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs))
20191005 000638 worker: Job updmpddb
20191005 000644 worker: Job sourcecfg
20191005 000647 worker: Job updmpddb
20191005 000726 worker: Job sourcecfg
20191005 000811 sourceMount(): Mount error: (mount.nfs: mount to NFS server '10.1.1.5:/music' failed: RPC Error: Unable to receive)
20191005 000814 worker: Job updmpddb
20191005 000846 worker: Job sourcecfg
20191005 000850 worker: Job updmpddb
20191005 000934 worker: Job sourcecfg
20191005 000936 sourceMount(): Mount error: (mount error: could not resolve address for Volumes: Unknown error)
20191005 000939 worker: Job updmpddb
20191005 000945 worker: Job sourcecfg
20191005 000949 worker: Job updmpddb
20191005 004653 worker: Job sourcecfg
20191005 004655 sourceMount(): Mount error: (mount error: could not resolve address for Volumes: Unknown error)
20191005 004658 worker: Job updmpddb
20191005 053723 worker: Maintenance completed
20191005 115531 worker: Maintenance completed
20191005 181340 worker: Maintenance completed
20191006 003151 worker: Maintenance completed
20191006 075001 worker: Maintenance completed
20191006 140809 worker: Maintenance completed
20191006 172015 worker: Job sourcecfg
20191006 172017 sourceMount(): Mount error: (mount error(13): Permission denied
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs))
20191006 172020 worker: Job updmpddb
20191006 172259 worker: Job sourcecfg
20191006 172302 worker: Job updmpddb
20191006 172529 worker: Job sourcecfg
20191006 172529 sourceMount(): Mount error: (mount error(13): Permission denied
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs))
20191006 172532 worker: Job updmpddb
20191006 172542 worker: Job sourcecfg
20191006 172543 sourceMount(): Mount error: (mount error(13): Permission denied
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs))
20191006 172546 worker: Job updmpddb
20191006 172602 worker: Job sourcecfg
20191006 172603 sourceMount(): Mount error: (mount error(13): Permission denied
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs))
20191006 172606 worker: Job updmpddb

Here's the error log. I don't know if this tells you anything more. I tried it again with the IP address and got the same result. Would re-downloading/installing Moode to the SD card help? Should I try Volumio and see if that works? I'm not sure what to do from here
Reply
#7
I tried Volumio and after a bit of faffing around and some digging on the forums I was able to have it find the NAS by logging into the NAS and increasing the SMB type range. I’m going to reinstall Moode tonight and see if that sorts it

I’ll report back
Reply
#8
(10-07-2019, 02:17 AM)simonmuller Wrote: I tried Volumio and after a bit of faffing around and some digging on the forums I was able to have it find the NAS by logging into the NAS and increasing the SMB type range. I’m going to reinstall Moode tonight and see if that sorts it
I have Moode connected to my Synology via NFS. To make that possible, the NFS support for the share needs to be explicitly enabled. You can specify the IP address of your RPi in the NFS settings so it is allowed to mount it.
This all works without problem but indeed I use the IP address of the Synology, the entire string I enter is like:

Code:
192.168.1.11:/volume1/music
Reply
#9
Reinstalled Moode and no difference :/

Thanks, @Sander I’ll try that
Reply
#10
Nope. Enabled the Pi for NFS in synology settings and tried every possible path and still nothing.

Moode hates me. I’m going to see what Rune is like.
Reply


Forum Jump: