Thank you for your donation!


HDMI Monitor says 'Signal out of range"
#1
When I boot up an rpi, using the latest moOde image, and it is connected via HDMI to a monitor, I get a "Signal out of range" error on the monitor.  

I have previously booted into Raspbian and got a normal display.  

I tried 2 monitors.

Is moOde supposed to display the boot process, and/or boot to a usable display, even just a login prompt?
Reply
#2
No problem on my end with my HDMI monitors and Pi 7" touch.

Can you provide steps to reproduce your issue so other users can try to help debug?
Reply
#3
What happens if you....?

Code:
sudo nano /boot/config.txt
and add

Code:
hdmi_safe=1

and reboot ....

There are plenty of options for configuration if you know the parameters of your monitor/s
https://www.raspberrypi.org/documentatio...t/video.md

What make and model monitors are you using ?
Reply
#4
I have an rPi (3 model B) running the latest image. It works, and I can access it's web page via my LAN. In system settings HDMI is switched on.

So, I turned it off, plugged a HDMI cable into it and into my monitor, and powered up. The monitor just flickered. I swapped the cable to a second monitor, and it said 'signal out of range'.

I powered down the rpi, and put in a raspbian desktop image - and it booted and displayed fine. I powered down again, and put back the moOde image, but as it boots up nothing shows now - just a blank screen.

I might try putting a fresh image on a new disk and try again.
Reply
#5
(12-12-2019, 05:32 AM)DRONE7 Wrote: What happens if you....?

Code:
sudo nano /boot/config.txt
and add

Code:
hdmi_safe=1

and reboot ....

There are plenty of options for configuration if you know the parameters of your monitor/s
https://www.raspberrypi.org/documentatio...t/video.md

What make and model monitors are you using ?

hdmi_safe=1   seems to have made no difference.

I think the monitors are fine as raspbian desktop boots up and displays nicely.  One is an AOC and the other is an LG monitor.
Reply
#6
can you post the contents of your 

Code:
/boot/config.txt
Just rereading your posts...you say you have hdmi turned on....and I'm guessing you want the MoOde display on your local monitor....so in system config tab have you turned on the local display option ?
Or do yo just want a terminal display ?
Reply
#7
Progress of a sort.   I commented out the hdmi_drive and hdmi_blanking lines (Edit:  sorry I also added a hdmi_force_hotplug=1 line)and got a low res view of the boot process.  So I removed hdmi_safe and now I get to watch a normal boot process.


At the end of which thew screen goes blank.  I can hotswitch to  get the text tty1 to 6 and login successfully.

So what is supposed to happen.  Is it switching to a GUI mode at the end of boot.  Should it display the normal Moode screen, like in the web browser?
Reply
#8
No it blanks at the end of boot.....post your
Code:
/boot/config.txt

and we need to change the hdmi mode from x to x

change

Code:
hdmi_drive=2
to

Code:
hdmi_drive=1
Reply
#9
(12-12-2019, 05:46 AM)DRONE7 Wrote: can you post the contents of your 

Code:
/boot/config.txt
Just rereading your posts...you say you have hdmi turned on....and I'm guessing you want the MoOde display on your local monitor....so in system config tab have you turned on the local display option ?
Or do yo just want a terminal display ?

I don't think I ever changed that setting.  I thought that was for an LCD plugged into the Pi - not the HDMI.   I can turn it on, but it would be need to be turned on by default so someone can burn an image and boot up first time with a monitor plugged in wouldn't it?
Reply
#10
(12-12-2019, 06:13 AM)DRONE7 Wrote: No it blanks at the end of boot.....post your
Code:
/boot/config.txt

and we need to change the hdmi mode from x to x

change

Code:
hdmi_drive=2
to

Code:
hdmi_drive=1

Currently after this last edit, it looks like this

disable_splash=1
disable_overscan=1
hdmi_drive=1
hdmi_blanking=1
hdmi_force_hotplug=1
dtparam=i2c_arm=on
dtparam=i2s=on
dtparam=audio=on
#dtoverlay=pi3-disable-wifi
#dtoverlay=pi3-disable-bt
#hdmi_safe=1
 

I have a little job to do for SWMBO, so will reboot and  test and report soon.
Reply


Forum Jump: