Thank you for your donation!


[SOLVED] Bluetooth functionality
#1
Hi,
First, thanks for such a great system. I've recently started using Moode having previously used Rune and Volumio: I find Moode to be better thought out and faster, and just works better in some areas.
I'm trying to get bluetooth functionality working on Moode 4.1 (built on the 2018-04-18 raspbian image). I'm trying to stream bluetooth audio from my phone to Moode so as to play through the DAC and amplifier attached to my Pi. However when I try to connect to Moode Bluetooth from my phone the only service listed is Contact sharing. Bluetooth appears to be running properly as far as I can tell:

pi@moode:~ $ systemctl status bluetooth
● bluetooth.service - Bluetooth service
   Loaded: loaded (/lib/systemd/system/bluetooth.service; disabled; vendor preset: enabled)
   Active: active (running) since Tue 2018-06-19 12:47:10 EDT; 4min 55s ago
     Docs: man:bluetoothd(8)
 Main PID: 1329 (bluetoothd)
   Status: "Running"
   CGroup: /system.slice/bluetooth.service
           └─1329 /usr/sbin/bluetoothd --noplugin=sap

Jun 19 12:47:10 moode systemd[1]: Starting Bluetooth service...
Jun 19 12:47:10 moode bluetoothd[1329]: Bluetooth daemon 5.49
Jun 19 12:47:10 moode systemd[1]: Started Bluetooth service.
Jun 19 12:47:10 moode bluetoothd[1329]: Starting SDP server
Jun 19 12:47:10 moode bluetoothd[1329]: Bluetooth management interface 1.14 initialized
Jun 19 12:47:10 moode bluetoothd[1329]: Endpoint registered: sender=:1.13 path=/A2DP/SBC/Source/1


It's a fresh build and I've tried it using a Pi 3B with onboard Bluetooth and also with a Pi 2B with a USB Bluetooth 4.0 dongle, with the same results. In the Audio Config "Renderers" section I have Bluetooth speaker on with the default name "Moode Bluetooth", Speaker sharing off, and Resume MPD playback off.
In the Bluetooth config page, List paired lists my device; List connected doesn't list anything (even after attempting to connect to my phone from the List connected page).

Am I doing something wrong, or have I misinterpreted Moode's functionality and I'm trying to do something it can't do?

Thanks,

Adrian.
Reply
#2
(06-19-2018, 06:01 PM)aknaggbaugh Wrote: Hi,
First, thanks for such a great system. I've recently started using Moode having previously used Rune and Volumio: I find Moode to be better thought out and faster, and just works better in some areas.
I'm trying to get bluetooth functionality working on Moode 4.1 (built on the 2018-04-18 raspbian image). I'm trying to stream bluetooth audio from my phone to Moode so as to play through the DAC and amplifier attached to my Pi. However when I try to connect to Moode Bluetooth from my phone the only service listed is Contact sharing. Bluetooth appears to be running properly as far as I can tell:

pi@moode:~ $ systemctl status bluetooth
● bluetooth.service - Bluetooth service
   Loaded: loaded (/lib/systemd/system/bluetooth.service; disabled; vendor preset: enabled)
   Active: active (running) since Tue 2018-06-19 12:47:10 EDT; 4min 55s ago
     Docs: man:bluetoothd(8)
 Main PID: 1329 (bluetoothd)
   Status: "Running"
   CGroup: /system.slice/bluetooth.service
           └─1329 /usr/sbin/bluetoothd --noplugin=sap

Jun 19 12:47:10 moode systemd[1]: Starting Bluetooth service...
Jun 19 12:47:10 moode bluetoothd[1329]: Bluetooth daemon 5.49
Jun 19 12:47:10 moode systemd[1]: Started Bluetooth service.
Jun 19 12:47:10 moode bluetoothd[1329]: Starting SDP server
Jun 19 12:47:10 moode bluetoothd[1329]: Bluetooth management interface 1.14 initialized
Jun 19 12:47:10 moode bluetoothd[1329]: Endpoint registered: sender=:1.13 path=/A2DP/SBC/Source/1


It's a fresh build and I've tried it using a Pi 3B with onboard Bluetooth and also with a Pi 2B with a USB Bluetooth 4.0 dongle, with the same results. In the Audio Config "Renderers" section I have Bluetooth speaker on with the default name "Moode Bluetooth", Speaker sharing off, and Resume MPD playback off.
In the Bluetooth config page, List paired lists my device; List connected doesn't list anything (even after attempting to connect to my phone from the List connected page).

Am I doing something wrong, or have I misinterpreted Moode's functionality and I'm trying to do something it can't do?

Thanks,

Adrian.

I found the answer in another thread (add -p a2dp-sink to the ExecStart line in /etc/systemd/system/bluealsa.service) - sorry for double posting a problem. Even after adding the -p a2dp-sink option it seemed kind of flaky, but it works for now and I'm looking forward to trying the new and improved bluetooth setup in v4.2.
Reply


Forum Jump: