Thank you for your donation!


Solved: My Library is not updating
#7
(04-19-2019, 05:32 AM)sintax Wrote: resurrecting this old thread... Looks like this is maybe still a bug?   The initial import worked very well, but added some folders and kicked off a refresh and got the following.

Kind of strange, I'm getting the same thing from my NFS share, the permissions on that are 777, but I am mounting RO.

Looks like /var/lib/mpd/music/NAS is a symblink of /mnt/NAS

Not sure about that wonky SMB workaround...

mpd log
Apr 18 22:12 : exception: Failed to open /var/lib/mpd/music/NAS/FS/FLAC/Dead/Daves Picks - 14 - 3-26-72 - Academy of Music NY: Permission denied
Apr 18 22:12 : exception: Failed to open /var/lib/mpd/music/NAS/FS/FLAC/Dead/Dicks Picks - 14 - 12-2-73 - Boston Music Hall MA: Permission denied
Apr 18 22:12 : exception: Failed to open /var/lib/mpd/music/NAS/FS/FLAC/Dead/Daves Picks - 12 - 11-4-77 - Colgate University NY: Permission denied
Apr 18 22:12 : exception: Failed to open /var/lib/mpd/music/NAS/FS/FLAC/Dead/Daves Picks - 22 - 12-7-71 - Felt Forum NY: Permission denied
Apr 18 22:12 : exception: Failed to open /var/lib/mpd/music/NAS/FS/FLAC/Dead/Daves Picks - 23 - 1-22-78 - McArthur Court OR: Permission denied
Apr 18 22:12 : exception: Failed to open /var/lib/mpd/music/NAS/FS/FLAC/Dead/Daves Picks - 15 - 4-22-78 - Municipal Auditorium TN: Permission denied

Bug? Not likely, actually.

You've given no details about how you "added some folders", how you're exporting from your NFS server or how you're mounting in moOde. 

The long and the short of it is that whatever NAS configuration information you enter becomes part of a standard nfs mount command. Here's the result when I mount a directory being exported as "Test" from my server "OMV-HC1" (to which I assigned the friendly name "OMV-NFS")

Code:
pi@moode:~ $ mount
...
pi@omv-hc1:/Test on /mnt/NAS/OMV-NFS type nfs4 (ro,relatime,vers=4.1,rsize=131072,wsize=131072,namlen=255,hard,proto=tcp,timeo=600,retrans=2,sec=sys,clientaddr=192.168.1.184,local_lock=none,addr=192.168.1.12)

If the initial import worked but you are getting "permission denied" on the added folders then you are caught in NFS purgatory. You'll have to figure out what's different about the ownership and permissions of the added folders/files. Google is your friend. Keep in mind that user names and group names don't count in NFS; it's all about the numeric uid and guid.

After decades of using NFS in a massive network of engineering workstations back in the day, I can candidly say I hate NFS.

As for the SMB workaround, since NFS and SMB are totally different technologies, the only way that could have worked is if the OP's server were exporting in both.

And, yes, there's some symlink magic going on.
 
Regards,
Kent
Reply


Messages In This Thread
My Library is not updating - by chriskchambers - 09-16-2018, 07:19 PM
RE: My Library is not updating - by Tim Curtis - 09-16-2018, 08:17 PM
RE: My Library is not updating - by Tim Curtis - 09-18-2018, 09:10 PM
RE: My Library is not updating - by sintax - 04-19-2019, 05:32 AM
RE: My Library is not updating - by TheOldPresbyope - 04-19-2019, 01:15 PM
RE: My Library is not updating - by sintax - 04-20-2019, 05:15 AM

Forum Jump: