Thank you for your donation!


4.3 Inplace update
#1
Hi,

Completed the 4.3 inplace update but hit a couple of problems.

Tried to turn on the new back drop display option but the yes / no options in the drop down were missing so I rebooted.

When the system is rebooting I get the following message up 7 times -   MPD Error SyntaxError: Unexpected end of JSON input.

The system seems to complete the boot process but doesn't display the backup image of the current album playing.

Tried powering down the system but it made no difference.

Any ideas?

Cheers,

David.
Reply
#2
In the Customization Menu.... once you have turned on the Background album art image then adjust the Alpha Blend and it will show ... try 55% for starters...
Reply
#3
(10-20-2018, 09:25 AM)DRONE7 Wrote: In the Customization Menu.... once you have turned on the Background album art image then adjust the Alpha Blend and it will show ... try 55% for starters...

Many thanks for the reply and it work!

Now I just need to sort out the MPD issue!

Cheers.
Reply
#4
(10-20-2018, 08:04 AM)mayburyds Wrote: Hi,

Completed the 4.3 inplace update but hit a couple of problems.

Tried to turn on the new back drop display option but the yes / no options in the drop down were missing so I rebooted.

When the system is rebooting I get the following message up 7 times -   MPD Error SyntaxError: Unexpected end of JSON input.

The system seems to complete the boot process but doesn't display the backup image of the current album playing.

Tried powering down the system but it made no difference.

Any ideas?

Cheers,

David.

Post the output from the command below and I'll have a look.

Code:
moodelog
Reply
#5
(10-20-2018, 10:30 AM)Tim Curtis Wrote:
(10-20-2018, 08:04 AM)mayburyds Wrote: Hi,

Completed the 4.3 inplace update but hit a couple of problems.

Tried to turn on the new back drop display option but the yes / no options in the drop down were missing so I rebooted.

When the system is rebooting I get the following message up 7 times -   MPD Error SyntaxError: Unexpected end of JSON input.

The system seems to complete the boot process but doesn't display the backup image of the current album playing.

Tried powering down the system but it made no difference.

Any ideas?

Cheers,

David.

Post the output from the command below and I'll have a look.

Code:
moodelog

As requested.

Thanks.

pi@moode:~ $ moodelog
20181020 111739 worker: - Start
20181020 111739 worker: Successfully daemonized
20181020 111739 worker: Integrity check ok
20181020 111740 worker: Session loaded
20181020 111740 worker: Debug logging (off)
20181020 111740 worker: - Platform
20181020 111745 worker: Host (moode)
20181020 111745 worker: Hdwr (Pi-3B 1GB v1.2)
20181020 111745 worker: Arch (armv7l)
20181020 111745 worker: Rasp (9.4)
20181020 111745 worker: Kver (4.14.76-v7+)
20181020 111745 worker: Ktyp (Standard)
20181020 111745 worker: Gov  (performance)
20181020 111745 worker: Rel  (Moode 4.3 2018-09-27)
20181020 111745 worker: Upd  (2018-10-19)
20181020 111745 worker: MPD  (0.20.20)
20181020 111745 worker: USB boot not enabled yet
20181020 111745 worker: File system expanded
20181020 111745 worker: HDMI port off
20181020 111745 worker: File check ok
20181020 111745 worker: - Network
20181020 111745 worker: eth0 exists
20181020 111745 worker: eth0 wait 0 for IP address
20181020 111748 worker: eth0 wait 1 for IP address
20181020 111751 worker: eth0 wait 2 for IP address
20181020 111754 worker: eth0 wait 3 for IP address
20181020 111756 command/moode: Connection to MPD failed
20181020 111757 worker: eth0 wait 4 for IP address
20181020 111810 worker: eth0 wait 5 for IP address
20181020 111811 command/moode: Connection to MPD failed
20181020 111813 worker: eth0 wait 6 for IP address
20181020 111816 command/moode: Connection to MPD failed
20181020 111816 worker: eth0 wait 7 for IP address
20181020 111819 worker: eth0 wait 8 for IP address
20181020 111821 command/moode: Connection to MPD failed
20181020 111822 worker: eth0 wait 9 for IP address
20181020 111825 worker: eth0 address not assigned
20181020 111825 worker: wlan0 exists
20181020 111825 worker: wifi country (GB)
20181020 111825 worker: wlan0 trying SSID (Maybury-main)
20181020 111825 worker: wlan0 (192.168.1.132)
20181020 111825 worker: - Audio
20181020 111826 worker: ALSA outputs unmuted
20181020 111826 worker: ALSA card number (0)
20181020 111826 worker: Audio out (I2S audio device)
20181020 111826 worker: Audio dev (IQaudIO Pi-DAC PRO)
20181020 111826 worker: ALSA mixer name (Digital)
20181020 111826 worker: MPD volume control (hardware)
20181020 111826 worker: Hdwr volume controller exists
20181020 111826 worker: Chip options (Burr Brown PCM5242)
20181020 111826 worker: - Services
20181020 111826 worker: Reset renderer active
20181020 111826 command/moode: Connection to MPD failed
20181020 111828 worker: MPD started
20181020 111828 worker: MPD scheduler policy (time-share)
20181020 111828 worker: Configure MPD outputs
20181020 111828 worker: MPD output 1 ALSA default (on)
20181020 111828 worker: MPD output 2 ALSA crossfeed (off)
20181020 111828 worker: MPD output 3 ALSA parametric eq (off)
20181020 111828 worker: MPD output 4 ALSA graphic eq (off)
20181020 111828 worker: MPD output 5 ALSA bluetooth (off)
20181020 111828 worker: MPD crossfade (off)
20181020 111828 worker: Rotary encoder on (100 2 3 4 5)
20181020 111828 worker: Shellinabox SSH started
20181020 111828 worker: Bluetooth controller started
20181020 111833 worker: Bluetooth controller initialized
20181020 111833 worker: - Music sources
20181020 111833 worker: USB sources (none attached)
20181020 111835 worker: NAS sources (mountall initiated)
20181020 111835 worker: - Miscellaneous
20181020 111836 worker: Volume level (100) restored
20181020 111836 worker: Maintenance interval (21600)
20181020 111836 worker: Screen saver activation (Never)
20181020 111836 worker: Watchdog started
20181020 111836 worker: Ready
Reply
#6
Hi,

It took me some time to understand how it works. So nice.
[Image: s1spie.jpg]
Remy
Reply
#7
(10-20-2018, 10:41 AM)mayburyds Wrote:
(10-20-2018, 10:30 AM)Tim Curtis Wrote:
(10-20-2018, 08:04 AM)mayburyds Wrote: Hi,

Completed the 4.3 inplace update but hit a couple of problems.

Tried to turn on the new back drop display option but the yes / no options in the drop down were missing so I rebooted.

When the system is rebooting I get the following message up 7 times -   MPD Error SyntaxError: Unexpected end of JSON input.

The system seems to complete the boot process but doesn't display the backup image of the current album playing.

Tried powering down the system but it made no difference.

Any ideas?

Cheers,

David.

Post the output from the command below and I'll have a look.

Code:
moodelog

As requested.

Thanks.

pi@moode:~ $ moodelog
20181020 111739 worker: - Start
20181020 111739 worker: Successfully daemonized
20181020 111739 worker: Integrity check ok
20181020 111740 worker: Session loaded
20181020 111740 worker: Debug logging (off)
20181020 111740 worker: - Platform
20181020 111745 worker: Host (moode)
20181020 111745 worker: Hdwr (Pi-3B 1GB v1.2)
20181020 111745 worker: Arch (armv7l)
20181020 111745 worker: Rasp (9.4)
20181020 111745 worker: Kver (4.14.76-v7+)
20181020 111745 worker: Ktyp (Standard)
20181020 111745 worker: Gov  (performance)
20181020 111745 worker: Rel  (Moode 4.3 2018-09-27)
20181020 111745 worker: Upd  (2018-10-19)
20181020 111745 worker: MPD  (0.20.20)
20181020 111745 worker: USB boot not enabled yet
20181020 111745 worker: File system expanded
20181020 111745 worker: HDMI port off
20181020 111745 worker: File check ok
20181020 111745 worker: - Network
20181020 111745 worker: eth0 exists
20181020 111745 worker: eth0 wait 0 for IP address
20181020 111748 worker: eth0 wait 1 for IP address
20181020 111751 worker: eth0 wait 2 for IP address
20181020 111754 worker: eth0 wait 3 for IP address
20181020 111756 command/moode: Connection to MPD failed
20181020 111757 worker: eth0 wait 4 for IP address
20181020 111810 worker: eth0 wait 5 for IP address
20181020 111811 command/moode: Connection to MPD failed
20181020 111813 worker: eth0 wait 6 for IP address
20181020 111816 command/moode: Connection to MPD failed
20181020 111816 worker: eth0 wait 7 for IP address
20181020 111819 worker: eth0 wait 8 for IP address
20181020 111821 command/moode: Connection to MPD failed
20181020 111822 worker: eth0 wait 9 for IP address
20181020 111825 worker: eth0 address not assigned
20181020 111825 worker: wlan0 exists
20181020 111825 worker: wifi country (GB)
20181020 111825 worker: wlan0 trying SSID (Maybury-main)
20181020 111825 worker: wlan0 (192.168.1.132)
20181020 111825 worker: - Audio
20181020 111826 worker: ALSA outputs unmuted
20181020 111826 worker: ALSA card number (0)
20181020 111826 worker: Audio out (I2S audio device)
20181020 111826 worker: Audio dev (IQaudIO Pi-DAC PRO)
20181020 111826 worker: ALSA mixer name (Digital)
20181020 111826 worker: MPD volume control (hardware)
20181020 111826 worker: Hdwr volume controller exists
20181020 111826 worker: Chip options (Burr Brown PCM5242)
20181020 111826 worker: - Services
20181020 111826 worker: Reset renderer active
20181020 111826 command/moode: Connection to MPD failed
20181020 111828 worker: MPD started
20181020 111828 worker: MPD scheduler policy (time-share)
20181020 111828 worker: Configure MPD outputs
20181020 111828 worker: MPD output 1 ALSA default (on)
20181020 111828 worker: MPD output 2 ALSA crossfeed (off)
20181020 111828 worker: MPD output 3 ALSA parametric eq (off)
20181020 111828 worker: MPD output 4 ALSA graphic eq (off)
20181020 111828 worker: MPD output 5 ALSA bluetooth (off)
20181020 111828 worker: MPD crossfade (off)
20181020 111828 worker: Rotary encoder on (100 2 3 4 5)
20181020 111828 worker: Shellinabox SSH started
20181020 111828 worker: Bluetooth controller started
20181020 111833 worker: Bluetooth controller initialized
20181020 111833 worker: - Music sources
20181020 111833 worker: USB sources (none attached)
20181020 111835 worker: NAS sources (mountall initiated)
20181020 111835 worker: - Miscellaneous
20181020 111836 worker: Volume level (100) restored
20181020 111836 worker: Maintenance interval (21600)
20181020 111836 worker: Screen saver activation (Never)
20181020 111836 worker: Watchdog started
20181020 111836 worker: Ready

Since you are using WiFi connection "wlan0 (192.168.1.132)" there should not also be an Ethernet cable connected so open System config and set "Wait for eth0 address" to OFF to get rid of the "worker: eth0 wait 0 for IP address" messages.

Then reboot and clear/refresh your Browser cache while you have the Customize screen open.
Reply
#8
(10-20-2018, 10:43 AM)remy1961 Wrote: Hi,

It took me some time to understand how it works. So nice.
[Image: s1spie.jpg]
Remy

Cred to @swizzle for this nice feature :-)

Is that Safari Browser? If so then you can replace the white scrollbars with nice looking overlay scrollbars. Open System preferences, General and set "Show scroll bars" to "Automatically based on mouse or trackpad"

-Tim
Reply
#9
(10-20-2018, 11:09 AM)Tim Curtis Wrote:
(10-20-2018, 10:41 AM)mayburyds Wrote:
(10-20-2018, 10:30 AM)Tim Curtis Wrote:
(10-20-2018, 08:04 AM)mayburyds Wrote: Hi,

Completed the 4.3 inplace update but hit a couple of problems.

Tried to turn on the new back drop display option but the yes / no options in the drop down were missing so I rebooted.

When the system is rebooting I get the following message up 7 times -   MPD Error SyntaxError: Unexpected end of JSON input.

The system seems to complete the boot process but doesn't display the backup image of the current album playing.

Tried powering down the system but it made no difference.

Any ideas?

Cheers,

David.

Post the output from the command below and I'll have a look.

Code:
moodelog

As requested.

Thanks.

pi@moode:~ $ moodelog
20181020 111739 worker: - Start
20181020 111739 worker: Successfully daemonized
20181020 111739 worker: Integrity check ok
20181020 111740 worker: Session loaded
20181020 111740 worker: Debug logging (off)
20181020 111740 worker: - Platform
20181020 111745 worker: Host (moode)
20181020 111745 worker: Hdwr (Pi-3B 1GB v1.2)
20181020 111745 worker: Arch (armv7l)
20181020 111745 worker: Rasp (9.4)
20181020 111745 worker: Kver (4.14.76-v7+)
20181020 111745 worker: Ktyp (Standard)
20181020 111745 worker: Gov  (performance)
20181020 111745 worker: Rel  (Moode 4.3 2018-09-27)
20181020 111745 worker: Upd  (2018-10-19)
20181020 111745 worker: MPD  (0.20.20)
20181020 111745 worker: USB boot not enabled yet
20181020 111745 worker: File system expanded
20181020 111745 worker: HDMI port off
20181020 111745 worker: File check ok
20181020 111745 worker: - Network
20181020 111745 worker: eth0 exists
20181020 111745 worker: eth0 wait 0 for IP address
20181020 111748 worker: eth0 wait 1 for IP address
20181020 111751 worker: eth0 wait 2 for IP address
20181020 111754 worker: eth0 wait 3 for IP address
20181020 111756 command/moode: Connection to MPD failed
20181020 111757 worker: eth0 wait 4 for IP address
20181020 111810 worker: eth0 wait 5 for IP address
20181020 111811 command/moode: Connection to MPD failed
20181020 111813 worker: eth0 wait 6 for IP address
20181020 111816 command/moode: Connection to MPD failed
20181020 111816 worker: eth0 wait 7 for IP address
20181020 111819 worker: eth0 wait 8 for IP address
20181020 111821 command/moode: Connection to MPD failed
20181020 111822 worker: eth0 wait 9 for IP address
20181020 111825 worker: eth0 address not assigned
20181020 111825 worker: wlan0 exists
20181020 111825 worker: wifi country (GB)
20181020 111825 worker: wlan0 trying SSID (Maybury-main)
20181020 111825 worker: wlan0 (192.168.1.132)
20181020 111825 worker: - Audio
20181020 111826 worker: ALSA outputs unmuted
20181020 111826 worker: ALSA card number (0)
20181020 111826 worker: Audio out (I2S audio device)
20181020 111826 worker: Audio dev (IQaudIO Pi-DAC PRO)
20181020 111826 worker: ALSA mixer name (Digital)
20181020 111826 worker: MPD volume control (hardware)
20181020 111826 worker: Hdwr volume controller exists
20181020 111826 worker: Chip options (Burr Brown PCM5242)
20181020 111826 worker: - Services
20181020 111826 worker: Reset renderer active
20181020 111826 command/moode: Connection to MPD failed
20181020 111828 worker: MPD started
20181020 111828 worker: MPD scheduler policy (time-share)
20181020 111828 worker: Configure MPD outputs
20181020 111828 worker: MPD output 1 ALSA default (on)
20181020 111828 worker: MPD output 2 ALSA crossfeed (off)
20181020 111828 worker: MPD output 3 ALSA parametric eq (off)
20181020 111828 worker: MPD output 4 ALSA graphic eq (off)
20181020 111828 worker: MPD output 5 ALSA bluetooth (off)
20181020 111828 worker: MPD crossfade (off)
20181020 111828 worker: Rotary encoder on (100 2 3 4 5)
20181020 111828 worker: Shellinabox SSH started
20181020 111828 worker: Bluetooth controller started
20181020 111833 worker: Bluetooth controller initialized
20181020 111833 worker: - Music sources
20181020 111833 worker: USB sources (none attached)
20181020 111835 worker: NAS sources (mountall initiated)
20181020 111835 worker: - Miscellaneous
20181020 111836 worker: Volume level (100) restored
20181020 111836 worker: Maintenance interval (21600)
20181020 111836 worker: Screen saver activation (Never)
20181020 111836 worker: Watchdog started
20181020 111836 worker: Ready

Since you are using WiFi connection "wlan0 (192.168.1.132)" there should not also be an Ethernet cable connected so open System config and set "Wait for eth0 address" to OFF to get rid of the "worker: eth0 wait 0 for IP address" messages.

Then reboot and clear/refresh your Browser cache while you have the Customize screen open.
Tim,

There isn't a cable attached but the option to use the ethernet port is still on. It was like that before the update and I never had any issues.

Did as suggested and all is well now, thanks!

One other thing I have found is that the REMOVE button to remove an image back drop doesn't remove the image.

Cheers,

David.
Reply
#10
There have been some reports from the Test Team of oddness with the CHOOSE/REMOVE buttons but nothing that I've been able to reliably reproduce.

If the image is in fact still present then there will be a file named /var/local/www/imagesw/bgimage.jpg

Code:
pi@rp3:~ $ ls -l /var/local/www/imagesw
total 608
-rw-r--r-- 1 root root  578947 Oct 18 20:39 bgimage.jpg
drwxr-xr-x 2 root root   24576 Oct 12 12:28 thmcache
-rwxr-xr-x 1 root staff    320 Oct 19 12:57 thumb.svg
-rwxr-xr-x 1 root staff    322 Oct 19 12:57 thumb-w.svg
drwxr-xr-x 2 root staff   4096 Jul  8 11:22 toggle
Reply


Forum Jump: