Thank you for your donation!


Instruction Guide 128x64 OLED with Song Status and Spectrum Display on Raspberry Pi
I managed to come up with an ALSA configuration file for Moode that creates a duplicate of the hw:0,0 stream (any hw: stream) for mpd_oled to read for the spectrum analyser. This method should work with all renderers (e.g. Spotify), but I have only tested with MPD and bluetooth.

   https://github.com/antiprism/mpd_oled/is...-567146826

If it is possible to get this working reliably, for different Moode installations, then this method also has the advantage that it removes the need to patch Moode during the mpd_oled installation.

Adrian.
Reply
Hi Adrian, I've just had a little time to re-case a Pi I had awaiting finishing....as it has been on the shelf for some time I re-imaged for the latest moode release and followed your most recent set-up instructions....

My bad, I failed to note that I had set the Architecture option to 64-bit in the moode system config page and spent quite some time troubleshooting...
All working now after I reverted to the 32-bit kernel.

Suggestion....perhaps add a note to your moode install instructions that it is for for the 32-bit kernel not the experimental 64-bit kernel ... Wink 

Cheers,
Bob.

Reply
Hi Bob

Thanks for the heads up. I have put a note in the install instructions for now but, as of a couple of days ago, I now have a Pi 4 (hooray, no more developing on a Pi Zero!)), and so I can look into this when I have a chance.


Adrian.
Reply
I'm impressed...
a) that you have been developing and supporting your wondrous oled screen on a Pi Zero !!!! Wow !!
b) that you've taken the nuclear option from a Zero to a Pi4 !!

Best Wishes for the coming year !

Cheers, Bob

Reply
I just updated from Moode 6.4.0 with the mpd_oled install instructions applied, to Moode 6.4.1. The update completed correctly, with mpd_oled still working except for the spectrum display. The fix is to reapply the Moode system patch from the mpd_oled directory

Code:
sudo patch -d/ -p0 -N < moode_mpd_fifo.patch

And restart the machine.

Adrian.
Reply
I just did a clean install of Moode 6.4.1 and then went through the installation instructions for mpd_oled step by step.
All seemed ok as far as mpd_oled is concerned, but it (or something) seems to have broken Moode.

The log now shows:

20200127 140620 worker: -- Start
20200127 140620 worker: Successfully daemonized
20200127 140620 worker: Integrity check (failed:1)
20200127 140620 worker: Exited
20200127 140749 moode.php: MPD connect failed: cmd=(lsinfo)
20200127 140750 moode.php: MPD connect failed: cmd=(lsinfo)

The screen is working, but Moode is broken....
Can you perhaps shed your light on this?
Reply
(12-18-2019, 06:55 PM)adrii Wrote: I managed to come up with an ALSA configuration file for Moode that creates a duplicate of the hw:0,0 stream (any hw: stream) for mpd_oled to read for the spectrum analyser. This method should work with all renderers (e.g. Spotify), but I have only tested with MPD and bluetooth.

   https://github.com/antiprism/mpd_oled/is...-567146826

If it is possible to get this working reliably, for different Moode installations, then this method also has the advantage that it removes the need to patch Moode during the mpd_oled installation.

Adrian.

I just did another fresh install of Moode 6.4.1 and used this method for mpd_oled.
All works fine now and no patching needed!!
Reply
I spoke too soon; i'm getting the following error:

Failed to open "ALSA default" (alsa); Error opening ALSA device "hw:1,0"; snd_pcm_hw_params_set_buffer_time_near() failed: Invalid argument
Reply
Right, it has to do with the loading of the snd-aloop module.
If i load it manually and then start mpd_oled all is fine.

If i put snd-aloop in the etc/modules and reboot, then in moode mpd config section - device type - use usb audio device is no longer there and audio playback does not work and the error i posted earlier is displayed.

If remove snd-aloop from /etc/modules, but edit rc.local to load snd-aloop, then start moode, then start mpd_oled it all works fine after a reboot!
Reply
Hi JB

It sounds like the sound modules are loading in the wrong order, and so the loopback has device index 0 and your USB sound card has index 1, with Moode expecting your sound card to have index 0. With your changes you are starting the modules in different places, and the loopback driver is started later and has index 1.


The usual way to fix this is to specify the index number as a module option. E.g. create a file /etc/modprobe.d/alsa-base.conf with the following line

Code:
options snd-aloop index=1

Or, I believe an index of -2 means don't make this the primary device, which might be better.

I'll review the mpd_oled installation instructions against a clean install of Moode 6.4.1

Adrian.
Reply


Forum Jump: