Thank you for your donation!


Playlist skipping tracks
#11
(04-24-2018, 02:32 PM)mik_mik Wrote: Do you have raspberry pi 3+ 2018?

Yes.
Reply
#12
The symptom suggests MPD unable to successfully connect to the URL which will result in skipping to the next item in the playlist. I think Tidal and these other music services also encode an expiration time in each track which cause the URL to become dead after that time limit has expired.

Either way, examine the MPD log for errors associated with the tracks that are skipped.
cat /var/log/mpd/log

-Tim
Reply
#13
(04-24-2018, 04:03 PM)Tim Curtis Wrote: The symptom suggests MPD unable to successfully connect to the URL which will result in skipping to the next item in the playlist. I think Tidal and these other music services also encode an expiration time in each track which cause the URL to become dead after that time limit has expired.

Either way, examine the MPD log for errors associated with the tracks that are skipped.
cat /var/log/mpd/log

-Tim

Thanks for the pointer Tim. I can see two types of error in the log:

Code:
exception: nested: CURL failed: The requested URL returned error: 500 TIDAL: Session does not have playback privileges

exception: Failed to decode http://10.0.0.10:57645/proxy/tidal/DA1CF661ECF663D74ABF1A18EEFD22C5.flac

These repeat throughout. I'll tail the log and try to figure out which one relates to the tracks skipping.
Reply
#14
This is the error in the log when a track is skipped:

exception: CURL failed: Recv failure: Connection reset by peer
Reply
#15
(04-24-2018, 11:11 AM)andi123 Wrote: Hi,

I've recently setup Moode Audio on a Raspberry Pi 3 and use BubbleUPNP to connect. I also have Tidal setup, and share direct from Tidal to Bubble. It all works great except that tracks frequently get skipped. I see them listed in the playlist, but as soon as track one finishes it'll jump to track three (for example).

MPD is configured with the following:

[Image: moode.png]


I get no mid-track skips and tracks play immediately. Can anyone advise on why whole tracks randomly gets skipped?

Many thanks
Andy

Please try setting your buffer size to 2048 and try again.
Reply
#16
(05-14-2018, 08:58 PM)serverbaboon Wrote:
(04-24-2018, 11:11 AM)andi123 Wrote: Hi,

I've recently setup Moode Audio on a Raspberry Pi 3 and use BubbleUPNP to connect. I also have Tidal setup, and share direct from Tidal to Bubble. It all works great except that tracks frequently get skipped. I see them listed in the playlist, but as soon as track one finishes it'll jump to track three (for example).

MPD is configured with the following:

[Image: moode.png]


I get no mid-track skips and tracks play immediately. Can anyone advise on why whole tracks randomly gets skipped?

Many thanks
Andy

Please try setting your buffer size to 2048 and try again.

Hi serverbaboon,

Thanks for the suggestion. I'd stopped using Moode because of this issue. Coincidentally I completely reinstalled Moode yesterday, same RPi 3B, same USB WiFi dongle, but a faster SD card. Since then it's worked flawlessly with no skipping. In the past, it was only ever an issue with Tidal. Flac files on a local NAS didn't skip. Anyhow, I spent a few hours listening to Tidal last night and not one track skipped.

Thanks again
Andy
Reply
#17
How do I delete all all tracks listed in Playback playlist?


Attached Files Thumbnail(s)
   
Reply


Forum Jump: