Thank you for your donation!


Problem: SMB mount error 13
#1
SOLVED: "i've found thoses options are working: "vers=2.0,ro,dir_mode=0777,file_mode=0777""

Hello !

All of a sudden, my Moode audio refuse to connect back to my local share:
As far as i know: everything was OK till i updated my NAS: Thing is: everything else work perfectly after aswell:

I access My nas on windows with \\10.0.0.5\share\musique\Library

My kodi on a raspberry is working fine aswell.

i'm 100% sure of my credential -  wiche didn't changed and, therfore, should work :-)

I tried to create another user : NOK
tried to moutn another folder: NOK
tried to change options as suggested by moode audio:
Tried to change options:
vers=1.0,sec=ntlm,ro,dir_mode=0777,file_mode=0777
vers=1.0,sec=none,ro,dir_mode=0777,file_mode=0777

vers=2.0,sec=ntlm,ro,dir_mode=0777,file_mode=0777
vers=3.0,sec=ntlm,ro,dir_mode=0777,file_mode=0777
vers=2.0,sec=none,ro,dir_mode=0777,file_mode=0777
vers=3.0,sec=none,ro,dir_mode=0777,file_mode=0777

EDIT 1: This is working to mount: sudo mount -t cifs -o username=username //10.0.0.5/share/musique/Library /mnt/NAS and Moode start to scan folder

log:
20180601 153819 worker: - Start
20180601 153819 worker: Successfully daemonized
20180601 153819 worker: - Init
20180601 153819 worker: Session loaded
20180601 153819 worker: Debug logging (off)
20180601 153820 worker: Host (moode)
20180601 153820 worker: Hdwr (Pi-3B 1GB v1.2)
20180601 153820 worker: Arch (armv7l)
20180601 153820 worker: Rasp (9.4)
20180601 153820 worker: Kver (4.14.32-v7+)
20180601 153820 worker: Ktyp (Standard)
20180601 153820 worker: Gov  (performance)
20180601 153820 worker: Rel  (Moode 4.1 2018-04-02)
20180601 153820 worker: Upd  (None)
20180601 153820 worker: MPD  (0.20.18)
20180601 153820 worker: USB boot not enabled yet
20180601 153820 worker: File system expanded
20180601 153821 worker: HDMI port on
20180601 153821 worker: File check ok
20180601 153821 worker: - Network
20180601 153821 worker: eth0 exists
20180601 153821 worker: eth0 (10.0.0.11)
20180601 153821 worker: wlan0 does not exist
20180601 153821 worker: - Audio
20180601 153821 worker: ALSA outputs unmuted
20180601 153821 worker: Audio out (I2S audio device)
20180601 153821 worker: Audio dev (IQaudIO Pi-DAC+)
20180601 153821 worker: ALSA mixer name (Digital)
20180601 153821 worker: MPD volume control (hardware)
20180601 153821 worker: Hdwr volume controller exists
20180601 153822 worker: Chip options (Burr Brown PCM5122)
20180601 153822 worker: - Services
20180601 153824 worker: MPD started
20180601 153824 worker: MPD scheduler policy (time-share)
20180601 153824 worker: Configure MPD outputs
20180601 153824 worker: MPD output 1 ALSA default (off)
20180601 153824 worker: MPD output 2 ALSA crossfeed (off)
20180601 153824 worker: MPD output 3 ALSA parametric eq (off)
20180601 153824 worker: MPD output 4 ALSA graphic eq (on)
20180601 153824 worker: MPD output 5 ALSA bluetooth (off)
20180601 153824 worker: MPD crossfade (5 secs)
20180601 153824 worker: - Last
20180601 153824 worker: USB sources (none attached)
20180601 153824 wrk_sourcemount(): Mount error: (mount error(13): Permission denied
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs))
20180601 153824 worker: NAS sources (mountall initiated)
20180601 153824 worker: Volume level (30) restored
20180601 153824 worker: Auto-playing id (1)
20180601 153824 worker: Maintenance interval (21600)
20180601 153824 worker: Watchdog started
20180601 153824 worker: Ready
20180601 153941 worker: Job sourcecfg
20180601 153941 wrk_sourcemount(): Mount error: (mount error(13): Permission denied
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs))
20180601 154129 worker: Job sourcecfg
20180601 154130 wrk_sourcemount(): Mount error: (mount error(13): Permission denied
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs))
20180601 154151 worker: Job sourcecfg
20180601 154330 worker: Job sourcecfg
20180601 154330 wrk_sourcemount(): Mount error: (mount error(13): Permission denied
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs))
20180601 154345 worker: Job sourcecfg
20180601 154346 wrk_sourcemount(): Mount error: (mount error(13): Permission denied
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs))

Thanks for your help and suggestions! Angel
Reply
#2
Try removing the vers= and sec= params so u end up with the line below.

ro,dir_mode=0777,file_mode=0777
Enjoy the Music!
moodeaudio.org | Twitter Feed | Git Repo
Reply
#3
(06-01-2018, 03:09 PM)Tim Curtis Wrote: Try removing the vers= and sec= params so u end up with the line below.

ro,dir_mode=0777,file_mode=0777

Hello Tim, Thanks for your support:

In the between i've found thoses options are working: "vers=2.0,ro,dir_mode=0777,file_mode=0777"

Thanks for your work :-)
Reply
#4
I would actually set file_mode to:  file_mode=0644 or of really necessary file_mode=666.
(the numbers tell you this:  Position 0 1 2 3, whereby 1=rights for the file owner, 2 rights for the group that the owner is a member of, 3 everyone.
The value means:  4 = read access, 5 = read/execute access, 6 = read/write access, 7 = read/write/execute access).

Hendrik-Jan
Reply
#5
(06-03-2018, 10:12 AM)hjheins Wrote: I would actually set file_mode to:  file_mode=0644 or of really necessary file_mode=666.
(the numbers tell you this:  Position 0 1 2 3, whereby 1=rights for the file owner, 2 rights for the group that the owner is a member of, 3 everyone.
The value means:  4 = read access, 5 = read/execute access,  6 = read/write access, 7 = read/write/execute access).

Hendrik-Jan

Hello mate, thanks for your suggestion. My only problem was the share not mounting, so you're a bit late and off-topic :-)
Anyway, thoses values are default values, i understand you're worried about thoses rights but it doesen't matter in this case for me.
But, i tried, and 0644 broke access. switched back to 0777 as default suggest :-) Have you tried on your setup?
Reply
#6
Hi antipiot,  

I would agree that the response is not 100% ontopic, but not far off either, as the response is purely related to good system management and rights setting. To be honest, I am not sure why this would not work for you.

I use the same setting for cifs/smb.See here for a related post (not mode, but still Linux and cifs/smb)
Reply
#7
MPD requires read+execure on all music directories and their parent directories.
https://www.musicpd.org/doc/user/support.html

-Tim
Enjoy the Music!
moodeaudio.org | Twitter Feed | Git Repo
Reply


Forum Jump: