Thank you for your donation!


Configuring the kernel
#1
Hello to all.

Configuring the kernel in order to achieve the best DAC performance, in my case I use a Burr Brown PCM1794A DAC.
When choosing the parameters listed below, the software often crashes, both in version 3.8.4 and 4.1:

"Audio configuration":
devices
I2S - RPI-DAC audio device

"System changes":
Linux Kernel - Standard, Advanced LL, Advanced RT.
Latency level - 2 ms, 5 ms, 10 ms
Governor of the CPU: on request, performance
MPD - TS, FIFO, RR scheduler policy

Let me explain it better, I use a homemade DAC, based on 8 chips in parallel with Burr Brown PCM1794A and I2S. I have two options for the "I2s Audio Device" driver:
RPI-DAC or DDDAC1794NOS (the latter does not work on version 3.8.4)

When I try to change the settings described above, to evaluate the best quality, in both versions 3.8.4 and 4.1, something often does not work and I no longer have the analog output from the DAC.
In practice, the playback page does not work anymore, sometimes I can solve the crash by choosing the Linux - Standard kernel, but I often have to reinstall the program on the SD card.

In addition to the REBOOT with each modification, there is a sequence to be respected when changing the parameters described above, there is some incompatibility. Or it would be better to act on the program through SSH, to change these options, if this is the right way to do it, you need to know how and what you need to change in the program.

Thanks and greetings to everyone for their contribution to my problem.

Jon
Reply
#2
Ciao a tutti.
Silenzio assordante.
Ho scritto una cosa concettualmente sbagliata o l'inconveniente è successo solo a me e ai miei amici?
Grazie comunque.
Jon
Reply
#3
(06-07-2018, 10:43 PM)Gate45 Wrote: Ciao a tutti.
Silenzio assordante.
Ho scritto una cosa concettualmente sbagliata o l'inconveniente è successo solo a me e ai miei amici?
Grazie comunque.
Jon

Hi,

Please post in English :-)

-Tim
Enjoy the Music!
moodeaudio.org | Twitter Feed | Git Repo
Reply
#4
Hi TIM

I apologize, I did not realize that the result was incomprehensible.
Unfortunately I use "Google translator".
I will check the text more carefully.
Thanks for your answer.
Jon
Reply


Forum Jump: