Thank you for your donation!


Problem: RPi 4b connected via I2S to SABRE ES9038Q2M DAC POPs at manual Track Change
#1
Big Grin 
Hy all,
2 days ago i received my ordered SABRE DAC ES9038Q2M from China Smile


I just connected it to my RPi 4b via I2S running on Moode Audio 6.5.2
I disabled Volume control on MoodeAudio -> 0db
Alsos SoX resampling is disabled.

What should I say, generelly it works and sounds pretty smooth Big Grin

I Played some tracks, as I recogniced sometimes two short pops / cracks when I changed a song.
It is not happening always, but mostly.
It doesn´t depend on what soundformat or bitrate of the tracks.

When I play a Tracklist, there is never a  pop / crack between the songs, so I exlude a HW Problem.

I tried different Generic I2S or Audiofonic ES9038 Drivers, but this isn´t changing at this problem.


I googled a bit, and found out that there could be an issue that the I2S clock resets during the manual track change with MPD what produces this problem?!
Hopefully someone can help me out of this.


The Problem is when I listen with higher volume, the pop/crack are very loud, and sounds not good to my speakers!


Thanks to all....
Reply
#2
It's prolly a hardware issue having to do with lack of a pop/mute capability in the audio device. None of the cheap HAT DAC's that I'm aware of have pop supression circuit that kicks in when the audio stream to the DAC is closed / opened.

IIRC when MPD automatically transitions from one track to the next in a Playlist the audio output is left open unlike when manually changing tracks where the audio output is closed then opened.
Enjoy the Music!
moodeaudio.org | Twitter Feed | Git Repo
Reply
#3
Thanks Tim for response...

Since it must be a Hardware thing, i don´t understand that at manual song change it works some times, some times not, and following the playlist always?
Normally when there is a Hardware issue it should be always?


Is there a possiblity to workaround this issue?
Maybe to force the to let the audiochannel open as if he follows the playlist?

Thanks
Reply
#4
This particular issue "audio glitch on stop/start" has been around for years and I think a couple of players for example Squeezelight have a workaround option to always keep the audio output open but this prevents other applications from using it.

In moOde for example such an option in MPD would prevent the other audio renderers including Bluetooth, Airplay, Spotify from working. IIRC the MPD maintainer also holds that audio players should release the output when they are not playing to allow other applications to use it.

The automute feature in certain ESS DAC chips is programmable and works based on signal level and time. Allo's new Revolution DAC for example offers this as a user configurable option (see below). IIRC their Katana DAC uses it at a default setting but doesn't expose it as a user configurable setting. I've never had any MPD audio glitches on my Katana and same with the Revolution DAC that I'm starting to test.

Revolution DAC
POPMUTE: to eliminate the POP/clicks on PCM stop/start/sample rate change . Mute duration can be customized.
0 – disabled, 1-5 is 20-100msec. (default 3)
Enjoy the Music!
moodeaudio.org | Twitter Feed | Git Repo
Reply
#5
Thanks Tim

So you mean they implemented the automute feature in their "Driver" or custom "Firmware"?

I just saw in the ES9038Q2M datasheet, that they only support the automute feature with PCM and SPDIF, but no in DSD mode.
so at least they also "must" have pops in DSD mode, if they have not an additional solution?

But again, it is strange that I don´t have it always, just somtimes... Maybe the chinese board supports it to, but it works not that good or always?

Maybe someone else has experience with this board on a RPI?:

https://de.aliexpress.com/item/329673938...4c4dxlfTUw


Thanks
Reply
#6
(07-18-2020, 02:19 PM)AudioFool77 Wrote: Thanks Tim

So you mean they implemented the automute feature in their "Driver" or custom "Firmware"?

Check out this post  and its followup from the designer of the Revolution on the Audio Science Review forum. BTW this ASR Forum thread is the only place I've found a link to the Revolution "manual" (you'd think it would be on the Allo site.)

Regards,
Kent
Reply
#7
(07-18-2020, 02:19 PM)AudioFool77 Wrote: Thanks Tim

So you mean they implemented the automute feature in their "Driver" or custom "Firmware"?

I just saw in the ES9038Q2M datasheet, that they only support the automute feature with PCM and SPDIF, but no in DSD mode.
so at least they also "must" have pops in DSD mode, if they have not an additional solution?

But again, it is strange that I don´t have it always, just somtimes... Maybe the chinese board supports it to, but it works not that good or always?

Maybe someone else has experience with this board on a RPI?:

https://de.aliexpress.com/item/329673938...4c4dxlfTUw


Thanks

I've never experienced audio glitches with DSD/DoP with either Katana or Revolution.

ESS automute is a feature included in the 9038 DAC chip itself. Providing access to it would be a function of the firmware in the audio device. If the feature were also exposed to Linux ALSA as a configurable option it would be implemented in the device driver which would communicate with the firmware to read/write the setting. The Revolution DAC only exposes the ESS chip features via a hardware front panel joystick and OLED display. The exception is the nice 32-bit low distortion volume control in the ESS chip. Thats accessible via ALSA as a mixer named "Revolution" and in turn can be set in moOde MPD Config as Hardware volume :-)
Enjoy the Music!
moodeaudio.org | Twitter Feed | Git Repo
Reply
#8
Hmm, since I have none of this two boards, this will not bring me further, right?

I couldn´t find a documented or hidden way to check or set the automute setting on the sabre chip, for my mentioned board:
[Image: HTB1R0B6aOzxK1RjSspjq6AS.pXa8.jpg]

unfortunately there is always a hook... would be too nice when all works out of the box..


thanks all
Reply
#9
Hi, I'll also add that this is a DAC hardware issue.
Basically when switching to different sample rates the DAC has to resync the i2s clock signal with the source, if the DAC can't do this without making nasty jitter noise it's the sign of a poorly designed DAC.

If your DAC has a USB interface try that, as USB is a asynchronous data interface jitter issues are less likely. Alternatively you could enable resampling so that the DAC always runs at the same sample rate.
Reply
#10
As @vinn says:

<< If your DAC has a USB interface try that, as USB is a asynchronous data interface jitter issues are less likely. Alternatively you could enable resampling so that the DAC always runs at the same sample rate. >>

There's a hefty thread on DIYAudio.com regarding ES9038Q2M DAC boards... The discussion and modifications are mostly geared towards the electronic hardware improvement but you can always ask for help there:

https://www.diyaudio.com/forums/digital-...board.html
Reply


Forum Jump: