Thank you for your donation!


Solved: Adafruit Speaker Bonnet issues
#1
I've just been setting up moOde on a Pi 3A+ with an adafruit speakerbonnet to bring an old dead radio back to life.

Initially I had a problem where starting/stopping audio (and switching stations/tracks) would cause alarmingly loud popping, and sometimes even cause the Pi to completely power off. This was solved by following adafruit's instructions (here: https://learn.adafruit.com/adafruit-spea...y-pi-usage) to install a service to continuously play back silent audio.

Once this was installed, speakertest still worked (and no longer popped) but moOde always produces the following error when trying to start playback:

Failed to open "ALSA default" (alsa); Failed to open ALSA device "hw:0,0": Device or resource busy

I've determined that this can be fixed by removing the "device hw:0,0" line from the "ALSA default" audio_output section in /etc/mpd.conf and restarting MPD.

This is great, except that every time I restart the system, mpd.conf seems to get regenerated complete with the unwanted "device hw:0,0" line.

Is there a way to stop this from happening? I'm not sure if there's something in my configuration that leads to this line being added. My /etc/asound.conf is as follows:


Code:
pcm.hifiberry {
 type hw card 0
}

pcm.!default {
 type plug
 slave.pcm "dmixer"
}

pcm.dmixer {
 type dmix
 ipc_key 1024
 ipc_perm 0666
 slave {
   pcm "hifiberry"
   channels 2
 }
}

ctl.dmixer {
 type hw
 card 0
}

Thanks! Really enjoying using moOde, btw. Think I am definitely going to be switching over from Volumio on my other systems  Smile
Reply
#2
I've found a fix for this issue. A little hacky, but it works for now Wink 

In /var/www/inc/playerlib.php in updMpdConf, I've changed the following line in the section headed //ALSA local (outputs 1 - 5):

from:
Code:
               "name \"ALSA default\"\n" . "device \"hw:" . $device . ",0\"\n",

to:
Code:
               "name \"ALSA default\"\n" . "#device \"hw:" . $device . ",0\"\n",
Reply


Forum Jump: