Thank you for your donation!

Hifiberry DAC2 Pro Headphone output
I have Hifiberry DAC2 Pro card connected to Raspberry Pi 4 4GB running Moode 7.0.1. Since this device is not present in I2S list I choose DAC+ Pro basing on this. It works great, but I don't get any sound from it's integrated headphone output. I suspect it's volume is just set to 0 as it uses different mixer. Is it possible in Moode UI to change this volume to test this theory?
I tried alsamixer. There is a headphone mixer for this DAC but increasing volume and muting/unmuting have no effect. Any ideas?
In the absence of a driver especially for this board, the headphone socket is unlikely to be available in moOde. The headphone output will be on another audio device that isn't exposed to moOde through the DAC+ Pro driver.
I am also using HiFiBerry DAC2 Pro (with a Pi 3B) and the headphone jack works. I don't recall making any config changes except for selecting Dac+ Pro followed by a restart.

BTW, left-right is switched, for headphones.

Here are some of my settings -- hope this is of use:

A U D I O   P A R A M E T E R S

Audio device = HiFiBerry DAC+ Pro
Interface = I2S
Mixer name = Digital
Hardware mixer = Yes
Max ALSA volume = 100
Max MPD volume = 100
Volume step limit = 10
Display dB volume = Off
Audio source = Local
Output device = Local
Resume MPD = No
Volume knob = 33
Volume mute = Unmuted
Saved MPD vol = 0
Preamp volume = 0
ALSA version = 1.1.8-1+rpt1
SoX version = 0.1.2-3

M P D   S E T T I N G S

Version = 0.22.3_p0x3
Volume mixer = hardware
ALSA device = hw:0
SoX resampling = disabled
Selective resampling = disabled
SoX quality = high
SoX multithreading = off
DSD over PCM (DoP) = no
Replaygain = off
Replaygain preamp = 0
Volume normalization = No
Audio buffer = 4 (MB)
Output buffer size = 128 (MB)
Max playlist items = 16384
Input cache = Disabled
Thank you very much for info and your settings. When I'm home I'll compare them with mine.
OK, so the settings are mostly the same, but I found something strange. I get the sound from jack output when I boot the rpi with headphones connected. Then if I disconnect and reconnect there is no sound from headphones, but the RCA output plays normally all the time. If I start the Raspberry with headphones disconnected and connect them later there is nothing I can do to make them play. The only way is to start with them connected. I even tried running HifiberryOS and the situation is the same, so I'll contact Hifiberry on their forum and see if they can shed some light on this.

Forum Jump: