Thank you for your donation!


Solved: High CPU usage on moode website
#1
For a long time, my processor is working at its maximum when I turn on the moode page. I always have a new firefox beta. I also checked on chromium. What could be the reason? moode 7.1 debian buster
Reply
#2
As you've not given detail of your equipment the only answers one can give is...

a) the library being rendered in the browser is particularly large
b) the device running the web browser is very slow
c) a combination of a & b
Reply
#3
(03-27-2021, 10:23 PM)vinnn Wrote: As you've not given detail of your equipment the only answers one can give is...

a) the library being rendered in the browser is particularly large
b) the device running the web browser is very slow
c) a combination of a & b

the load is when the sound is playing and the clock counts down the track. When I make a pause or nothing is playing and the clock is off, there is no cpu load
   
Reply
#4
Well that is some relatively ancient hardware which could be easily overwhelmed by a modern web browser.

I can only guess that Firefox is using so much CPU time to render the page because the Intel 965 GME graphics processor (or the Mesa driver driving it) isn't able to do the hardware accelerated compositing that is a standard feature on most modern computers. Simple effects like opacity and composite layers could be problemmatic. A smartphone would likely be faster.
Reply
#5
is it possible to somehow disable all animations on the site?
Reply
#6
You'd probably be better off using a desktop mpd client for Linux such as gmpc or xfmpc, controlling Moode's mpd daemon from that.
Alternatively use a more modern device.
Reply
#7
(03-28-2021, 03:49 PM)vinnn Wrote: You'd probably be better off using a desktop mpd client for Linux such as gmpc or xfmpc, controlling Moode's mpd daemon from that.  
Alternatively use a more modern device.

thx
Reply


Forum Jump: